Jump to content

Recommended Posts

19 hours ago, xr500user said:

are you sure it's not just because it's using a self-signed ssl certificate (still works, but not verified)?

Is there an option when you see that message to go to Advanced, and Confirm security exception and proceed to the website anyway..? Same for chrome.

If it's a real ssl cert it may have just expired (on the actual routerlogin.net domain)

You could try https://192.168.1.1/  and confirm the exception there, it may work.

I tried this in Firefox a while back, it worked, but then it got stuck on https and always wanted to use https with that message when going to 192.168.1.1, I had to disable force https in firefox to get back into it without https.  I previously reported that there is no option in the firmware to tick "Always use SSL connection for remote management" but firefox seems to always want to use ssl after you do it once. Popping a similar message.

It would be nice to always use ssl, but without that message, but true ssl certs cost money, and it seems netgear doesn't want to spend for that, along with fixing all the issues that need to be addressed in a timely manner it seems

You should not get the warning at all, it should just lead you to the login, this happens on other Netgear routers as well so needs to be fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×