Jump to content
dpk_ydv

Cloudflare WARP Hybrid VPN not working

Recommended Posts

Hello, 

I generated a Wireguard VPN profile using wgcf for cloudflare WARP VPN, but the Hybrid VPN fails to connect. It says no VPN configured even after I paste the contents of the config file. 

This is an unofficial method of using WARP, since cloudflare does not provide any config files, but I've got WARP to work on my OpenWRT router and on my macbook using the wireguard application through config file.

Share this post


Link to post
Share on other sites

Is there any authentication required for WARP? I haven't played around with it myself yet. Often times these sorts of things don't work with Hybrid VPN if there's no authentication.

Share this post


Link to post
Share on other sites
50 minutes ago, dpk_ydv said:

The only authentication is private key and public key, which is part of the config. 

OK, can you provide a screenshot of the error you're seeing? Can you also link any documentation you followed for generating the Wireguard file?

Share this post


Link to post
Share on other sites

Alright I've looked into this some more, it's an issue with Hybrid VPN.

There's two issues, the version of WireGuard Hybrid VPN uses doesn't accept some of the parameters in the WireGuard conf files generated by wgcf. While looking into this, we also found a bug in how we validate the config files, so thank you for that!

I've passed this on to the dev and he's going to fix this when he gets a chance.

Share this post


Link to post
Share on other sites

Thanks for acknowledging.

This is best guide I've found to get the config file and setup Cloudflare WARP.  

I also a question if there have been any QOS algorithm changes in the recent update? The QOS gives me better results now on dslreports, and I dont even have to throttle my bandwidth much like before. 

I would like to request a feature. Could you please implement more options to deal with ipv6? The ones I am interested in are IPv6 passthrough and IPV6 DHCP relay. my ISP provides /64 PD, and so to get routable IPv6 on my LAN clients, I need something like ipv6 relay. This is a feature on OpenWRT just for reference. 

Share this post


Link to post
Share on other sites

Thanks for that! No algorithm changes, just a lot of fixes and improvements to improve the stability of the router and that's presenting itself in your QoS results. That is something that has been requested before and we are looking into it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...