Jump to content
Netduma Liam

NEW R2 FIRMWARE: 3.0.394

Recommended Posts

17 hours ago, John213 said:

Hi again!

It's something wrong with down speed on .394 fw. I  can't pass 500 mbps on R2 while my ISP Router does 940 mbps so easy. Using vlan with ppoe and tested without ticked QOS.

 

 

 

How are you testing the speeds? Through connection benchmark or through a third party speedtest like speedtest.net? Can you run both and compare the results?

10 hours ago, johnnytran said:

Just wondering is there an explanation of the different options for traffic prioritization? I remember the earlier firmware versions had no option to select gaming/voice, video, normal or apply to WAN.

Can we get an explanation of what each one does? I used to get a nice connection with the old firmware so just want to recreate it with the new one, not sure which option to select and whether to apply it to WAN. I was trying a combination of them all yesterday and can't seem to get it working how it used to.

I'd like to avoid going back to the old firmware if  can recreate whatever setting was used on those with the new firmware

Use gaming/voice for Wi-Fi and normal for wired. We need to make this clearer, I know! Apply to WAN is entirely optional to be honest, we can't measure how well it works as it just appends a priority flag to your important traffic when it's sent upstream. There's no harm in applying it, it can only make a positive difference.

10 hours ago, HANDSOME KING said:

My Ping Heatmap has been fixed and is currently working. Good job guys, this new firmware on the R2 is PERFECTION!

Nice, glad you're enjoying it!

Share this post


Link to post
Share on other sites
20 minutes ago, John213 said:

Some screenshots with my ISP and R2 routers.

If you have the ISP router handle PPPoE/VLAN does the R2 get higher speeds? Also disable the protection options in WAN Settings, that can boost the speeds a little.

Share this post


Link to post
Share on other sites

Yep. When my R2 is behind ISP, it runs with approximately 850 mbps. So it seems like it's problem with vlans.

Share this post


Link to post
Share on other sites
6 minutes ago, John213 said:

Yep. When my R2 is behind ISP, it runs with approximately 850 mbps. So it seems like it's problem with vlans.

Thanks for confirming, I'll pass this onto the team and I'd recommend you stay with that configuration so you can get the higher speeds

Share this post


Link to post
Share on other sites
On 11/20/2021 at 7:57 PM, Deng said:

I did the factory reset of course :)

DFS channels are not selectable after you reboot the router.

I have replicated the same issue:
if the router is turned off or rebooted (tried both) the choice of 5Ghz channels goes back to the original UNII-1 ones (36, 40, 44, 48), and if a higher one had been selected (and was working fine) earlier, the WiFi just stops working until it is set to one of them.
The full channel selection does come back after another factory reset, but now I am fearful of turning it off, as re-inputting all the configuration is quite tedious :)

On this last point (restoring settings), a useful feature would be saving an arbitrary selection of settings (e.g. WiFi settings, DHCP, port forwardings, ad-blocker lists, device names, ...) to a file for a quick re-application after factory reset.

Share this post


Link to post
Share on other sites
41 minutes ago, D_L said:

I have replicated the same issue:
if the router is turned off or rebooted (tried both) the choice of 5Ghz channels goes back to the original UNII-1 ones (36, 40, 44, 48), and if a higher one had been selected (and was working fine) earlier, the WiFi just stops working until it is set to one of them.
The full channel selection does come back after another factory reset, but now I am fearful of turning it off, as re-inputting all the configuration is quite tedious :)

On this last point (restoring settings), a useful feature would be saving an arbitrary selection of settings (e.g. WiFi settings, DHCP, port forwardings, ad-blocker lists, device names, ...) to a file for a quick re-application after factory reset.

Wasn't aware the WiFi stopped working if the channel was set to DFS prior to a reboot, that explains a lot, thank you, will pass that onto the team.

That has been suggested before so will likely be implemented in the future.

Share this post


Link to post
Share on other sites

I'm having the same issue @John213 is having with the download speed not reaching 900mbps. I''ve also disabled [ticked] QoS completely. This is the speedtest with it disabled after factory reset twice to ensure no leftovers from previous firmware. I've disabled both 'Protection' Options in WAN.

175694456_Webcapture_23-11-2021_214151_192_168_77.1.thumb.jpeg.2cb499de59089c951d24f93c435f7cf7.jpeg

Share this post


Link to post
Share on other sites
5 hours ago, TrayDay said:

I'm having the same issue @John213 is having with the download speed not reaching 900mbps. I''ve also disabled [ticked] QoS completely. This is the speedtest with it disabled after factory reset twice to ensure no leftovers from previous firmware. I've disabled both 'Protection' Options in WAN.

Are the speeds this low if you run a speedtest from speedtest.net for example? Are you using VLAN ID, PPPoE or DHCP identifiers at all?

Share this post


Link to post
Share on other sites

New wireguard settings aren't saving @Netduma Fraser @Netduma Liam

 

[Interface]
PrivateKey = (removed)
Address = 172.16.0.2/32
Address = fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128
DNS = 1.1.1.1
MTU = 1280
[Peer]
PublicKey = (removed)
AllowedIPs = 0.0.0.0/0
AllowedIPs = ::/0
Endpoint = engage.cloudflareclient.com:2408

 

That's my config or do I need something extra ?
 

Share this post


Link to post
Share on other sites
49 minutes ago, Killerelite06 said:

New wireguard settings aren't saving @Netduma Fraser @Netduma Liam

[Interface]
PrivateKey = (removed)
Address = 172.16.0.2/32
Address = fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128
DNS = 1.1.1.1
MTU = 1280
[Peer]
PublicKey = (removed)
AllowedIPs = 0.0.0.0/0
AllowedIPs = ::/0
Endpoint = engage.cloudflareclient.com:2408

That's my config or do I need something extra ?

Try this please:

[Interface]
PrivateKey = (removed)
Address = 172.16.0.2/32, fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128
DNS = 1.1.1.1
MTU = 1280
[Peer]
PublicKey = (removed)
AllowedIPs = 0.0.0.0/0, ::/0
Endpoint = engage.cloudflareclient.com:2408

Share this post


Link to post
Share on other sites
55 minutes ago, Netduma Fraser said:

Try this please:

[Interface]
PrivateKey = (removed)
Address = 172.16.0.2/32, fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128
DNS = 1.1.1.1
MTU = 1280
[Peer]
PublicKey = (removed)
AllowedIPs = 0.0.0.0/0, ::/0
Endpoint = engage.cloudflareclient.com:2408

I don't even know if its saving the settings (when I move to a  different tab and go back the settings are gone). Theres also no signs of it trying to connect 

I know the settings work when I use Wireguard on my PC it connects 

Share this post


Link to post
Share on other sites
29 minutes ago, Killerelite06 said:

I don't even know if its saving the settings (when I move to a  different tab and go back the settings are gone). Theres also no signs of it trying to connect 

I know the settings work when I use Wireguard on my PC it connects 

Ah I see, that happens, it's just a bug with HybridVPN. What does it show on Status? Are there any logs?

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

Ah I see, that happens, it's just a bug with HybridVPN. What does it show on Status? Are there any logs?

I have the same problem ! Status fail No log

Share this post


Link to post
Share on other sites
5 minutes ago, Netduma Fraser said:

Ah I see, that happens, it's just a bug with HybridVPN. What does it show on Status? Are there any logs?

 

Just now, Fuzy said:

I have the same problem ! Status fail No log

Exactly the same

Share this post


Link to post
Share on other sites
6 hours ago, Netduma Liam said:

Are the speeds this low if you run a speedtest from speedtest.net for example? Are you using VLAN ID, PPPoE or DHCP identifiers at all?

I'm using DHCP Identifiers. The good news is, speedtest.net gives close to ISP advertised speeds and DumaOs speedtest seem to have gotten a little better from previous one. Any idea why the speedtest in DumaOS and Fast.com are not surpassing 700mbps with QOS disabled? I believe I used to be able to get close to 900mbps before when I initially purchased the R2. But I reduced my ISP package for a while and didn't notice the speed. But recently, increased it back and noticed I've been struggling to get over 700mbps. But if it's hardware limitations, then it's fine. But I could of sworn I was getting 900mbps with QOS disabled upon release of R2. 

inkedwebcapture_24-11vbk4g.jpg

webcapture_24-11-202k3jax.jpeg261953991_Webcapture_24-11-2021_9270_192_168_77.1.thumb.jpeg.4b6fff487df1954bf897ac585b167b71.jpeg

 

Share this post


Link to post
Share on other sites
12 minutes ago, Fuzy said:

I have the same problem ! Status fail No log

11 minutes ago, Killerelite06 said:

 

Exactly the same

I've updated the config, if you can both try with this format and see if there is any change please, in the meantime I've asked a dev if they have a working config we can compare to.

[Interface]
Address = 172.16.0.2/32, fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128

ListenPort = 2408
PrivateKey = (removed)

DNS = 1.1.1.1
MTU = 1280

[Peer]
PublicKey = (removed)
Endpoint = engage.cloudflareclient.com:2408

AllowedIPs = 0.0.0.0/0, ::/0

7 minutes ago, TrayDay said:

I'm using DHCP Identifiers. The good news is, speedtest.net gives close to ISP advertised speeds and DumaOs speedtest seem to have gotten a little better from previous one. Any idea why the speedtest in DumaOS and Fast.com are not surpassing 700mbps with QOS disabled? I believe I used to be able to get close to 900mbps before when I initially purchased the R2. But I reduced my ISP package for a while and didn't notice the speed. But recently, increased it back and noticed I've been struggling to get over 700mbps. But if it's hardware limitations, then it's fine. But I could of sworn I was getting 900mbps with QOS disabled upon release of R2. 

It should be able to get 900 for sure, perhaps it's the identifiers, did you use those before when you got over 900? If you did it could be a bug regression.

Share this post


Link to post
Share on other sites
22 minutes ago, TrayDay said:

I'm using DHCP Identifiers. The good news is, speedtest.net gives close to ISP advertised speeds and DumaOs speedtest seem to have gotten a little better from previous one. Any idea why the speedtest in DumaOS and Fast.com are not surpassing 700mbps with QOS disabled? I believe I used to be able to get close to 900mbps before when I initially purchased the R2. But I reduced my ISP package for a while and didn't notice the speed. But recently, increased it back and noticed I've been struggling to get over 700mbps. But if it's hardware limitations, then it's fine. But I could of sworn I was getting 900mbps with QOS disabled upon release of R2. 

 

It's not hardware, I easily get my 900 Mbps with QOS enabled!

 

image.png.9e60cb46c918aa2214c269a535fd34f0.png

Share this post


Link to post
Share on other sites
9 minutes ago, Netduma Fraser said:

I've updated the config, if you can both try with this format and see if there is any change please, in the meantime I've asked a dev if they have a working config we can compare to.

[Interface]
PrivateKey =!!=
Address = 192.168.!!.!!/32
DNS = 212.27.38.253
MTU = 1360

[Peer]
PublicKey = !!=
Endpoint = 82.!!.!!.!!:1!!!!
AllowedIPs = 0.0.0.0/0, 192.168.!!.!!/27, 192.168.1.0/24
PresharedKey =!!=

I don't have exactly the same configuration. My ISP router allows me to create a WG server and generate a WG configuration file which is not similar!

 

Share this post


Link to post
Share on other sites

@Netduma Fraser

Yes, I believe it I used fast.com then when I did the speedtest. But, I know for sure I used speedtest.net and got the speeds. Yes, it could be the identifier. Seeing that I get close to my speeds on speedtest.net and @Fuzy confirimation. I'm fine with the results. 

Share this post


Link to post
Share on other sites
5 minutes ago, Fuzy said:

[Interface]
PrivateKey =!!=
Address = 192.168.!!.!!/32
DNS = 212.27.38.253
MTU = 1360

[Peer]
PublicKey = !!=
Endpoint = 82.!!.!!.!!:1!!!!
AllowedIPs = 0.0.0.0/0, 192.168.!!.!!/27, 192.168.1.0/24
PresharedKey =!!=

I don't have exactly the same configuration. My ISP router allows me to create a WG server and generate a WG configuration file which is not similar!

 

I'd add the listen port to interface as well. Your allowedips is a bit of a contradiction, saying apply to everything but actually only apply to these addresses so take the 0.0.0.0/0 out at least

Just now, TrayDay said:

@Netduma Fraser

Yes, I believe it I used fast.com then when I did the speedtest. But, I know for sure I used speedtest.net and got the speeds. Yes, it could be the identifier. Seeing that I get close to my speeds on speedtest.net and @Fuzy confirimation. I'm fine with the results. 

We'll take a look at that, thanks!

Share this post


Link to post
Share on other sites
9 minutes ago, Netduma Fraser said:

I'd add the listen port to interface as well. Your allowedips is a bit of a contradiction, saying apply to everything but actually only apply to these addresses so take the 0.0.0.0/0 out at least

Always negative result for me! Fail status No log

Share this post


Link to post
Share on other sites

 

22 minutes ago, Netduma Fraser said:

@Fuzy confirimation. I'm fine with the results. 

Sorry, I read it wrong!

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

I've updated the config, if you can both try with this format and see if there is any change please, in the meantime I've asked a dev if they have a working config we can compare to.

[Interface]
Address = 172.16.0.2/32, fd01:5ca1:ab1e:8e20:35e0:2599:9d96:1f5f/128

ListenPort = 2408
PrivateKey = (removed)

DNS = 1.1.1.1
MTU = 1280

[Peer]
PublicKey = (removed)
Endpoint = engage.cloudflareclient.com:2408

AllowedIPs = 0.0.0.0/0, ::/0

I tried this config, dint work for me. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...