Jump to content

Recommended Posts

Im on sky adsl and  but want to use vigor 130 modem and xr500 as router. I cant seem to get an internet connection on the vigor 130 and when I put it in bridge mode i still cant connect to the internet using xr500. any tips?

Share this post


Link to post
Share on other sites

you will need your pppoe username and password in order to use a draytek vigor modem  you will have to use wireshark to get them as sky will not give them to you as they only want you to use their equipment.   There are videos on youtube on how to do this.

 

 

 

 

Share this post


Link to post
Share on other sites

Just a nothing to do with anything question here. I have the 130 modem and an issue that I can not talk to the 130 through the XR1000. I have been unable to resolve the problem. Are you able to talk to the 130 through the xr500??

Share this post


Link to post
Share on other sites
9 hours ago, Harley said:

Just a nothing to do with anything question here. I have the 130 modem and an issue that I can not talk to the 130 through the XR1000. I have been unable to resolve the problem. Are you able to talk to the 130 through the xr500??

Have you put the Draytek in bridge mode or anything like that or is it still acting like a router?

Share this post


Link to post
Share on other sites

FWIW:

If you want to see the stats on your Draytek Vigor 130 then between the modem and router, use a small 4 to 8 port switch.

Connect your Laptops/PC Ethernet cable into that switch with an IP of 192.168.2.2 (manual IP address on that  interface) - (no gateway needed)

Then at your browser type 192.168.2.1 to enable you to login and get your stats etc.

Note: my TP-Link 5 port switch likes it when the Ethernet cable from the laptop plugs into Port 1 ? -  Ports 4 and 5 are used for the connection from DrayTek 130 to my XR500 

(switch only adds marginal delay - so not big issue when gaming)

😉

Share this post


Link to post
Share on other sites
On 9/24/2021 at 1:22 PM, UK Sentinel said:

FWIW:

If you want to see the stats on your Draytek Vigor 130 then between the modem and router, use a small 4 to 8 port switch.

Connect your Laptops/PC Ethernet cable into that switch with an IP of 192.168.2.2 (manual IP address on that  interface) - (no gateway needed)

Then at your browser type 192.168.2.1 to enable you to login and get your stats etc.

Note: my TP-Link 5 port switch likes it when the Ethernet cable from the laptop plugs into Port 1 ? -  Ports 4 and 5 are used for the connection from DrayTek 130 to my XR500 

(switch only adds marginal delay - so not big issue when gaming)

😉

The funny thing is that with my old Asus router, I could just talk right through the router to the modem's web interface.  I can't do that with the XR1000. I have noticed before that Netgear routers do not allow this for some reason but Asus do. The address of the 130 is 192.168.0.1 and the XR1000 is 192.168.1.1

I baffled as to why I can not talk to the 130.

And sorry for hijacking this post.

Share this post


Link to post
Share on other sites

There is much discussion about this on the internet but it's all vague, confused, and frankly seems to be mostly a bunch of people who don't know what they are talking about making a lot of guesses!! Meanwhile, I think I have at least discovered what the problem is..

192.168.x.x is universally reserved for private networks. I believe that Netgear routers by default block such messages from being transmitted on to the WAN. Asus routers do not.

I don't understand routers well enough to know if there is a solution to this.  Perhaps it would be possible to bypass this "feature" in Netgear routers or perhaps use a different address for the modem. I don't know.

Share this post


Link to post
Share on other sites
4 hours ago, Harley said:

There is much discussion about this on the internet but it's all vague, confused, and frankly seems to be mostly a bunch of people who don't know what they are talking about making a lot of guesses!! Meanwhile, I think I have at least discovered what the problem is..

192.168.x.x is universally reserved for private networks. I believe that Netgear routers by default block such messages from being transmitted on to the WAN. Asus routers do not.

I don't understand routers well enough to know if there is a solution to this.  Perhaps it would be possible to bypass this "feature" in Netgear routers or perhaps use a different address for the modem. I don't know.

The Netgear routers are able to take internal addresses as a WAN IP just fine so I'm afraid that won't be the cause. 

If you go to the dumaOS interface by going to routerlogin.net in your web browser, check System Information -> Network Status and see if it's got a WAN IP from the Vigor.

Share this post


Link to post
Share on other sites

It should not be the case actually. My internal network is 192.168.1.0/24 and my cable modem is 192.168.100.1 and I have no issues logging into it with either XR500 or XR700, doubt the XR1000 is any different in that aspect.

 

It's just that anything else than your default subnet is generally routed via the WAN interface, unless you tell it to do different via static routes.

 

If you cascade routers, so for example router 1 192.168.1.0/24 and second 192.168.10.0/24 then you will run into this issues as router 2 can access LAN on router 1 but not the other way around due to the firewall. It could be done if router 2 had no firewall and you set a static route in router 1 where 192.168.10.0 points to the 'WAN' on router 2. But this is a different setup entirely.

Share this post


Link to post
Share on other sites

No I have cable modem in bridge connected straight to XR700, using DHCP. Before I had XR700 then I used XR500 in that spot, works the same. So no double NAT.

Share this post


Link to post
Share on other sites

The XR700 gets the public IP. This a broadcom cable modem/router in bridged mode though.

 

I assume it works just like a switch. The LAN and WAN ports are bridged and the interface of the cable modem is accessible as connected to the internal switch, similar to accessing a managed switch.

 

This may not work for PPPoE connections though as you will have PPPoE encapsulation when leaving the router. PPPoE is essentially a point to point serial link. But in most cases I would expect the cable modem to handle this. But this might be the reason why you need a separate switch between the Vigor and the router and acces it via that.

Share this post


Link to post
Share on other sites

@Bert - glad you seem to understand networking protocols to a good degree 😉

For both @Harley (probably )and myself ,  we use PPPoE to Router, the  Modem is bridged by default and manages the VLAN ID tag 101 separation,  hence issue with most Netgear WAN's.

 ASUS do not have such a limitation on the WAN as they have virtual WAN's  (I believe) or routing to that allow more than just PPPoE via WAN

This limitation could be considered a Security enhancement I suppose, so maybe why Netgears function that way ?

 

 

Share this post


Link to post
Share on other sites

I'm not sure actually as I have never looked into this situation.

 

But you mention that there is also a VLAN tag in play.

 

Do you set VLAN tags on the router?

 

That might also be the issue. Same for switches, the managment interface is usually tied to a specific VLAN, most of the time default means VLAN 1. So in that case you won't be able to reach the modem as the modem passes through traffic.

 

If the modem is doing the ingress tagging on the LAN port then this should be no issue as you can also get into it through a switch. If your router is doing it, it expalins why it works through a switch. Most switches honor VLAN tags, only managed switches can add them and strip them. But if you attach a second cable to the switch and access it via laptop this will essentially be untagged traffic and assigned to default VLAN. Moreso the modem and your ISP won't care as this untagged traffic is not interfering with any sort of DHCP since this is run via VLAN 101. 

 

In my other house I have a dual WAN fiber connection. Means one fiber coming in and this is split into 2 different connections using VLAN's I run them through a switch, that does the tagging for me. I can't reach the managment for that either unless I use a loopback cable from one of the LAN ports. That's because the managment interface only responds on VLAN 1.

Share this post


Link to post
Share on other sites
4 hours ago, Netduma Liam said:

The Netgear routers are able to take internal addresses as a WAN IP just fine so I'm afraid that won't be the cause. 

If you go to the dumaOS interface by going to routerlogin.net in your web browser, check System Information -> Network Status and see if it's got a WAN IP from the Vigor.

I have no idea in that case why I can not communicate with the modem. 

I do know, though, that I could view the modem configuration pages with my Asus router, and I could not with another Netgear router I had previously. 

This is the topic of a number of conversations about the problem on the internet and no one seems to know the answer.  I have tried changing the address of the modem and still doesn't work. The modem web page "Can't be reached".

If I go to view  the WAN IP in the XR1000 it correctly displays my ISP provided IP so the XR1000 seems to have no issue with the modem. 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, UK Sentinel said:

@Bert - glad you seem to understand networking protocols to a good degree 😉

For both @Harley (probably )and myself ,  we use PPPoE to Router, the  Modem is bridged by default and manages the VLAN ID tag 101 separation,  hence issue with most Netgear WAN's.

 ASUS do not have such a limitation on the WAN as they have virtual WAN's  (I believe) or routing to that allow more than just PPPoE via WAN

This limitation could be considered a Security enhancement I suppose, so maybe why Netgears function that way ?

 

OK that went a big WOOOSH as it passed over my head. LOL. 

 

Share this post


Link to post
Share on other sites

Modem handles VLAN separation - router does not.

Switch between Modem and Router does not need and VLAN ID's I just plug laptop into switch and access Modems UI .

 

 

 

Share this post


Link to post
Share on other sites
27 minutes ago, UK Sentinel said:

Modem handles VLAN separation - router does not.

Switch between Modem and Router does not need and VLAN ID's I just plug laptop into switch and access Modems UI .

 

 

 

OK no idea what you are saying, but it seems you are in the right ballpark. I searched Draytek and found this. 

https://www.draytek.com/support/knowledge-base/5212

It seems to deal with the issue you are talking about but most of it goes clean over my head.  I am assuming that without the ability to fully configure what's going on in the router then this is a lost cause. 

Share this post


Link to post
Share on other sites

VLAN/PPPoE can be configured on the XR if needed so that shouldn't cause a problem accessing the vigor. Set the Vigor to bridge mode https://www.draytek.co.uk/support/guides/kb-vigor-130-bridge?return=8567559 then see if you can access it when connected to the XR

Share this post


Link to post
Share on other sites
17 hours ago, Netduma Fraser said:

VLAN/PPPoE can be configured on the XR if needed so that shouldn't cause a problem accessing the vigor. Set the Vigor to bridge mode https://www.draytek.co.uk/support/guides/kb-vigor-130-bridge?return=8567559 then see if you can access it when connected to the XR

Nope. Still will not connect. "The connection has timed out".

I think I may just give up on this. It's not like it is critical but I would have liked to have accessed the modem to see what is going on in there, try different settings and so on, but it is just too time consuming if I can't directly access the modem.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...