Jump to content
Kwee

Bufferbloat and Ping Test Underload Results

Recommended Posts

What if you try to set your actual bandwidth numbers to something like 920/920 or 940/940 ?

 

These bandwidth numbers control the traffic shaping algorithm.

 

The issue with 1Gbit connectivity over a 1Gbit LAN port is that you won't actually make 1Gbit due to overhead. That's why a number of ISP's advertise their service as 940mbit and not 1000mbit. So if you try to push 1000mbit through a 920mbit pipe it will bufferbloat eventually.

 

In the last connection benchmark you can see latency running up on upload, that's buffers filling because of link congestion.

Share this post


Link to post
Share on other sites

Target ping vs idle set to 5ms is too little, natural variations in ping can go over that, 10 is a good low figure that will account for natural variance. Try it with that figure and see if it recommends anything else

Share this post


Link to post
Share on other sites
11 minutes ago, Bert said:

What if you try to set your actual bandwidth numbers to something like 920/920 or 940/940 ?

 

These bandwidth numbers control the traffic shaping algorithm.

 

The issue with 1Gbit connectivity over a 1Gbit LAN port is that you won't actually make 1Gbit due to overhead. That's why a number of ISP's advertise their service as 940mbit and not 1000mbit. So if you try to push 1000mbit through a 920mbit pipe it will bufferbloat eventually.

 

In the last connection benchmark you can see latency running up on upload, that's buffers filling because of link congestion.

 

Screenshot (18).png

Share this post


Link to post
Share on other sites

It's still pushing it.

 

What is the highest speed you have seen in a speedtest?

Share this post


Link to post
Share on other sites
12 minutes ago, Netduma Fraser said:

Target ping vs idle set to 5ms is too little, natural variations in ping can go over that, 10 is a good low figure that will account for natural variance. Try it with that figure and see if it recommends anything else

 

Screenshot (20).png

Share this post


Link to post
Share on other sites
On 7/15/2021 at 11:09 AM, Bert said:

It's still pushing it.

 

What is the highest speed you have seen in a speedtest?

950Mbps

Share this post


Link to post
Share on other sites

seems like my speed test is all over the place 🙄

Share this post


Link to post
Share on other sites

The Connection Benchmark results still need to be improved and the auto setup uses those same servers so can take it with a pinch of salt. In this scenario we usually recommend saturating your connection with downloads, streams etc while following this guide http://support.netduma.com/en/support/solutions/articles/16000074717-how-to-test-your-internet-ping and experiment with the percentages set to always and see what lowers it the most

Share this post


Link to post
Share on other sites

So just mess with the sliders until I don't see any spikes and Packet loss with out using a speed test during the test? Just use downloads and streams?

 

Share this post


Link to post
Share on other sites
55 minutes ago, Kwee said:

So just mess with the sliders until I don't see any spikes and Packet loss with out using a speed test during the test? Just use downloads and streams?

Yes exactly, the reason I suggest downloads and streams are 1) It's more like what you would be doing normally & 2) speedtests are over too quickly

Share this post


Link to post
Share on other sites

I just updated my netwrok adapter driver and seeing better results now. I just checked my motherboards website and came across a new driver they placed in the download section and bingo I'm getting super low spikes now

 

off topic but should I be using traffic prioritization for my games? I notice upnp always has port 3074 open when I'm playing warzone and thought that would be good enough. I always have open NAT when playing so that's not a issue for me.

What should the source port be for best performance? default? I just want every inch of hit reg I can get when playing Warzone

(I just made that rule that's why you don't see anything prioritized )

Screenshot (24).png

Share this post


Link to post
Share on other sites

That rule is backwards. You should set source as 3074 and destination as 1-65535. Also I only use UDP since that is what the actual game traffic uses.

 

Adding it as games console will also work decently.

Share this post


Link to post
Share on other sites
9 hours ago, Kwee said:

I just updated my netwrok adapter driver and seeing better results now. I just checked my motherboards website and came across a new driver they placed in the download section and bingo I'm getting super low spikes now

 

off topic but should I be using traffic prioritization for my games? I notice upnp always has port 3074 open when I'm playing warzone and thought that would be good enough. I always have open NAT when playing so that's not a issue for me.

What should the source port be for best performance? default? I just want every inch of hit reg I can get when playing Warzone

(I just made that rule that's why you don't see anything prioritized )

Thanks for letting us know, the rule you've created will work great, however Warzone is classified in the DumaOS Classified Games Rule so that would probably work better than creating a custom rule!

Share this post


Link to post
Share on other sites

is it normal for GEO filter to take awhile sometimes? Seems like I've been seeing long wait times when trying to join a server on Warzone. Got my ping assist at 35 and 411 mile distance 

Share this post


Link to post
Share on other sites
58 minutes ago, Kwee said:

is it normal for GEO filter to take awhile sometimes? Seems like I've been seeing long wait times when trying to join a server on Warzone. Got my ping assist at 35 and 411 mile distance 

It really depends, if it's outside peak time it could be longer, also how far away are you trying to force servers?

Share this post


Link to post
Share on other sites

I always get good servers 11-30ms but it's taking 5-10min to join sometimes

Screenshot (25).png

Screenshot (26).png

Share this post


Link to post
Share on other sites

Just noticed in network status I have 8k unprioritized packets. Could that be a issue?

Screenshot (27).png

Share this post


Link to post
Share on other sites
3 hours ago, Kwee said:

Just noticed in network status I have 8k unprioritized packets. Could that be a issue?

Screenshot (27).png

Yes that is almost certainly the problem - you have more failed to send packets than successfully sent packets. Change the ethernet cable connecting the XR to your modem - it's quite possible the existing cable is faulty.

Share this post


Link to post
Share on other sites

Unprioritized is simply traffic that does not go by the traffic prio rules.

 

The reason you have 0 unprioritized transmitted packets is that your QoS rule is backwards. If you say Source TCPUDP 1-65355 it simply prioritises all upload traffic. And hence your QoS is not effective.

 

You should set source as 3074. 

Share this post


Link to post
Share on other sites
20 minutes ago, Bert said:

Unprioritized is simply traffic that does not go by the traffic prio rules.

 

The reason you have 0 unprioritized transmitted packets is that your QoS rule is backwards. If you say Source TCPUDP 1-65355 it simply prioritises all upload traffic. And hence your QoS is not effective.

 

You should set source as 3074. 

That's not applicable to this panel, just TP:

You can view the amount of data transferred since your router was switched on, including unprioritized packets (packets which did not reach their destination).

Share this post


Link to post
Share on other sites

650560164_Screenshot(29).thumb.png.480a11e81d55b0a744b5261d537aaa39.png2034980452_Screenshot(28).thumb.png.16a4e16b4517440a2752e67b7f9e502e.png

5 hours ago, Bert said:

Unprioritized is simply traffic that does not go by the traffic prio rules.

 

The reason you have 0 unprioritized transmitted packets is that your QoS rule is backwards. If you say Source TCPUDP 1-65355 it simply prioritises all upload traffic. And hence your QoS is not effective.

 

You should set source as 3074. 

I already switched that to Source as 3074 and destination port is start 1 end  65535. Sorry should have updated that

 

5 hours ago, Netduma Fraser said:

Yes that is almost certainly the problem - you have more failed to send packets than successfully sent packets. Change the ethernet cable connecting the XR to your modem - it's quite possible the existing cable is faulty.

My wires run through the inside of the house, should I just unplug the ethernet from the modem lan port 1 and plug one directly into it and back into the XR1000? Also my ONT box is connected to another Ethernet that runs through the walls that connects the modem to the ONT so I got  2 ethernet cables that could be the issue. Only thing is my ONT is in the garage so I would need a long cord to run that for a test. I might have them come out and move the ONT to my room so then I can directly plug it into my   modem then XR1000 to limit out more issues.

Share this post


Link to post
Share on other sites
13 minutes ago, Netduma Fraser said:

Yes do try the first option if you can, it would be better in general as well if everything was coming from the same point

Should both of them be 0 unprioritized packets? this is with the new ethernet cable running from the modem to the xr1000

Screenshot (30).png

Share this post


Link to post
Share on other sites
53 minutes ago, Kwee said:

Should both of them be 0 unprioritized packets? this is with the new ethernet cable running from the modem to the xr1000

Ideally yes but a small amount is normal depending on the connection and yours there is 0.07% so that is a lot better and you should have a better experience now

Share this post


Link to post
Share on other sites
31 minutes ago, Netduma Fraser said:

Ideally yes but a small amount is normal depending on the connection and yours there is 0.07% so that is a lot better and you should have a better experience now

How do you get that percentage?

would increasing transmit buffers on the realtek lan in Advqance settings help this at all? right now it's on default 512 but I can increase it all the way to 4096. Receive buffers can't go any higher then 512

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...