Jump to content

Recommended Posts

just got the XR1000 and when i was setting it up and making sure all my ports were open across my ps4, ps3, PC 

for the ps4 call of duty black ops 3 port 3074 is open 
for PC (manually added ports to have a open NAT for GTA 5 on PC as well and port 6672 is open)  call of duty black ops 3 ( uses a different port ) is open
for ps3, call of duty black ops 1 & 2 port 3074 is closed and i get NAT Type moderate 

on my NETDUMA R2 i had no trouble with having more than one console using port 3074, i had alot of problems with the wifi dropping out and the router crashing then rebooting itself so i got my hands on the XR1000


port triggering is Enabled
UPnP is Enabled
portforwarding rules were set for ( GTA 5 PC, Port opened ) ( PS4 Black ops 3, port opened ) didn't let me manually add UDP 3074 for my ps3 to have open nat on black ops 1 + 2

i've set Nat filtering from secured to OPEN, didn't help with opening port:3074 across all my consoles 

Share this post


Link to post
Share on other sites

For the PS3, make a rule where 3074 is the external and 3075 is the internal as if you have more than one device playing CoD then 3075, 3076 etc is used for additional devices

Share this post


Link to post
Share on other sites

a restart seems to have helped UPnP, it's forwarding ports as it should cheers for letting me know man

also, i notice there's no Hybrid VPN, could this be considered in the next XR1000 update? I myself really need this feature 

for the people live streaming and playing games, they could end up being DDoSed, i also used the hybrid VPN on the NETDUMA R2 and i ran into a lot of people trying to boot me offline, at the time i had my R2 on with the Hybrid VPN enabled and they'd boot the VPN offline but my internet would be untouched. I've stopped playing GTA 5 on ps3 but I'd like to go back to it, however there's people on there that pull ip addresses either by a mod menu or an ip sniffer on a pc.

i also play gta 5 on my gaming pc and know modders have mod menus to grab a players ip address and, you guessed it, they can even hit players offline there too

please let there be an update to the XR1000 and any other nighthawk to have the Hybrid VPN added ASAP, if there were a petition to sign I'd sign it

Share this post


Link to post
Share on other sites

Ah great to hear! We're happy to implement it but it is up to Netgear as to whether it does get included on their hardware. They love the feature so I'm sure it will come in future!

Share this post


Link to post
Share on other sites

had to restart the XR1000. bad news, the NAT Type issue is back.
NAT Type is open for one ps3, and my computer. my ps4 and other ps3 has moderate NAT for black ops 1 ,2 & 3
1488843725_Screenshot(95).thumb.png.9a30d4d70e9ea06c3b18c7b04eed446b.png
i tried forwarding ports for the ps4 and other ps3, it gives me a error message ( failed to add port, or ports conflict ) 

UDP 3074 External port cannot be added to other port forwarding rules for some reason. only works for [ PlayStation 3 Black Ops l & ll ]

( can only have one external port as 3074 )

Share this post


Link to post
Share on other sites

What's the make and model of your modem? Could you try accessing it's interface then reserve the current IP for the XR1000 (so it won't change). Then take this IP and put it in the modem's DMZ. Then restart both modem and router if possible and see if you have the same issues.

Share this post


Link to post
Share on other sites

Modem: TP-Link
Model: Archer VR1600V

 it worked perfectly fine with the Netduma R2 my Nat type was open in every game on every console without fail, apart from GTA 5 on pc, i had to portforward.

I set the XR1000 to have the same default gateway as the Netduma R2 ( 192.168.2.1 ) so all i had to do was change the wifi name and password so i didn't have to connect all the devices to the new SSID and enter a new password 


TP-Link Archer VR1600V ---> Netgear Nighthawk XR1000
bridge mode Enabled.

my Ipv4 address shows up in the "system information"

Share this post


Link to post
Share on other sites
4 hours ago, ifell said:

Modem: TP-Link
Model: Archer VR1600V

 it worked perfectly fine with the Netduma R2 my Nat type was open in every game on every console without fail, apart from GTA 5 on pc, i had to portforward.

I set the XR1000 to have the same default gateway as the Netduma R2 ( 192.168.2.1 ) so all i had to do was change the wifi name and password so i didn't have to connect all the devices to the new SSID and enter a new password 


TP-Link Archer VR1600V ---> Netgear Nighthawk XR1000
bridge mode Enabled.

my Ipv4 address shows up in the "system information"

Thanks for confirming, the only reason I suggest this is because I believe it may be a much easier way for you to ensure an open NAT without having to keep changing configuration.

I'd suggest taking the TP-Link out of bridge mode and disable it's Wi-Fi (If applicable), then DMZ the XR1000 and you should be good to go.

Share this post


Link to post
Share on other sites

i factory reset the tp-link and set it up back in bridged mode ( worked with the Netduma R2 ) hope it works as its intended to 

Share this post


Link to post
Share on other sites

I have a static public ipv4 address, I have the modem in bridged mode. the XR1000 WAN: Nat filtering is OPEN. I've manually forwarded ports for a OPEN Nat type on black ops 1, 2, 3

192.168.2.18 | internal: 3077 | external: 3077 | UDP - port forwarded 

it seems to ignore it and tries to do UPnP, 
192.168.2.18 | internal: 3074 | external: 3074 | UDP ( and fails to use the port I forwarded and it gets a moderate NAT. even though the |  192.168.2.18 | internal: 3077 | external: 3077 | UDP worked via UPnP, but not when I do port forwarding.
 
in the past UPnP opened the Nat type for 3074, 3076, 3077, 3078 all the ps3's on the network had OPEN NAT for black ops 1 & 2, so 4/4 total of PS3's.

but the ps4 gets moderate NAT on black ops 3.

also getting moderate Nat type for GTA 5 on pc. I forwarded the ports as well...

why is it that when I try to forward the same ports that worked for UPnP it ignores the ports I've forwarded?

the Netduma R2 had no problems with NAT and port forwarding rules. so its the XR1000 at fault.

 

Untitled.112png.png

Untitled111.png

Share this post


Link to post
Share on other sites

"Occupied" spelling error in one of the photos, my bad 

 

Share this post


Link to post
Share on other sites

Could you please disable UPnP and re-test? Sometimes the two can conflict and create more problems than they fix.

Share this post


Link to post
Share on other sites

i thought about that, first I'm going to try disabling UPnP on the ps3 end, with port forwarding 3077 UDP & Port 3658 UDP  for  ( 192.168.2.18 ) then see if the UPnP gives it 3074, if it does i'll disable UPnP and restart the XR1000 and see what happens 

Share this post


Link to post
Share on other sites
3 minutes ago, ifell said:

i thought about that, first I'm going to try disabling UPnP on the ps3 end, with port forwarding 3077 UDP & Port 3658 UDP  for  ( 192.168.2.18 ) then see if the UPnP gives it 3074, if it does i'll disable UPnP and restart the XR1000 and see what happens 

Right OK, cool, let us know how you get on.

Share this post


Link to post
Share on other sites

moderate nat.. im going to try deleting all portforwarding rules all together and use port triggering, i've added some ports. to port triggering. i've enabled UPnP, i'll test it without UPnP after i've tried with UPnP 

Share this post


Link to post
Share on other sites
6 minutes ago, ifell said:

moderate nat.. im going to try deleting all portforwarding rules all together and use port triggering, i've added some ports. to port triggering. i've enabled UPnP, i'll test it without UPnP after i've tried with UPnP 

Interesting, OK let me know the results.

Share this post


Link to post
Share on other sites

UPnP with port triggering: opened the Nat Type for 2/2 ps3's that I tested. I can't test if all consoles and pc have open Nat at this time. but, I'll be able to test it for them within 2 days.
here's what ports UPnP opened
924883746_Screenshot(99).thumb.png.949108c89a91b050cc36479c47ce2aee.png
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
here's what I set in port triggering. and these are the settings in WAN
578389993_Screenshot(100).thumb.png.764d76b08468f005195e1c216610698c.png 946238143_Screenshot(101).thumb.png.51788dce40d882eb7571677d0f98daa8.png
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
UPnP Disabled and port triggering in use: only 1/2 ps3's had open NAT


-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
when I tried to enter the same ports as UPnP has ( as seen in the first image above in the UPnP screenshot ) in port forwarding, only 1 ps3 had open Nat.

there must be something wrong with port forwarding because that should have worked without UPnP. another thing worth noting is that port forwarding has some text that seems out of place and doesn't have any purpose ( not usable when clicked on  ) below ( please select a service type ) this includes port forwarding, port triggering.

Untitled1222.thumb.png.93994bfb6241caf7ac6ac9377d6c9949.png

that's all for now. I'll post what happens with the other devices I haven't tested yet ( ps4, ps3 and pc ) NAT type, but I'll keep UPnP enabled for those 

Share this post


Link to post
Share on other sites

I've sent you a trial firmware, if you upgrade then switch NAT to Open in WAN Settings it should get everything open no problems. Factory reset after install and do keep in mind it is a trial firmware so may have some bugs.

Share this post


Link to post
Share on other sites

when I can, I'll check to see if all the consoles and my PC has an open Nat, I'll let you know how it goes, if it still hasn't got an open Nat Type for all devices then I'll factory reset the XR1000 then log-in and install the firmware you've provided then factory reset it again.

once all that is done, I'll check if UPnP is enabled, port triggering is enabled but I'll leave the port triggering and port forwarding rules blank, and set WAN Nat filtering from Secured to OPEN 
then reboot the XR1000

if I still get moderate I'll try some port triggering or port forwarding rules 

Share this post


Link to post
Share on other sites
6 hours ago, ifell said:

when I can, I'll check to see if all the consoles and my PC has an open Nat, I'll let you know how it goes, if it still hasn't got an open Nat Type for all devices then I'll factory reset the XR1000 then log-in and install the firmware you've provided then factory reset it again.

once all that is done, I'll check if UPnP is enabled, port triggering is enabled but I'll leave the port triggering and port forwarding rules blank, and set WAN Nat filtering from Secured to OPEN 
then reboot the XR1000

if I still get moderate I'll try some port triggering or port forwarding rules 

Sounds great, let us know how you do.

Share this post


Link to post
Share on other sites

still ran into some trouble. one test I did was able to get open NAT on my ps3, ps4, & pc for black ops, but it would only open it up for the last device that connected to the call of duty servers. so in short.. only the PlayStation that was most recently connected to the call of duty servers and PC would get OPEN Nat for black ops 

pc port 27013 UDP - black ops 
ps4 port 3074 UDP port conflict - black ops 
ps3 port 3074 UDP port conflict - black ops 

for example if the ps3 was connected to the call of duty server first, then the ps4 was turned on then booted up black ops 3, the ps4 would pinch port 3074 from the ps3, and the ps3 would go back to moderate 

I wasn't able to open port 6672, 61455-61458 UDP for GTA V pc ( moderate Nat, UPnP enabled ) didn't see any UPnP rules saying that ports 6672, 61455-61458 where added, so yeah moderate Nat.




I'll give the Firmware update Fraser sent me a try when no one else is home. everyone enjoys streaming Netflix, I'll post here once I've updated the XR1000 and have finished testing the NAT type, I'll make sure I have Nat Filtering set to OPEN in WAN 

Share this post


Link to post
Share on other sites

Let us know how you get on with the firmware, it should be much easier to get an Open NAT across the board with that compared with port forwarding which is more difficult. Also for multiple devices go up by one for each device e.g. 3074, 3075, 3076 etc.

Share this post


Link to post
Share on other sites

installed the firmware, still having the same thing happen. I'll give port forwarding a shot, if that fails I'll use port triggering 

not all consoles would get a open NAT type, which would impact matchmaking 

Share this post


Link to post
Share on other sites

Was that with switching NAT to Open in the WAN Settings?

Unless the devices were getting a strict NAT then it shouldn't really affect matchmaking much at all and it certainly won't impact the quality of the connection - just impacts who you're able to connect to but as the game uses servers anyway it won't be a problem

Share this post


Link to post
Share on other sites

call of duty black ops is mostly peer to peer the only time it connects to a game server is when you select play online ( connects and downloads online progress for call of duty )  and with ps3 having an open Nat type it helps with finding games as the player count is around 1000players globally without open Nat you cant find any matches for ages. also helps with hosting public matches 

some of my friends have a strict Nat type and they cant join me.

on my ps4 when someone with a strict Nat type joins my party I cant hear them because I have a moderate Nat type for my ps4 straight after setting up the XR1000.

the Netduma r2 had everything OPEN Nat, apart from GTA5 for pc, but when I port forward a rule for it it worked no problem, but that didn't work for the XR1000

yes this is even with WAN ( NAT Filtering set to OPEN )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...