Jump to content
GTOMAN

Few questions about running two routers

Recommended Posts

So I originally was using my r2 as my only router, but I have so many wireless devices, etc that the router was slightly unreliable. So I put my tplink archer c8 as the main router and the r2 as the second router. I have them connected via Lan ports 1-4. Disabled dhcp server on the r2 and changed the r2 ip address to one number higher then the tplink ip. Was this correct? Everything seems to be working correctly for the most part. Is there a better way to do this? 

Share this post


Link to post
Share on other sites

OK, so my Xbox is connected to the internet. I can play games, etc. But geo filtering is not working, nor does my Xbox show to be connected to the Duma, even though it is hard wired to the duma

Share this post


Link to post
Share on other sites

Try it the other way round.  Seems there are some problems WiFi related on the R2 that causes dropouts as you probably know.  Until it's resolved, I have a similar setup to yours but with the R2 as primary and disabled WiFi.  It's a lot more reliable like this and you get to use the other features as intended.  As of today, I've had no problems for over 2 weeks compared to before when the dropouts were daily and even a few times per day.  Try it and see how you get on.

PS. I have everything connected to my secondary.

Share this post


Link to post
Share on other sites
1 hour ago, GTOMAN said:

So I originally was using my r2 as my only router, but I have so many wireless devices, etc that the router was slightly unreliable. So I put my tplink archer c8 as the main router and the r2 as the second router. I have them connected via Lan ports 1-4. Disabled dhcp server on the r2 and changed the r2 ip address to one number higher then the tplink ip. Was this correct? Everything seems to be working correctly for the most part. Is there a better way to do this? 

Destiny 2? 

Share this post


Link to post
Share on other sites
3 hours ago, GTOMAN said:

So I originally was using my r2 as my only router, but I have so many wireless devices, etc that the router was slightly unreliable. So I put my tplink archer c8 as the main router and the r2 as the second router. I have them connected via Lan ports 1-4. Disabled dhcp server on the r2 and changed the r2 ip address to one number higher then the tplink ip. Was this correct? Everything seems to be working correctly for the most part. Is there a better way to do this? 

as gamingcavalier posted, put them the other way around. use the R2 as your main router and turn the wireless completely off on the R2. Use the tp-link router in access point mode meaning you do not need to turn dhcp on the tp-link. geo-filter will work now and you will probably stop getting disconnects.

Share this post


Link to post
Share on other sites

OK, my next question is, can I leave the wifi on and still be OK? I also don't believe my tplink has a access point mode. 

Share this post


Link to post
Share on other sites

I guess you could try with it on for testing purpose but I would advise you to just turn WiFi off on the R2 because it's still unknown why it causes problems but having it disabled makes it much more usable.  You will just introduce more unnecessary interference into your network having WiFi on both R2 and Archer.  AP mode makes things more simple and streamlined but if it's not an option then shouldn't be a problem as long as you turn off DHCP on the Archer and give it a static IP as you've done with the R2 on your first post.

Share this post


Link to post
Share on other sites

Good advice above there! I'd also reset the IP address you gave the R2 as that isn't needed and you will need to re-enable DHCP on the R2. Disabling DHCP doesn't help, just means you would have to assign IPs to devices to have them connect to the router which is more of a headache in my opinion.

Share this post


Link to post
Share on other sites
34 minutes ago, alhilali55 said:

I have an R1 device, does that include my device type or is it exclusive to the R2?

Hey, welcome to the forum!

I would recommend the same thing for the R1 as well yes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...