Jump to content
VigoDaCarpathien

Apex Legends issues associated with R2

Recommended Posts

Hello everyone,

1st time on the forum so apologies in advance if I did not find the relatable topic and helpful solution to my problem. Ok so this is odd to explain.

Ever since I got my R2 I have had a fun time figuring out how it all works. The most recent issue I have had is with my GeoFilter and Apex Legends. Ever since I set up everything I kept getting these odd errors (code:leaf) that would kick me out of the game before the character select screen. Even when I did manage to get into a game, I would be booted back to the data center select screen after every game. When I further investigated the code, I found out that it is to be a code error on the Respawn side of things (e.g. the Server is basically not connecting to my internet) and there seems to be minimal answers on how to solve the issue.

I saw a few Reddit posts with some suggestions on things I could do (router reset, port forwarding, etc) but it all circled back to that it was a Respawn issue and there seemed to be nothing I can do.

In a last ditch effort I went and did some port forwarding to see if that would clean things up. I got into a few matches in a row with no problem, but then I started to get the same code:leaf error again...and again...and again.

As a final final "let's see if this works" effort, I unplugged my gaming PC from my R2 and directly into my ISP Router. WELP, played for 4hrs last night with 0 issues. So there is some lack of comms between my R2, my ISP, and the Respawn Servers. I would love some feedback on this!

My Geo settings: Location - Eastern US, Radius - 500 miles (covers about 4 data centers between Virginia, New York & South Carolina), Geo Options - Strict with Auto Ping: OFF

I have also Resynced Cloud, turned on fast search, expanded radius, tuned on Auto Ping etc etc etc (feels like I tried everything - I hope not)

SOOO is it a geo filter setting or is it a setting I should have turned on or off in my router? LOL I don't know pls help. Currently feeling like the router was a waste and I do not want to feel that way.

 

P.S. I have also struggled with issues in Warzone as well. It has been a journey but I think I have fixed those (fingers crossed)

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

This is something we're aware of and looking into. It it the Geo-Filter blocking an authentication server most likely and so to prevent that happening we need to allow it. That's my thought anyway, the team may find another reason. I'd suggest disabling Filtering Mode for the Apex until we fix that - or when you see the error have a look on the Geo-Filter quickly to see if anything is blocked, if it is then allow it. You may need to do this a few times and then in theory it should work.

Share this post


Link to post
Share on other sites

Thanks for your response and the team working on it. I have disabled the filter before as well I unfortunately still get the error when my gaming PC is connected to the router. I currently have 0 issues when I am connected directly to my Modem. Hoping to hear of a fix soon! (fingers crossed)

Share this post


Link to post
Share on other sites

I would also like to add that I have been further troubleshooting. I realized that I also had my Call of Duty filter enabled as well. It seems to be what caused the issue. However, it does not seem like the Apex filter is working at all. When I had both CoD and Apex filter on, it was showing me blocked servers on the map plus the servers that were blocked had -1 next to their data center. Ever since I turned off the CoD filter, all of the servers are showing as available and none are blocked. With CoD filter enabled I was getting code:leaf error. With it off, I have not had the error once. Just figured I can make you guys aware of that as well. So it seems like that fixed the error issue but it does not seem to filter the servers out. It also seems that my CoD filter when enabled was also working for Apex.

Share this post


Link to post
Share on other sites

Just to clarify, you had Apex and CoD added for your device twice on the Geo-Filter? If filtering mode is disabled it will allow the game to connect you to wherever it wants. I'd recommend giving your PC a PlayStation device type in the Device Manager and then re-adding to the Geo-Filter and select the manual option. You can then just have that one rule for all games and enable/disable as needed.

Share this post


Link to post
Share on other sites

@Netduma Fraser correct. When I have both filters on, I get the code: leaf error. When I turn off CoD and leave Apex on, I do not get the error but the filter doesn't seem to be working. I will attempt the Playstation device way to see if that will make the Apex filter work.

Capture.PNG

Share this post


Link to post
Share on other sites

It could be a server authentication error, but one thing to note, is that when in a lobby, you could be placed on pretty much any server in the world.

I'm sure that there is some sort of prioritisation working in the background, but if your local servers are full (as they seem to be at the moment with the latest season 9 release) then you will be placed in another region, by selecting a specific server in the data centre screen, it appears that you are only selecting a preference and not an exclusive location, therefore if you have Geofilter enabled, you will be kicked back to the data centre screen as soon as the game places you on a server outside of your filter area.

Share this post


Link to post
Share on other sites
45 minutes ago, Unfinished said:

It could be a server authentication error, but one thing to note, is that when in a lobby, you could be placed on pretty much any server in the world.

I'm sure that there is some sort of prioritisation working in the background, but if your local servers are full (as they seem to be at the moment with the latest season 9 release) then you will be placed in another region, by selecting a specific server in the data centre screen, it appears that you are only selecting a preference and not an exclusive location, therefore if you have Geofilter enabled, you will be kicked back to the data centre screen as soon as the game places you on a server outside of your filter area.

Thanks for the response. This issue was before Season 9. I haven't attempted to use the GeoFilter since then. My filter covers several servers on the East Coast so I am not too sure what you mean. I will say that with the filter off I am consistently connecting to my nearby servers. If it's kicking me out because it is outside of my filter radius, then the filter isn't working. That was the reason for bringing up my issue.

Share this post


Link to post
Share on other sites

I was about to start a new topic for the same issue but glad i searched. So i am Kind of in a similar situation, but the issue with Duma OS where it used to kick you out even before getting into the lobby has kind of been fixed as i dont get kicked out too often now, BUT getting kicked out of the game after every game ends. So every time i click to go back to the lobby it kicks me out of the game and gives me some kind of error i actually dont bother to look at it and just quick press buttons to go back, So i figured it out why it happens by looking at the geo filter screen. So every time it kicks me out there is a Blocked player icon appears on the map, which means that every time i leave lobby the game is trying to connect me to a different player or a server or a host, rather than to stay connected to the server i was when i was playing the game and it has happened 10/10. so i was wondering how to fix it, but after reading this thread i guess there is no fix until devs fix it?

Am i right @Netduma Fraser.

 

 

P.S this image was taken after i got kicked out with code leaf error and then going back into the main screen.

Capture.PNG

Share this post


Link to post
Share on other sites
29 minutes ago, Eefo said:

I was about to start a new topic for the same issue but glad i searched. So i am Kind of in a similar situation, but the issue with Duma OS where it used to kick you out even before getting into the lobby has kind of been fixed as i dont get kicked out too often now, BUT getting kicked out of the game after every game ends. So every time i click to go back to the lobby it kicks me out of the game and gives me some kind of error i actually dont bother to look at it and just quick press buttons to go back, So i figured it out why it happens by looking at the geo filter screen. So every time it kicks me out there is a Blocked player icon appears on the map, which means that every time i leave lobby the game is trying to connect me to a different player or a server or a host, rather than to stay connected to the server i was when i was playing the game and it has happened 10/10. so i was wondering how to fix it, but after reading this thread i guess there is no fix until devs fix it?

Am i right @Netduma Fraser

If you add that server to the allow list then that should prevent you getting kicked, if you can also give us the ID of it we can add it to the cloud

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

If you add that server to the allow list then that should prevent you getting kicked, if you can also give us the ID of it we can add it to the cloud

Id of the server to white list?
Sure going to do it now.

 

 

these are a few ones i whitelisted as they were in the polygon i drew.

 

p.s i guess i tried allowing the server before but it still kicked me out, i guess i'd have to allow every server i see in the polygon and then send you the ids so you allow them universally? 

Right?

Capture.PNG

Share this post


Link to post
Share on other sites
1 minute ago, Netduma Fraser said:

Yeah just the IDs of the servers that appear blocked when you get that error please, not the game server IDs that you're playing on

Gotchya

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

Yeah just the IDs of the servers that appear blocked when you get that error please, not the game server IDs that you're playing on

f6ce703b6b95babf Appeared Blocked.

Another one 6d42dfaadf0cedf2

 

 

6d42dfaadf0cedf2 this one is actually from Europe. 

Share this post


Link to post
Share on other sites
13 minutes ago, Netduma Fraser said:

Great thank you!

shall i edit the same post of reply in a new one so you'll get notify i guess?

Share this post


Link to post
Share on other sites
52 minutes ago, Eefo said:

shall i edit the same post of reply in a new one so you'll get notify i guess?

Post new replies if you could please, thanks for the additions!

Share this post


Link to post
Share on other sites
On 5/11/2021 at 4:17 PM, VigoDaCarpathien said:

Thanks for the response. This issue was before Season 9. I haven't attempted to use the GeoFilter since then. My filter covers several servers on the East Coast so I am not too sure what you mean. I will say that with the filter off I am consistently connecting to my nearby servers. If it's kicking me out because it is outside of my filter radius, then the filter isn't working. That was the reason for bringing up my issue.

The whole point of the geofilter is to keep your gameplay limited to a specified region to reduce lag, that's the job of the R2. In Apex, the server that you select as a local server is not neccessarily the server that you will be connected to on every game and as the servers are quite often oversubscribed, then the algorithm used to place players on another server will pick one and as is often the case, outside of a geofiltered zone, hence the connection errors, as the R2 blocks those connections. This is not something that could be fixed by Netduma in my opinion, it's a game related issue. Warzone, on the other hand, searches for an appropriate server based on ping and with Geofilter enabled, I have never had a disconnection issue, so the error is very much a code error from Apex.

If however you are getting blocked from servers within your geofilter radius (and you might know this to be the case if you specifically check) then the issue lies with the geofilter. My only issue with the geofilter is that it randomly turns itself off for some unknown reason and it is immediately obvious.

Share this post


Link to post
Share on other sites
55 minutes ago, Unfinished said:

The whole point of the geofilter is to keep your gameplay limited to a specified region to reduce lag, that's the job of the R2. In Apex, the server that you select as a local server is not neccessarily the server that you will be connected to on every game and as the servers are quite often oversubscribed, then the algorithm used to place players on another server will pick one and as is often the case, outside of a geofiltered zone, hence the connection errors, as the R2 blocks those connections. This is not something that could be fixed by Netduma in my opinion, it's a game related issue. Warzone, on the other hand, searches for an appropriate server based on ping and with Geofilter enabled, I have never had a disconnection issue, so the error is very much a code error from Apex.

If however you are getting blocked from servers within your geofilter radius (and you might know this to be the case if you specifically check) then the issue lies with the geofilter. My only issue with the geofilter is that it randomly turns itself off for some unknown reason and it is immediately obvious.

For us I think it's just a case of whitelisting some servers to prevent that error, I have asked the team to do so already so should be resolved soon. Geo-Filter turning off though is a weird one, setup the Geo-Filter how you want then reboot from the interface and see if that preserves the settings for longer.

Share this post


Link to post
Share on other sites
14 hours ago, Netduma Fraser said:

For us I think it's just a case of whitelisting some servers to prevent that error, I have asked the team to do so already so should be resolved soon. Geo-Filter turning off though is a weird one, setup the Geo-Filter how you want then reboot from the interface and see if that preserves the settings for longer.

The geofilter has been stable of late. I did grant access for the devs to my R2 when requested a while back and also provided some logs, hopefully of use. The main issue with the R2 is the connection instability, with one or two disconnects a day. I understand that this is being worked on?

Share this post


Link to post
Share on other sites
3 hours ago, Unfinished said:

The geofilter has been stable of late. I did grant access for the devs to my R2 when requested a while back and also provided some logs, hopefully of use. The main issue with the R2 is the connection instability, with one or two disconnects a day. I understand that this is being worked on?

Thanks for the update. Yes we are still working on this issue, it's top priority for us at the moment as we understand how frustrating this issue is for users that experience it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...