Jump to content
Wayne

Geofilter Issues?

Recommended Posts

2 hours ago, OldNOff said:

As long as I don't deny that server connection I can find a game yes, but thats not the point Liam. It seems like geofilter is not working properly no matter where I set my location or how big the radius is, if I'm using a vpn or if I set the geofilter to ping assist only, the game keeps trying to connect to that server.
 I was trying to connect thru the vpn just to check if it kept doing the same, no change.

I also realized that no matter how you set your QOS(0.8Up/Dwn for my tests) the connection to CoD warzone is not throttled and the bandwidth keeps showing 4.xxx.xxxkbps. Cold War registers the bandwidth properly, and all the speedtests I've made were actually ok according to the throttled speeds, except for warzone.

I know there's no way the game could use more bandwidth than what its assigned in QOS, but somehow the game keeps reporting the wrong bandwidth.

Understood, you haven't manually allowed that Spain server have you? I'm pretty sure it's an authentication server hence why it appears to be manually allowed. When you're in game, is there still only one server showing on the map? You should be seeing another server/peer appearing.

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Liam said:

@OldNOff If you set your radius around Spain, are you able to find a game? The issue may be that you're trying to force a very distant server.

@thewilloxdiaz Let us know how you get on!

Still the same. Found games and says i cant join the lobby and is forcing me to Europe. Location is on the ocean, 66 ms ping on Ping Assist, nothing.

Share this post


Link to post
Share on other sites
20 hours ago, thewilloxdiaz said:

Still the same. Found games and says i cant join the lobby and is forcing me to Europe. Location is on the ocean, 66 ms ping on Ping Assist, nothing.

As a test, could you please search for a game with filtering mode disabled and see which servers you connect to?

 

17 hours ago, OldNOff said:

Nope, I just tried blocking it for a while and CoD didn't want to connect so i just deleted the rule after a few minutes. But it is a NL server what we are talking about, not a Spanish one.

I just made a few more tests setting my location to diferent countries(NA east and west, Italy, Uk London and Manchester, France and Mexico) using the vpn and that NL server always pops up as allowed when connecting or searching for a game even if its out of the radius, but... after that it seems like I'm able to connect to the region I want to, so I guess you are right and it must be an authentication server. The app is really laggy and I must reboot the R2 for the geofilter to work after every change though, otherwise geofilter its not showing anything but the NL server.

What about the bandwidth thing I told you, do you know what could be causing such a weird behavior,  can you test if its working properly for you by any chance?

 

Ah OK - my bad.
Sorry to hear that DumaOS is running slow for you, could you just confirm which firmware you're currently on?

CoD will be categorised within the DumaOS Classified Games rule so it will supersede any limitations set by Bandwidth allocation and Congestion control, as you mentioned though it shouldn't require very much bandwidth. 

 

On 3/29/2021 at 2:07 PM, OldNOff said:

the bandwidth keeps showing 4.xxx.xxxkbps.

Where exactly are you seeing this?

Share this post


Link to post
Share on other sites
1 hour ago, designerema said:

is this Normal???

That is an authentication server which we have allowed automatically so it is normal

1 hour ago, OldNOff said:

Got some news I think, after further testing I was able to block that NL server and connect to UK, Italy and Spanish(showing in France) servers, but it took me like 20 game reboots to make the geofilter work "properly", and when I say "properly" its because when you block that NL server the game can't connect to online services unless you have previously allowed the other regions servers manually (even when the radius is set to allow one of these regions), the only way you will see these servers showing up is on boot and with "Auto Ping Host" disabled, every time you boot the game a few servers show up and you have to allow them manually, after every server in that region(and a few servers detected as peers) are allowed the game will deny the connection to NL server and it will connect to the server allowed by the geofilter.

I will try to upload a video later today or tomorrow if I have time.

PS: R2 3.0.205, but I don't think DumaOs is running slow tbh Liam, I was using firefox and it seems its kind of buggy, after switching to chrome everything is working nicely and I dont have to reboot the router for every change to be applied.

Ps2: You can check the bandwidth in-game, settings/account, bottom right corner.

EDIT: Adding a Gif so you guys can see the process. Ps4 using RemotePlay for my tests.

I'm surprised you even managed to block the server, that's very interesting though. Would be intrigued to see the video! 

Share this post


Link to post
Share on other sites
4 hours ago, Netduma Liam said:

As a test, could you please search for a game with filtering mode disabled and see which servers you connect to?

 

Ah OK - my bad.
Sorry to hear that DumaOS is running slow for you, could you just confirm which firmware you're currently on?

CoD will be categorised within the DumaOS Classified Games rule so it will supersede any limitations set by Bandwidth allocation and Congestion control, as you mentioned though it shouldn't require very much bandwidth. 

 

Where exactly are you seeing this?

Not always im connecting to the same server, i think that is obvious because there are times that i have 80 ms, 100 ms, 130 ms and even 160 ms.

PIC 1 is Filtering mode disabled, Ping Assist 0, no Auto Ping Host. Those are the servers that showed while i was on a game. Still is showing the Europe server. While in game i was 125 ms ping.

PIC 2 server latency 

PIC 3 is the servers i have available when i boot the game.

 

image.thumb.png.5b006ac1cb288fc28fef4ec844fd9ff9.png

 

image.thumb.png.c07f878b059b56877b30f096ba60c0dc.png

 

 

 

image.thumb.png.8764a614018893e17e277513e531be5f.png

 

Share this post


Link to post
Share on other sites
1 hour ago, OldNOff said:

Right now I'm not sure If I will upload the video to be honest, after all the time it took me to make it work as desired I'm not willing to delete all the config to start from scratch again only to record 3h video + edit time of router config.

We need a backup config feature guys!!!! If you dont want us to mess with the config file at least let the router upload and retrieve the config from a server of your choice, that would be really helpful for this cases.

At this point Im not sure anymore if that server is an authentication server or if it should be automatically allowed, I think it would be far easier to connect to other regions if I could deny the server without so much trouble.

That's totally fair enough and we are looking at doing that.

It's a Stun server so definitely not an actual game server

17 minutes ago, thewilloxdiaz said:

Not always im connecting to the same server, i think that is obvious because there are times that i have 80 ms, 100 ms, 130 ms and even 160 ms.

PIC 1 is Filtering mode disabled, Ping Assist 0, no Auto Ping Host. Those are the servers that showed while i was on a game. Still is showing the Europe server. While in game i was 125 ms ping.

PIC 2 server latency 

PIC 3 is the servers i have available when i boot the game.

I'm not sure we can suggest anything else at this point and I know we have both been trying to figure this out for years for you. Do you play with any people from your country online? What ping do they get when they play solo?

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

That's totally fair enough and we are looking at doing that.

It's a Stun server so definitely not an actual game server

I'm not sure we can suggest anything else at this point and I know we have both been trying to figure this out for years for you. Do you play with any people from your country online? What ping do they get when they play solo?

I play solo. Sometimes, when im on those Florida or 66 ms servers, i play against people from my country or nearby countries. I dont know anyone who plays COD MW, CW or WZ but im gonna asume that the lowest ping for anyone based on Ecuador is 70 - 75 ms on MW- and 80 ms on CW. I have to mention, but i think you already know that, ping heatmap says 66 ms but in game is 70 ms for MW and 80 ms for CW.

 

The only thing i want to achieve is play on those less ping server when is desired. 

 

image.thumb.png.6f1d0ee4a5a9bcf8f1b9109207710603.png

image.thumb.png.f3e587553064d1b63125c9bad6380de7.png

Share this post


Link to post
Share on other sites
9 minutes ago, OldNOff said:

Si estás dispuesto a perder más tiempo te puedo decir los pasos que yo he seguido para evitar conectar a ese servidor de forma parcialmente satisfactoria debo decir. Porque me estaba haciendo lo mismo que a ti intentando conectar al mismo server todo el rato, y mas importante, el geofiltro jamás abría ninguna conexion a otro server excepto a ese, me parece extraño que sea solamente un servidor de autentificacion, pero supongo que esta gente sabrá lo que dice obviamente.

Edit: Sorry btw, I assumed you speak Spanish, do you need a translation?

Thanks for the help, no translation needed. Shoul i have to allow all those US servers? 

image.thumb.png.33264727acb33d1655a7c82ce8468f0e.png

Share this post


Link to post
Share on other sites
1 hour ago, thewilloxdiaz said:

I play solo. Sometimes, when im on those Florida or 66 ms servers, i play against people from my country or nearby countries. I dont know anyone who plays COD MW, CW or WZ but im gonna asume that the lowest ping for anyone based on Ecuador is 70 - 75 ms on MW- and 80 ms on CW. I have to mention, but i think you already know that, ping heatmap says 66 ms but in game is 70 ms for MW and 80 ms for CW.

The only thing i want to achieve is play on those less ping server when is desired. 

Give the above ago, if that works then maybe we need to have a look at why that is needed and see if there is anything we can do to get around that

Share this post


Link to post
Share on other sites
59 minutes ago, OldNOff said:

I would go for the low ping servers you said if I were you.

Here's how I did it.


Disable Auto Ping Host.
Boot the game, a bunch of servers will show up for a few seconds, start allowing the servers in the region you want to connect to. It's going to take some time.
Don't worry about that Nl server yet, the game will still connect to NL
Close and re-open the game and keep adding servers.
After 4 or 5 restarts you will probably have those servers allowed(you will realize because there are no new servers to allow or deny and the ones shown are already allowed), if you see a peer showing in the exact same location where the server is, allow it aswell.

Now repeat the same steps but blocking the NL server.


Boot the game, deny servers until no new servers are shown, at some point you might not be able to go online, don't panic, keep restarting the game and blocking servers, if you reach that point were your game is not able to connect to online services, start the game a few more times and make sure the server shown as blocked is always the same and then allow only that server connection.


And I think that should work, I did the whole process twice trying to set my router up and now its connecting to the servers inside the radius.

The real problem is that you have to repeat the same steps if you want to connect to a diferent server location rendering the geofilter useless unless configured properly in advance, but after that initial setup you can switch locations using the filter radius.


That's how it is working right now for me,  Its a pain in the...but at least its working I guess.

Si tienes alguna pregunta o no tienes algo claro no dudes.

Suerte!
 

Thanks again for taking time to help. The "Deny" button is in grey that means it doesnt allow me to deny it. It happens only with that NL server.

 

image.thumb.png.cf7d6e708be436c4656be6e0ab950c62.png

 

 

Share this post


Link to post
Share on other sites
21 hours ago, OldNOff said:

You're welcome amigo. Allow it and change it to deny after the rule is created, I think thats what I did. Misma ID como puedes comprobar en la foto.

NL1.png

Espero que te sea de ayuda, esta es mi lista de servidores denegados. Si ves algún servidor repetido por casualidad, es debido a editar la foto rapido.
deny.jpg



------------------------------------------------------------------------EDIT----------------------------------------------------------------------------
My last report unless you need more info.
 

I hope you guys put the same effort trying to fix the issue as I did trying to identify it.

 

The good news, my method is working and I'm able to switch regions at pleasure as you can check in the video im attaching.

The bad news, now I can clearly tell the geofilter is not working properly(being kind) unless it was previously configured following the steps I mentioned before(start game, allow servers, deny, repeat, repeat, repeat, repeat, repeat, until you get bored).

Such config took me MORE THAN 3 HOURS just for the UK region!!! I had to MANUALLY ADD 82 servers for the geofilter to work consistenly, and even more servers kept showing up every time I started the game, but I finally gave up, that means I had to restart the game MORE THAN 82 TIMES just to make it work!!!. So at this point guys, in my opinion, when you have to put so much effort to make a system work, such system is not working. Imagine the amount of time it could take to allow a big populated region in North America, there must be hundred of servers and that will be an impossible task to accomplish, just for one region!

https://youtu.be/LjngYFuHejM

It is a real pain in the ass. Its more frustrating that i cant even Deny those servers. As soon the game boots, i see those NL server then tried to Deny and i cant because the Deny button isnt available, so i Allowed those servers and even i added a name, closed the game and boot again and still cant Deny it. ID: ccb9edb8566b1d22, ccb9b681566b1d22, ccb9b580566b1d22

 

image.thumb.png.2529a15a9e791546e7ccc81dbb532a4e.png

 

Share this post


Link to post
Share on other sites
21 hours ago, Netduma Fraser said:

Give the above ago, if that works then maybe we need to have a look at why that is needed and see if there is anything we can do to get around that

Already gave it a try. I cant even Deny the server because the Deny button is not available when i click on those specific servers.

ID: ccb9edb8566b1d22, ccb9b681566b1d22, ccb9b580566b1d22

image.thumb.png.ab5e082ba230ac19e38a76d0623f1bb0.png

 

Share this post


Link to post
Share on other sites

You shouldn't be able to deny them, that is expected but were you able to do it by using the workaround above? Allowing them, then pinging from the list and denying that way?

Share this post


Link to post
Share on other sites
17 hours ago, Netduma Fraser said:

You shouldn't be able to deny them, that is expected but were you able to do it by using the workaround above? Allowing them, then pinging from the list and denying that way?

Yes, just managed to Deny those servers right from the list by clicking on the "ping" icon. Now i reached the point where i cant connect to Cod online services.

image.thumb.png.62b2573798063a7e6eef0286ea5bac0c.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...