Jump to content
Sign in to follow this  
K0NSPIRACY

Xbox One X not picking up IPv6

Recommended Posts

I've mentioned this in my previous posts so probably needs its own thread to resolve.

Xbox One X is not picking up IPv6 despite it being enabled on both the BT Smarthub2 (it can't be turned off) and R2. 

Having had several issues with the R2, I did disconnect the R2 for a few days and connected the Xbox One X direct to the BT Smarthub2 which picked up both IPv4 and IPv6.

I've done the requested actions previously (turning off IPv6, rebooting and reactivating) but it does not resolve the issue.

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Fraser said:

We're testing a firmware at the moment that has a fix for devices not getting an IPv6 address so it should be fixed for the next firmware.

Ok thanks Fraser. 👍

Share this post


Link to post
Share on other sites
On 2/11/2021 at 12:58 PM, K0NSPIRACY said:

I've mentioned this in my previous posts so probably needs its own thread to resolve.

Xbox One X is not picking up IPv6 despite it being enabled on both the BT Smarthub2 (it can't be turned off) and R2. 

Having had several issues with the R2, I did disconnect the R2 for a few days and connected the Xbox One X direct to the BT Smarthub2 which picked up both IPv4 and IPv6.

I've done the requested actions previously (turning off IPv6, rebooting and reactivating) but it does not resolve the issue.

dont worry man. my xbox one x doesnt pick IPv6 either with the R2 router. Doesnt affect its performance any.

Share this post


Link to post
Share on other sites
On 2/11/2021 at 8:08 PM, Netduma Fraser said:

We're testing a firmware at the moment that has a fix for devices not getting an IPv6 address so it should be fixed for the next firmware.

Hi Fraser. I've upgraded to 3.0.205 and saw the notes from Liam stating "Fixed occasional issue where IPv6 devices weren't assigned DHCP IPs".

I can confirm that my Xbox One X still isn't picking up an IPv6 when connected via the R2 (but it does when connected directly to BT Smarthub2).

I've checked the IPv6 settings in BT Smarthub2 and found the following settings which can be configured:

ULA Enabled: no/yes
IPv6 adress allocation: stateful/stateless/both/off
Pinholes: options to create new IPv6 pinhole (requires port information)

I currently have ULA disabled and IPv6 is now set to stateful however stateless also doesn't make any difference. Should I change any of these settings?

I've also tried turning off IPv6, rebooting and reactivating in 3.0.205 but the Xbox still doesn't get an IPv6 address.

 

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

Did you factory reset the R2 after upgrading? Does the R2 get an IPv6 address if you look at attached devices on the hub?

Yeah I did the factory reset after upgrade and did the other method you suggested. 

If you mean attached devices in Device Manager on the R2, then I can see some devices have IPv6 addresses (MacBook, Apple TV and iPhone) on 5.0GHz wifi but the Xbox (wired), Nest (5.0GHz), Harmony and Sky Q don’t (both 2.4GHz wifi).

On the BT Smarthub2, I can see the R2 has a both the standard IP (also reserved in DMZ) and IPv6 address.

Share this post


Link to post
Share on other sites

Thanks for that. On the BT hub it will have a feature/section where it shows what devices are connected and their local IP addresses, does it show any of those devices/the R2 having an IPv6 address?

Share this post


Link to post
Share on other sites
33 minutes ago, Netduma Fraser said:

Thanks for that. On the BT hub it will have a feature/section where it shows what devices are connected and their local IP addresses, does it show any of those devices/the R2 having an IPv6 address?

Yeah the only device I have connected to the BT Smarthub2 is the R2. As mentioned in previous reply, the R2 does have an IPv6 address assigned as well as the standard IP which is reserved in DMZ.

Share this post


Link to post
Share on other sites

I wouldn't worry about IPV6 on the Xbox.

It won't make a difference in your gaming experience. 

Share this post


Link to post
Share on other sites
47 minutes ago, K0NSPIRACY said:

Yeah the only device I have connected to the BT Smarthub2 is the R2. As mentioned in previous reply, the R2 does have an IPv6 address assigned as well as the standard IP which is reserved in DMZ.

Great, thank you. A bit of a seemingly odd request but it does make sense - can you disable anything you've done on the R2 to ensure the Xbox gets an Open NAT, UPnP, DMZ, port forwarding etc and see if it gets an IPv6 address then?

Share this post


Link to post
Share on other sites
51 minutes ago, Netduma Fraser said:

Great, thank you. A bit of a seemingly odd request but it does make sense - can you disable anything you've done on the R2 to ensure the Xbox gets an Open NAT, UPnP, DMZ, port forwarding etc and see if it gets an IPv6 address then?

The only thing I’ve done is add the port forwarding rules on the R2. On the BT Smarthub2, I think all I’ve done is disable UPNP, turn firewall off and add the R2 IP into DMZ. I can reset everything and see if it gives the Xbox an IPv6...I’ve had enough tinkering for one day so I’ll do it next time something goes wrong 👍

Share this post


Link to post
Share on other sites

You can leave the R2 in the DMZ on the BT Hub but on the R2 disable port forwarding and UPnP please - my thinking is technically IPv6 does not need any of those port solutions to get an Open NAT so if the Xbox sees it's struggling with IPv4 then it might force it onto IPv6.

Share this post


Link to post
Share on other sites

From my understanding your r2 is connected to your hub thats in router mode and no hub i know of can send this ipv6 through its lan for the r2 to use as a WAN so its can assign its devices a ipv6 address

You will not get ipv6 to your xbox with your setup. you may get one if the r2 connects using PPPoE

 

Share this post


Link to post
Share on other sites

Im connected with

fritzbox -> r2

 

i get ipv6

what i did was

On the r2 Go to network settings look at dhcp

Do a checkmark on youre xbox (you will se youre console name there) and set youre reserved ip to 100 for the xbox

The xbox should always geht the same ip adress now.

go back to network settings on r2

set dmz to ip 100

(192.168.77.100)

(make sure ipv6 is active on wan and lan)

 

now turn off youre

bt - r2- xbox

Turn off xbox completely by pressing and holding the power button for 10seconds on the console !
 

Or unplug it because fast boot may cause some problems.

 

Start youre bt until its ready

start youre r2 until its ready

start youre xbox an check the nat and do a nat type test.

Share this post


Link to post
Share on other sites
On 2/19/2021 at 12:03 AM, Netduma Fraser said:

You can leave the R2 in the DMZ on the BT Hub but on the R2 disable port forwarding and UPnP please - my thinking is technically IPv6 does not need any of those port solutions to get an Open NAT so if the Xbox sees it's struggling with IPv4 then it might force it onto IPv6.

Done. Did a factory reset, no port forwarding and UPnP disabled. Still no IPv6.

Share this post


Link to post
Share on other sites
On 2/19/2021 at 2:14 PM, Anilman92 said:

Im connected with

fritzbox -> r2

 

i get ipv6

what i did was

On the r2 Go to network settings look at dhcp

Do a checkmark on youre xbox (you will se youre console name there) and set youre reserved ip to 100 for the xbox

The xbox should always geht the same ip adress now.

go back to network settings on r2

set dmz to ip 100

(192.168.77.100)

(make sure ipv6 is active on wan and lan)

 

now turn off youre

bt - r2- xbox

Turn off xbox completely by pressing and holding the power button for 10seconds on the console !
 

Or unplug it because fast boot may cause some problems.

 

Start youre bt until its ready

start youre r2 until its ready

start youre xbox an check the nat and do a nat type test.

Thanks for your reply. After doing a factory reset, I have done all that and unfortunately still no IPv6 address on Xbox One X. 

I give up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...