Jump to content
Kyusuke39

COD CW(PC): How can I have the NAT type: "Open" while on a wireless connection?

Recommended Posts

8 hours ago, Netduma Fraser said:

It may be counter intuitive but could you change NAT back to secured please and see if you get an Open NAT on them then?

Indeed it does sound counter-intuitive but it ended up working for some reason lol

My PC can now be the second device to connect to Cold War and still obtain a NAT Type: "Open"

 

Question: Will keeping my NAT Filtering "Secured" present any significant issues in other applications/online multiplayer games?

 

The only remaining issue is the PS4 was never able to obtain a NAT Type: "Open", no matter if it was the first or second device to connect to Cold War.

6 hours ago, DanyKTM said:

could you try 3074 for PS4, and also make sure you have static IP adress on it

and put 3075 for your PC with static IP adress. both wired.   I tried many time to do this by myself, but I never tried to put 3074 for ps4 and 3075 for PC.  maybe you will get luck !

I'm going to try this right now, I'll report back my findings soon.

Share this post


Link to post
Share on other sites
6 hours ago, DanyKTM said:

could you try 3074 for PS4, and also make sure you have static IP adress on it

and put 3075 for your PC with static IP adress. both wired.   I tried many time to do this by myself, but I never tried to put 3074 for ps4 and 3075 for PC.  maybe you will get luck !

Yeah, that didn't work.
I obtained NAT Type: "Moderate" on my PC when wired.

I obtained NAT Type: "Open" on my PS4 when on a wireless connection. 

I want both devices to obtain a NAT Type: "Open"
The PC will normally be Wired and the PS4 will be on a wireless connection.

Thanks for the suggestion! 

Share this post


Link to post
Share on other sites
10 hours ago, Kyusuke39 said:

Question: Will keeping my NAT Filtering "Secured" present any significant issues in other applications/online multiplayer games?

No, it shouldn't do!

Is the PCs NAT type open or moderate now? 

Share this post


Link to post
Share on other sites

Correct, as long as I have the appropriate Port Forwarding Rules set up for the type of connection I'm going to use, regardless of if it's the first or second device to connect to Cold War then it will obtain a NAT Type "Open".

Share this post


Link to post
Share on other sites

I didn't change anything from the UPnP page. 

It's default but I'll post a screenshot when I get home.

I conducted the tests without ever using/adding devices to the Geo-Filter. 

 

Share this post


Link to post
Share on other sites

I want to see if it's trying to open any ports at all, could be conflicting with port forwarding or it could be its not adjusting fast enough, in which case we can try to adjust that. Also I've just noticed you're using IPv6, do the LAN devices get IPv6 addresses in the device manager?

Share this post


Link to post
Share on other sites

Yes, my LAN devices(Computer) get assigned a IPV6 Address in the device manager. 

UPnP.png

Note: IP Address 192.168.1.6 is the PS4 on a Wireless connection.

Share this post


Link to post
Share on other sites

Okay thank you. An odd suggestion but can you make sure IPv6 is enabled for LAN/WAN and then disable UPnP, remove port forwarding rules and put NAT to secure please. Then see if you get an open NAT on the PC and console - reason I ask is because with IPv6 in theory you should get an Open NAT without any of those options enabled. This may very much depend on the console as PS don't really support IPv6.

Share this post


Link to post
Share on other sites
33 minutes ago, Netduma Fraser said:

 can you make sure IPv6 is enabled for LAN/WAN

How can I check that?
I checked Settings->WAN Setup/Settings-> LAN Set Up and they don't mention IPV6.

Share this post


Link to post
Share on other sites
1 hour ago, Kyusuke39 said:

How can I check that?
I checked Settings->WAN Setup/Settings-> LAN Set Up and they don't mention IPV6.

It's in Settings > Advanced Settings > IPv6 then enable it however you need to for your connection, then make sure for LAN its using as DHCP server.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

An odd suggestion but can you make sure IPv6 is enabled for LAN/WAN and then disable UPnP, remove port forwarding rules and put NAT to secure please. Then see if you get an open NAT on the PC and console

Didn't work, the PC got a NAT Type: "Moderate" connection when on a wired connection.
I changed everything to what you exactly said to do and I even changed the NAT Filter to Open for further testing after your method didn't work.
Changing it to NAT Filter to Open did nothing to help the issue lol

Share this post


Link to post
Share on other sites

Okay disappointing but thanks for trying. If we go back to port forwarding with 3074 for one device, 3075 for the other etc. Do that again but have the internal ports be 3074 so for example:

PS - 3074 external 3074 internal
PC - 3075 external 3074 internal

Share this post


Link to post
Share on other sites
On 1/23/2021 at 6:18 AM, Netduma Fraser said:

Okay disappointing but thanks for trying. If we go back to port forwarding with 3074 for one device, 3075 for the other etc. Do that again but have the internal ports be 3074 so for example:

PS - 3074 external 3074 internal
PC - 3075 external 3074 internal

Sorry for the delay but I finally had the chance to do conduct tests.
Sadly, this method didn't work since I got NAT Type: Moderate on my PC

Share this post


Link to post
Share on other sites

Could you try the other way for the PC please so:

PC - 3074 external 3075 internal 

and keep the PS the same if it allows you to which it may not. If it doesn't then do 3075 for external and internal for the PC.

Share this post


Link to post
Share on other sites
On 1/21/2021 at 10:37 AM, DanyKTM said:

could you try 3074 for PS4, and also make sure you have static IP adress on it

and put 3075 for your PC with static IP adress. I tried many time to do this by myself, but I never tried to put 3074 for ps4 and 3075 for PC.  maybe you will get luck !

3074 for PS4 
3075 for PC
I've done it before, and it NAT Type: Open the PS4 but the PC got Moderate 😕

8 minutes ago, Netduma Fraser said:

and keep the PS the same if it allows you to which it may not. 

Didn't allow it.

Share this post


Link to post
Share on other sites
7 minutes ago, Netduma Fraser said:

Thanks for trying, I think I'm going to have to contact NG on this and see if they can take a look because it really shouldn't be this hard to get an open NAT.

That would be great if you can!
Just send them this whole thread lol

If they do find solution them tell them to list the exact options/configurations they did.
My goal is to have a NAT Type: "Open" on both a PC and PS4 when they are connected to Cold War at the same time and connection type shouldn't matter to achieve that.

Share this post


Link to post
Share on other sites

Stupid question,

Did you tried it only with your ISP modem ? Are you able to get open Nat on PC and PS4 ?

For my side, I tried many thing and I wasnt ever able to get open nat on PC and PS4, so now, My Pc show me open nat and my PS4 moderate and I cant see anydifference.

But yes It should be good to be able to have open nat on both.  The fact is, PS4 and PC use both 3074 to get open nat, but we can't apply manually 3074 for 2 differents consoles

Share this post


Link to post
Share on other sites
2 hours ago, DanyKTM said:

Stupid question,

Did you tried it only with your ISP modem ? Are you able to get open Nat on PC and PS4 ?

For my side, I tried many thing and I wasnt ever able to get open nat on PC and PS4, so now, My Pc show me open nat and my PS4 moderate and I cant see anydifference.

But yes It should be good to be able to have open nat on both.  The fact is, PS4 and PC use both 3074 to get open nat, but we can't apply manually 3074 for 2 differents consoles

Yes, I tried various methods with my ISP Modem.

In fact there's a whole different thread, involving it.

One of the reasons I got a CM1000V2 is because my ISP Modem wasn't great and whatever we tried didn't work.

 

Share this post


Link to post
Share on other sites

@Kyusuke39 thank you for your patience with all this. I have received word from NG that they are working to get this issue resolved but that it isn't a quick fix unfortunately. The good thing is that as you're on moderate you shouldn't really have problems connecting to anyone and it won't impact your game connection negatively.

Share this post


Link to post
Share on other sites
18 minutes ago, Netduma Fraser said:

@Kyusuke39 thank you for your patience with all this. I have received word from NG that they are working to get this issue resolved but that it isn't a quick fix unfortunately. The good thing is that as you're on moderate you shouldn't really have problems connecting to anyone and it won't impact your game connection negatively.

Thank you for all your help and going the extra mile! 

Please let me know about any updates to the situation and if there's any solutions, I'll gladly test them out for you!

Share this post


Link to post
Share on other sites

@Kyusuke39 I have been provided a firmware by Netgear that should resolve this issue, I have private messaged it to you. Please provide any feedback you have on the version here and I can relay that back to Netgear. Thanks for your patience!

Share this post


Link to post
Share on other sites
23 minutes ago, Netduma Fraser said:

@Kyusuke39 I have been provided a firmware by Netgear that should resolve this issue, I have private messaged it to you. Please provide any feedback you have on the version here and I can relay that back to Netgear. Thanks for your patience!

Thank you, I have replied to your private message!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...