Jump to content
Sign in to follow this  
iMoD1998

DumaOS Beta 3.0 - XR700 IPv6 Problems

Recommended Posts

I've notice a problem with IPv6 setting on the latest beta. Even with options disabled its still assigning IPv6 addresses like the following:

image.png.302997fafa1747e4aa5495fdb8a93626.png

Not sure if its directly related but seems on linux devices, im having problems with DNS queries taking alot of time as they are expecting AAA records causing web requests to take around 5+ seconds.

Ive provided a TCP dump of an example web request:

tcpdump -vvv -s 0 -l -n port 53
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
01:24:25.441601 IP (tos 0x0, ttl 64, id 58816, offset 0, flags [DF], proto UDP (17), length 57)
    192.168.1.253.34549 > 1.1.1.1.53: [bad udp cksum 0xc4dd -> 0x7654!] 7015+ A? ifconfig.so. (29)
01:24:25.441613 IP (tos 0x0, ttl 64, id 58817, offset 0, flags [DF], proto UDP (17), length 57)
    192.168.1.253.34549 > 1.1.1.1.53: [bad udp cksum 0xc4dd -> 0xe057!] 38499+ AAAA? ifconfig.so. (29)
01:24:25.454176 IP (tos 0x0, ttl 57, id 28155, offset 0, flags [DF], proto UDP (17), length 73)
    1.1.1.1.53 > 192.168.1.253.34549: [udp sum ok] 7015 q: A? ifconfig.so. 1/0/0 ifconfig.so. [56m35s] A 54.146.53.133 (45)
01:24:26.212361 IP (tos 0x0, ttl 64, id 59565, offset 0, flags [DF], proto UDP (17), length 60)
    192.168.1.253.34767 > 1.1.1.1.53: [bad udp cksum 0xc4e0 -> 0x965f!] 40193+ A? api.github.com. (32)
01:24:26.224390 IP (tos 0x0, ttl 57, id 52197, offset 0, flags [DF], proto UDP (17), length 76)
    1.1.1.1.53 > 192.168.1.253.34767: [udp sum ok] 40193 q: A? api.github.com. 1/0/0 api.github.com. [15s] A 140.82.121.5 (48)
01:24:26.224430 IP (tos 0x0, ttl 64, id 59571, offset 0, flags [DF], proto UDP (17), length 60)
    192.168.1.253.34767 > 1.1.1.1.53: [bad udp cksum 0xc4e0 -> 0x7f41!] 46084+ AAAA? api.github.com. (32)
01:24:26.236925 IP (tos 0x0, ttl 57, id 52200, offset 0, flags [DF], proto UDP (17), length 144)
    1.1.1.1.53 > 192.168.1.253.34767: [udp sum ok] 46084 q: AAAA? api.github.com. 0/1/0 ns: github.com. [6m52s] SOA ns-1707.awsdns-21.co.uk. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400 (116)
01:24:26.538234 IP (tos 0x0, ttl 64, id 59832, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.1.253.40246 > 1.1.1.1.53: [bad udp cksum 0xc4eb -> 0x881a!] 48328+ A? raw.githubusercontent.com. (43)
01:24:26.538244 IP (tos 0x0, ttl 64, id 59833, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.1.253.40246 > 1.1.1.1.53: [bad udp cksum 0xc4eb -> 0xad15!] 31949+ AAAA? raw.githubusercontent.com. (43)
01:24:26.549642 IP (tos 0x0, ttl 57, id 55967, offset 0, flags [DF], proto UDP (17), length 170)
    1.1.1.1.53 > 192.168.1.253.40246: [udp sum ok] 48328 q: A? raw.githubusercontent.com. 5/0/0 raw.githubusercontent.com. [23s] CNAME github.map.fastly.net., github.map.fastly.net. [23s] A 151.101.0.133, github.map.fastly.net. [23s] A 151.101.192.133, github.map.fastly.net. [23s] A 151.101.64.133, github.map.fastly.net. [23s] A 151.101.128.133 (142)
01:24:30.446231 IP (tos 0x0, ttl 64, id 62125, offset 0, flags [DF], proto UDP (17), length 57)
    192.168.1.253.34549 > 1.1.1.1.53: [bad udp cksum 0xc4dd -> 0x7654!] 7015+ A? ifconfig.so. (29)
01:24:30.463758 IP (tos 0x0, ttl 57, id 31815, offset 0, flags [DF], proto UDP (17), length 73)
    1.1.1.1.53 > 192.168.1.253.34549: [udp sum ok] 7015 q: A? ifconfig.so. 1/0/0 ifconfig.so. [56m27s] A 54.146.53.133 (45)
01:24:30.463804 IP (tos 0x0, ttl 64, id 62132, offset 0, flags [DF], proto UDP (17), length 57)
    192.168.1.253.34549 > 1.1.1.1.53: [bad udp cksum 0xc4dd -> 0xe057!] 38499+ AAAA? ifconfig.so. (29)
01:24:30.475736 IP (tos 0x0, ttl 57, id 31826, offset 0, flags [DF], proto UDP (17), length 134)
    1.1.1.1.53 > 192.168.1.253.34549: [udp sum ok] 38499 q: AAAA? ifconfig.so. 0/1/0 ns: ifconfig.so. [22m37s] SOA ns1.p16.dynect.net. admin.samuelkadolph.com. 2020111000 3600 600 604800 1800 (106)
01:24:31.542697 IP (tos 0x0, ttl 64, id 62832, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.1.253.40246 > 1.1.1.1.53: [bad udp cksum 0xc4eb -> 0x881a!] 48328+ A? raw.githubusercontent.com. (43)
01:24:31.554259 IP (tos 0x0, ttl 57, id 58506, offset 0, flags [DF], proto UDP (17), length 170)
    1.1.1.1.53 > 192.168.1.253.40246: [udp sum ok] 48328 q: A? raw.githubusercontent.com. 5/0/0 raw.githubusercontent.com. [17s] CNAME github.map.fastly.net., github.map.fastly.net. [17s] A 151.101.64.133, github.map.fastly.net. [17s] A 151.101.192.133, github.map.fastly.net. [17s] A 151.101.0.133, github.map.fastly.net. [17s] A 151.101.128.133 (142)
01:24:31.554299 IP (tos 0x0, ttl 64, id 62835, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.1.253.40246 > 1.1.1.1.53: [bad udp cksum 0xc4eb -> 0xad15!] 31949+ AAAA? raw.githubusercontent.com. (43)
01:24:31.566468 IP (tos 0x0, ttl 57, id 58517, offset 0, flags [DF], proto UDP (17), length 164)
    1.1.1.1.53 > 192.168.1.253.40246: [udp sum ok] 31949 q: AAAA? raw.githubusercontent.com. 1/1/0 raw.githubusercontent.com. [22s] CNAME github.map.fastly.net. ns: fastly.net. [22s] SOA ns1.fastly.net. hostmaster.fastly.com. 2017052201 3600 600 604800 30 (136)

This issue is alleviated only when forcing curl to work in IPv4 mode.

This device also does not have an IPv6 address, which makes this even more confusing.

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.253  netmask 255.255.255.0  broadcast 192.168.1.255
        ether XX:XX:XX:XX:XX:XX  txqueuelen 1000  (Ethernet)
        RX packets 382473  bytes 29037121 (27.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 296761  bytes 14461330039 (13.4 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 92  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 117  bytes 11651 (11.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 117  bytes 11651 (11.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Any help would be apricated. 

If it helps any more this was taken from an unraid server thats using the 10GB sfp+ port.

I've also experienced this problem on other linux based devices like a raspberry pi aswell. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...