Jump to content
SteelForeHeed

No Support British Telecom (BT) IGMP Proxying XR1000

Recommended Posts

I purchased a Netgear Nighthawk XR1000 to replace my XR500. Everything seems to be working fine and I have also updated the latest firmware (v1.0.0.52).
My ISP is BT broadband and I also have BT TV. There was a setting in WAN Setup in the XR500, Support British Telecom (BT) IGMP Proxying, which had to be ticked
to be able to watch my BT subscription channels through my BT View Box. This setting does not exist in the XR1000 so I cannot access the subscription channels. Is this setting
going to be added in a future firmware.  If not I will have to return it.  

Wan Settings.jpg

Edited by SteelForeHeed
Title did not describe post subject.

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

Sorry to hear that option isn't available for you, I can certainly check with NG as to whether that feature will return. Does it not work with standard IGMP Proxying enabled (unticked)?

Share this post


Link to post
Share on other sites

Thanks for getting back to me so soon. Firstly a very Happy New Year to you.  I have tried standard IGMP Proxying enabled (unticked) but it doesn’t work.  I get an error message telling me something wrong with connecting to this channel, please check internet connection or router settings. Same error with all subscription channels.  If I remember the XR500 had the same problem and the added the setting Support British Telecom (BT) IGMP Proxying in a firmware release.

 

Share this post


Link to post
Share on other sites

I raised the same issue back in September for both the XR300 and R1 (on OS 3.0). I periodically check in to see if there has been any change, but nothing yet.

I've ended up using the BT smarthub as the main router so the TV still works and the XR300 is just used as a switch that geo filters the games consoles and nothing else. This makes it an expensive switch. 

If you still have the option, I would return the XR1000 as I don't see anything changing in a hurry. 

Share this post


Link to post
Share on other sites

I’ve got until the end of January to return the router as purchased from Amazon so have got a few weeks to play with.  I’ve actually had two calls from Netgear in the US now and they are speaking with their engineers to see if they can add the Support British Telecom (BT) IGMP Proxying Setting. I spent nearly 2 hours on the phone with Netgear last night setting up my XR1000 from scratch again. Reset to factory settings and installing the latest firmware to see if it fixed the problem but of course it didn’t.  Netgear are going to call me back either tonight or on Tuesday next week so will find out what’s happening then. Depending on the outcome I will then decide whither to return the router or keep it.

Share this post


Link to post
Share on other sites

I don't have the patience to start the process you have undertaken so far! Good luck!

When they do call you back and if it seems they are likely to add the feature back in, it would be great if you could highlight that the XR300 also needs it please?!

 

Share this post


Link to post
Share on other sites
12 minutes ago, SteelForeHeed said:

I will certainly do that as soon as hear from Netgear. Fingers crossed.

Did they supply you a case number?

Share this post


Link to post
Share on other sites
1 hour ago, SteelForeHeed said:

Yes they did. All support cases are given a number.

That’s good, I wanted to double check. I would check online as they tend to forget to ring back and sometimes the case is closed. Did they mention level 2 support would contact you?

Share this post


Link to post
Share on other sites

Can’t remember them mentioning level 2 support but they did say they will be speaking to their senior technicians and will call me back Tuesday next week. I must admit they have been quite good so far as they have called me  back when they said they would. Cannot fault them so far.  I will also check regularly in case they  close the case, thanks for that info.  As soon as I hear more I will update 

Share this post


Link to post
Share on other sites

Hi,  Had a call from Netgear support tonight.  Asked about the Support British Telecom (BT) IGMP Proxying Setting again and was there any other setting I changed during the XR500 setup to get BT TV subscription channels to work. I told them I never changed anything apart from enabling the BT setting in WAN Settings. I was then told that their engineers had still not got back with an answer whither they were going to add the setting to a firmware update for the XR1000.  Support said they would call me again later tonight or tomorrow night with a possible answer.  Will update as soon as I hear.

Share this post


Link to post
Share on other sites

Just a quick update. Got a call from support tonight. They said still no word from engineers whither they will add setting.  They apologised and said they would call me the minute the hear anything.  Will update when I hear anything else.

Share this post


Link to post
Share on other sites

Hi,  Sorry haven’t updated for a couple of weeks. Had not heard from Netgear support for a while so added a comment to my raised ticket stating the fact. I also mentioned that if I never heard anything in a few days I would have to return the router to Amazon.  A couple of days after posting the comment I received a call from Netgear apologising for not getting back to me and to tell me their engineers have still not come back with an answer as to whither they will include the Support British Telecom (BT) IGMP Proxying Setting in a future firmware update.  I told them I was sending the router back to Amazon as I couldn’t wait any longer for an answer.  They said that even though I was sending it back they would still let me know when their engineers make a decision on the setting and would keep my case open.  Not great news but hopefully will receive an answer soon.  Will update again when I hear something.

Share this post


Link to post
Share on other sites

Received a call from Netgear support last night. I have some good news about the XR1000.  Support have been informed by their engineers that the Support British Telecom (BT) IGMP Proxying setting will be added in the next firmware update.  A bit of bad news is I have returned the router to Amazon but I did receive a full refund.  I will probably purchase again when the firmware becomes available.  As for the XR300, no word about at the moment. I would think that when they add the setting to the next XR1000 firmware they will also add it to all their XR models. Will just have to wait and see.

Share this post


Link to post
Share on other sites

Many thanks for the offer of the trial firmware.  Unfortunately I have gone and bought a TP Link Archer AX1100 WiFi 6 Gigabit Tri-Band Gaming Router.  First time using a different manufacturer but I’m quite impressed with and no problems so far.  I will probably use Netgear again in the future.  Hope the trial firmware works for anyone that gives it a shot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...