Jump to content
voomz

Issue with UPnP on Xbox One

Recommended Posts

Hi, I am using the netgear nighthawk m1 mobile router with an EE sim card connected to the netduma r2. The M1 is switched into 'passthrough' mode and supplying internet to the duma. The duma is then connected through ethernet cable to my Xbox One, however my xbox is displaying 'UPnP not successful'.

How can I fix this?

Share this post


Link to post
Share on other sites

Instead of doing the passthrough mode, use the DMZ instead so get the WAN IP from the System Information page on the R2 and enter it into the DMZ in SETTINGS > Advanced > Other on the M1 and then give the R2 a static/reserved IP on the M1 using the same IP then reboot the R2 and see if the UPnP issue is gone.

Share this post


Link to post
Share on other sites
46 minutes ago, Netduma Fraser said:

give the R2 a static/reserved IP on the M1

Thanks for the quick response. Erm you lose me at this bit, do i do this in the dumaos? or in the M1 interface?

Share this post


Link to post
Share on other sites
10 minutes ago, voomz said:

Thanks for the quick response. Erm you lose me at this bit, do i do this in the dumaos? or in the M1 interface?

Yes do this on the M1 interface please, just use the same IP address the R2 has already been assigned by the M1.

Share this post


Link to post
Share on other sites
5 minutes ago, Netduma Fraser said:

Yes do this on the M1 interface please, just use the same IP address the R2 has already been assigned by the M1.

I can see that the M1 has automatically assigned the LAN device with the same IP address, I just don't know where in the M1 interface that I add the static/reserved IP.

Share this post


Link to post
Share on other sites
1 minute ago, Netduma Fraser said:

I don't think it has that as an option then. You've put the correct IP from System Information on the R2 in the DMZ in the M1? Have you got any port forwarding rules enabled on the M1?

Maybe. Yes, I've enabled DMZ on the M1 and put the IP from the R2 as the 'DMZ address'. No port forwarding rules set at the moment

Share this post


Link to post
Share on other sites
32 minutes ago, Netduma Fraser said:

A double NAT only happens when the router above is trying to control traffic as well. 

You had it in IP Passthrough mode previously is that right? Did this disable the M1 WiFi also?

When it was in passthrough mode I could no longer find the M1 network to connect to.

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

Okay put it back in passthrough mode and then on the R2 put the console IP in the DMZ on the R2 and see if it gets rid of that message on the console.

Is this where I put the console IP in the DMZ on the R2?

Screen Shot 2020-12-27 at 5.19.41 pm.png

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Fraser said:

Yes that is exactly right, turn on the toggle and enter the IP as shown in device manager/console network settings.

Okay, so I've done this and now my xbox one is displaying the 'UPnP not successful' message again. I was playing okay with the Double NAT.

Share this post


Link to post
Share on other sites
3 minutes ago, voomz said:

Okay, so I've done this and now my xbox one is displaying the 'UPnP not successful' message again. I was playing okay with the Double NAT.

There is a 'Gateway IP address' on the M1 mobile router setup page, I don't know if this needs changing?

Share this post


Link to post
Share on other sites

I'm thinking this might be due to LTE being a bit more restrictive than residential broadband as your settings are all right and on any other setup is should be working. No you don't need to change that. Okay so I will list here all the possible combinations I can think of that could result in Open NAT, hopefully one of them works, if it doesn't then I definitely think the provider of your LTE is restricting necessary ports:

  • M1 - Passthrough R2 - Xbox in DMZ, UPnP enabled
  • M1 - Passthrough R2 - Xbox in DMZ, UPnP disabled
  • M1 - Passthrough R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - Passthrough R2 - Xbox in Port Forwarding, UPnP disabled
  • M1 - DMZ R2 - Xbox in DMZ, UPnP enabled
  • M1 - DMZ R2 - Xbox in DMZ, UPnP disabled
  • M1 - DMZ R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - DMZ R2 - Xbox in Port Forwarding, UPnP disabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in DMZ, UPnP enabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in DMZ, UPnP disabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in Port Forwarding, UPnP disabled

You could also try just UPnP on it's own on the R2. Assume where something hasn't been mentioned, i.e. Port Forwarding/DMZ that it is disabled. I know that's a lot but it should be working already so just trying to save some time and list what could be tried.

Share this post


Link to post
Share on other sites
11 hours ago, Netduma Fraser said:

I'm thinking this might be due to LTE being a bit more restrictive than residential broadband as your settings are all right and on any other setup is should be working. No you don't need to change that. Okay so I will list here all the possible combinations I can think of that could result in Open NAT, hopefully one of them works, if it doesn't then I definitely think the provider of your LTE is restricting necessary ports:

  • M1 - Passthrough R2 - Xbox in DMZ, UPnP enabled
  • M1 - Passthrough R2 - Xbox in DMZ, UPnP disabled
  • M1 - Passthrough R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - Passthrough R2 - Xbox in Port Forwarding, UPnP disabled
  • M1 - DMZ R2 - Xbox in DMZ, UPnP enabled
  • M1 - DMZ R2 - Xbox in DMZ, UPnP disabled
  • M1 - DMZ R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - DMZ R2 - Xbox in Port Forwarding, UPnP disabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in DMZ, UPnP enabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in DMZ, UPnP disabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in Port Forwarding, UPnP enabled
  • M1 - Port Forwarding (1-65535 TCP/UDP) R2 - Xbox in Port Forwarding, UPnP disabled

You could also try just UPnP on it's own on the R2. Assume where something hasn't been mentioned, i.e. Port Forwarding/DMZ that it is disabled. I know that's a lot but it should be working already so just trying to save some time and list what could be tried.

Yeah, I've just tried completely removing the R2 from the equation and connecting directly to the the M1 and I'm still getting Double NAT so it's definitely the fact that I'm using a 4G modem. However when i connect straight to the M1 I get a moderate NAT type on my xbox which is good, but when I double NAT with the R2 I'm on a strict NAT type which I don't want.

Share this post


Link to post
Share on other sites
4 hours ago, Netduma Fraser said:

That's unfortunate, maybe contact them and see if they would be able to unblock the ports they're restricting so that you can police that yourself with another router.

Yeah thanks for all your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...