Jump to content
Sign in to follow this  
shiddy

BOCW - Lag Compensation on PC?

Recommended Posts

Hi, I have an R2 and set up MW on my PS4 pretty good, accurate Hit Detection.

 

Now I have a optimized GamingPC (took a LOT of time to test and tweak and so on), CSGO and Warzone are really good in HitDetection, so no problem here in hit detection or input lag.

But on BOCW  the Lag Compensation is driving me mad... I dont know if my connection is bad or if it is these shitty game... Every 7. Game or so my PacketLoss goes till 40% !? And sometimes I feel like my client is 500ms behind the enemys... I have read about  the Tip to set PC at Wireless connection, but my Hardware has no WiFi.... Atm i run a VDSL 250/40 at QoS CC 70/20, have tested QoS CC 8/5 and can not find any difference..

Are there any Tips for better connection?

Btw: At my Modem all Ports are forwarded and PC is set to DMZ in R2 (but i think with moderate NAT the lobbies are less full of cheaters?!)

Share this post


Link to post
Share on other sites

What people generally do is try throttling using Congestion Control, experimenting with ports on Traffic Prioritization or forcing some further away servers to try and raise the ms a bit and pull the compensation in their favor. Give them a try, I'm sure others will comment also.

Share this post


Link to post
Share on other sites

Which Port to Prioritizing?  Is there a Guide to best "Try and Error" this?

For now I never had used to prioritize traffic or ports! never had to be...

Share this post


Link to post
Share on other sites
29 minutes ago, shiddy said:

Which Port to Prioritizing?  Is there a Guide to best "Try and Error" this?

For now I never had used to prioritize traffic or ports! never had to be...

There is a lot of discussion in this topic here where they try different ports https://forum.netduma.com/topic/32923-traffic-prortization-please-read/

Share this post


Link to post
Share on other sites
28 minutes ago, shiddy said:

@Netduma Fraser For PC the GeoFilter is not working, only in watching mode, will it be bypassed to set my Computer in DeviceManager as "Console"?

Yes set it to a PlayStation in the Device Manager and re-add it to the Geo-Filter selecting the Manual option and it should work correctly.

Share this post


Link to post
Share on other sites

UDP - Source Port (3074:3074) - Destination Port (30000:65535) & Disable IPv6 & Set GamingPC as "Playstation" DID THE TRICK :)

feels really nice, before only 1/3 of my shots found the way.. now straight hit detection :)

Share this post


Link to post
Share on other sites

@Netduma FraserAfter Prioritize Traffic Port 3074 even for my PS4, i am not be able to achieve Open NAT.. even if my PS4 is as a DMZ... bug or feature?

PC works if i set it in DMZ, only other changes i made, was disabling IPv6, but this makes no sense...

Share this post


Link to post
Share on other sites
9 hours ago, shiddy said:

@Netduma FraserAfter Prioritize Traffic Port 3074 even for my PS4, i am not be able to achieve Open NAT.. even if my PS4 is as a DMZ... bug or feature?

PC works if i set it in DMZ, only other changes i made, was disabling IPv6, but this makes no sense...

Have you confirmed that its definitely prioritising 3074 that's the issue? If you disable this rule in Traffic Prio does your NAT type return to Open?

Share this post


Link to post
Share on other sites

No maybe it is because i set privacy settings to offline/not findable (in game and in playstationnetwork). If i disable rule to prioritize, stays also moderate. Disabling IPv6 was the only other change i did (beside the traffic prio, and set PC to a playstation device)

Share this post


Link to post
Share on other sites
8 minutes ago, shiddy said:

No maybe it is because i set privacy settings to offline/not findable (in game and in playstationnetwork). If i disable rule to prioritize, stays also moderate. Disabling IPv6 was the only other change i did (beside the traffic prio, and set PC to a playstation device)

OK, try reverting the changes you made in the Playstation settings and see if that gets you back to an open NAT

Share this post


Link to post
Share on other sites
On 12/15/2020 at 1:43 PM, Netduma Liam said:

OK, try reverting the changes you made in the Playstation settings and see if that gets you back to an open NAT

Negative. Still ModeratNAT... is it really cuz i disabled IPv6 at my AiO Modem/Router and in Netduma R2??? Or Maybe cuz my PC is now a "Playstation Device" and has PortPrio? could not get it back to Open...

Share this post


Link to post
Share on other sites

With IPv6 it is easier to get an Open NAT. Changing device type shouldn't affect that, how do you have the R2 setup for an open NAT with the all in one and what current settings on the R2 for NAT?

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

With IPv6 it is easier to get an Open NAT. Changing device type shouldn't affect that, how do you have the R2 setup for an open NAT with the all in one and what current settings on the R2 for NAT?

AIO:
NetdumaR2 -> StaticIP / LAN 1 mit 1 Gbit/s / Exposed Host (kind of a DMZ)/ selbst. Portfreigabe erlaubt / Echtzeitpriorisiert
PortForward T is TCP / U is UDP:
PS4T80
PS4T443
PS4T465
PS4T993
PS4T983
PS4T1935
PS4T3478-3480
PS4T5223
PS4T10000-10100
PS4T8080
PS4T9988
PS4T17502
PS4T42127
PS4T3659
PS4U3074
PS4U3658
PS4U10070
PS4U50000
PS4U3659
PS4U14000-14016
PS4U6000-6250
PS4U6251-6500
PS4U6501-6750
PS4U6751-7000
PS4U3478-3479
PCT3074
PCT27014-27050
PCT11700-11725
PCU4379
PCU27000-27031
PCU27036
PCU1119
PCU48800-48900
PCU7002
IPv6 Disabled
UPnP enabled
Global Filters (Stealth Mode etc) (Firewall???) all disabled
DNS not set to google or cloudflare. Standard ISP DNS will it be i think

Netduma: only 5Ghz WiFi, LAN/WAN disable IPv6, UPnP enable, PS4 at static IP in DMZ, PC set to playstation (also static IP), DNS Override to Gateway (AiO IP),QoS 70/20, 75% Gaming both, TrafficPrio Source 3074 3074 UDP - Destination 30000-65535 UDP (For PC and same for PS4)

 

Share this post


Link to post
Share on other sites

On the AIO if you're port forwarding the console that is connected to the R2 it won't work. You need to put the R2 WAN IP found in System Information into the AIO DMZ and then you should get an open NAT.

Share this post


Link to post
Share on other sites

I have, no way to gain Open NAT like before... On PC i have moderat NAT and if i put IP from PC in R2 DMZ it will be NATopen, If i put PS4 IP in R2 DMZ it stays NATmoderat...

Only changes was "disabling overall IPv6" and "remove custom DNS" (now use Upstream DNS in R2 / at AiO no custom DNS set like before 8888)

 

Edit: enabled back IPv6 overall, set custom DNS to google 8888 and voila OpenNAT again... really strange..... better i leave it as now... but would be good if anyone has good settings for PC BOCW, seems like newest update from yesterday, my Hitreg on my previous settings is shitty again

Share this post


Link to post
Share on other sites

Yep now PortForwarding Rules on AiO are deleted, only UPnP are on (on both), Yes Other Devices on AiO Network/Mesh (all on standby) like WifesPhone, Soundbar, etc. no need to change this

Share this post


Link to post
Share on other sites

If UPnP is enabled on it and devices are still connected to it then they will be using ports that may be needed for the R2/console to get an Open NAT. So would suggest connecting everything over to the R2 and disabling UPnP on the AIO.

Share this post


Link to post
Share on other sites

No i dont think so, cuz tested it with every device are in standby (blocked for test). But With previous Settings (IPv6/GoogleDNS), everything workes, exept that Hitreg is really bad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...