Jump to content

Recommended Posts

Hi,

I have recently bought the Netgear XR500 for configuring my own LAN devices with VPN. I've tried to configure HybridVPN, but i cant make it work properly. I have as of now 2 devices in my LAN(described below). The Iphone works without a problem, but my laptop is giving me wrong public IP and location. 

I've tried the following:

  • Configuring the routers internet settings with the DNS provided by the VPN provider
  • Different openVPN config file to test if TCP or UDP tunneling would do the trick
  • Flushed DNS on laptop, flushed browser for cached data and also restarted all devices on my LAN(including the router)
  • Included devices under VPN Traffic and selected the following mode : DO NOT VPN THESE SERVICES
  • Checked that the MAC-address provided by DUMAOS corresponds with the physical address of the devices

I havent been able to find a solution to this specific problem on this, or the netgear community forum. If anyone here has a solution or could give me some tips for further problem solving, that would be much appreciated.

Device/System information:
Router: Netgear Nighthawk XR 500(FW:XR500 V2.3.2.66)
VPN provider: PrivateInternetAccess(PIA)
LAN-Devices: Windows Laptop(HP Envy x360, WIN10), Iphone(IOS 13.2)

PIA OpenVPN config file

client
dev tun
proto udp
remote no.privacy.network 1198
resolv-retry infinite
nobind
persist-key
persist-tun
cipher aes-128-cbc
auth sha1
tls-client
remote-cert-tls server

auth-user-pass
compress
verb 1
reneg-sec 0
<crl-verify>
-----BEGIN X509 CRL-----

-----END X509 CRL-----
</crl-verify>

<ca>
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
</ca>
 

 

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

Sorry to hear you're having this issue. How is the laptop connected exactly - via ethernet or WiFi? Do you have MAC randomization enabled on the PC? It shouldn't make a difference but it might be messing with the detection which could explain why the phone works instead.

Share this post


Link to post
Share on other sites

Hey, thanks for the quick reply.

The laptop is connected via WiFi. The laptop doesn't seem to support MAC randomization as it's not an option in my WiFi settings. I've during the troubleshooting tried to disabled the windows firewall, just to exclude network policies. Still no luck.

Share this post


Link to post
Share on other sites
11 hours ago, smultringen said:

Hey, thanks for the quick reply.

The laptop is connected via WiFi. The laptop doesn't seem to support MAC randomization as it's not an option in my WiFi settings. I've during the troubleshooting tried to disabled the windows firewall, just to exclude network policies. Still no luck.

OK, and do you experience the same issue if the laptop is connected via ethernet?

Share this post


Link to post
Share on other sites

Hey guys, thanks for the quick responses. Quick update on the HybridVPN situation;

After removing the laptop from device manager(in DUMAOS), rebooting the router, assigning the laptop its own IP in the routers dhcp and generating a new openVPN config file it seems to work. I'm not quite sure why all this solved the problem, but at least it seems to have solved it for me. I could have been more organized in my troubleshooting, but i guess i was a bit impatient.

Anyways thank you guys.

Share this post


Link to post
Share on other sites

apologies for re lighting this fire but im having some very similar issues, i can get my vpn config working, but i cannot split tunnel specific services from my nividia shield, i wish to use netflix and prime video without a vpn connection but it does not seem to segregate the traffic for these apps effectively, any advice on this?

 

Kind regards

Nick 

 

Share this post


Link to post
Share on other sites
1 hour ago, Zeek88 said:

apologies for re lighting this fire but im having some very similar issues, i can get my vpn config working, but i cannot split tunnel specific services from my nividia shield, i wish to use netflix and prime video without a vpn connection but it does not seem to segregate the traffic for these apps effectively, any advice on this?

Kind regards

Nick 

Hey, welcome to the forum, happy holidays!

No need to apologize! There is a Netflix and Amazon Prime Video option, are you saying when selecting these options the services still go through the VPN? How have you added them exactly to the VPN?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...