Jump to content
stallhagen

Geo-filter not working for Modern Warfare

Recommended Posts

I’ve owned the XR500 with newest bios for 6 weeks now. I have a radius set in the geo-filter with strict mode. Ping assist 50. My filtering device is PC-callofduty. I live in CA, USA.

Yet any time I join on my friends, it connects us to a server that is outside of my radius, and my ping is 90-110ms, which makes it hard to be competitive.

Is the geofilter not supposed to work this way or have I misunderstood something? I have flushed the cloud and re-selected my device.

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

Could you provide a screenshot of how you've configured the device/Geo-filter?

Please also be aware that changes to Geo-filter won't come into affect until you've rebooted the game.

It's possible that servers you're connecting to outside your radius are authentication servers and has been whitelisted by us, but this shouldn't affect your ping.

Share this post


Link to post
Share on other sites

Hi Liam, thanks for the quick reply!

I have attached a picture of how it's set up. I also tried changing my PC to "console" in device manager but that did not help. I have strict mode and fast search enabled, but I've also tried without each of them.

What happens is that I can join my friends party in COD even if they are not whitelisted. Then we get taken to a game with a server on the east coast and my ping is 95-110ms. My friends and the server appear as white symbols on the map outside of the prescribed range.

All help appreciated, thanks!

geofilter.png

Share this post


Link to post
Share on other sites

I would suggest doing the PC > Console option. Put Ping Assist to 0 and when you add/invite your friend allow them on the ping panel, once you've done that then search for a game and it will force it to be within the radius.

Share this post


Link to post
Share on other sites

Any other advice? I changed the PC to Console in device manager and changed ping assist to 0.

This time none of the servers showed up on the screen and I still got connected to a 98ms ping game.

#2.png

Share this post


Link to post
Share on other sites

Do you experience the same issue when you host the party with your friends?

If one of your friends is hosting, it may be that you just connect to whatever server their search results in and Geo-filter is bypassed.

Share this post


Link to post
Share on other sites
6 hours ago, stallhagen said:

I do have better ping when I'm hosting. Is there no way to circumvent someone else hosting getting us in a bad server?

There’s no way to work around that, the party leader looking for a game controls the connection and while as a party leader you can select a server via the geo filter it does not mean those in your party have the same great experience. 
The geo filter applies to you only.

Share this post


Link to post
Share on other sites

@stallhagen @Newfie

It doesnt matter who is hosting when ur geo-filter is working it will not put u in a game outside of the radius u have set. 

I can confirm this with CoD MW, BO CW and for Warzone i am doing it all the time i set up the geo-filter and let another friend host (with a low kd he has only 1.6 kd on Warzone) 🤣

Share this post


Link to post
Share on other sites

@Mobel, can you share your settings?

I play with buddies on the East Coast and I'm in CA. Hoping that when we play we could connect somewhere in the middle with ~50ms ping for all instead of them having 20ms and I have 110ms.

Share this post


Link to post
Share on other sites
1 hour ago, stallhagen said:

@Mobel, can you share your settings?

I play with buddies on the East Coast and I'm in CA. Hoping that when we play we could connect somewhere in the middle with ~50ms ping for all instead of them having 20ms and I have 110ms.

It can’t, if say you had one and your friend 500 miles had another xr and your other friend 500 miles in the other direction had an xr which one would it pick!

no settings can change that, if your friend fires up a server it is impossible for your router to control a group as you have found out as the connection of the game is with your friend who started the gaming session. 
 

Geo filter only gives you the one who picks the server the connection you want, it does not guarantee the other players in your group the same connection. Laws of physics comes into play as all paths are different. It’s why DumaOS is marketed for you as an individual, no where does it state it can control multiple connections of other players.


 

Share this post


Link to post
Share on other sites
On 12/11/2020 at 3:48 AM, stallhagen said:

Any other advice? I changed the PC to Console in device manager and changed ping assist to 0.

This time none of the servers showed up on the screen and I still got connected to a 98ms ping game.

  1. Quit game/client completely
  2. Remove device from Geo-Filter
  3. Flush the Cloud
  4. Re-add device to Geo
  5. Adjust settings
  6. Wait 2 minutes
  7. Boot up the game

See if it works better then.

Share this post


Link to post
Share on other sites

@stallhagen

I have on Geo-filter:

Strict mode enabled, Auto-ping enabled 

Ping assist on 0, Fast search disabled.

And set your home as close as possible on your real location on the map.

Share this post


Link to post
Share on other sites

The problem I’m having is I can’t find a game in Cold War when I have a small radius set. I have pretty much all of Cali covered with my circle and ping assist at 0, and have been searching for a match for ten mins now. I know there are servers in Cali. Same thing happens when I try to play on servers near me in Texas. I’m baffled. This only seems to happen with ping assist at 0. When ping assist is set high enough that other servers are allowed then it will connect me to servers outside the circle and within. Why can I not just play on servers within my radius? I know it’s supposed to connect to servers outside the circle when the ping meets the criteria, but that defeats the purpose for me. I want to play on particular servers I know are there. 

Share this post


Link to post
Share on other sites
29 minutes ago, Kfetish said:

The problem I’m having is I can’t find a game in Cold War when I have a small radius set. I have pretty much all of Cali covered with my circle and ping assist at 0, and have been searching for a match for ten mins now. I know there are servers in Cali. Same thing happens when I try to play on servers near me in Texas. I’m baffled. This only seems to happen with ping assist at 0. When ping assist is set high enough that other servers are allowed then it will connect me to servers outside the circle and within. Why can I not just play on servers within my radius? I know it’s supposed to connect to servers outside the circle when the ping meets the criteria, but that defeats the purpose for me. I want to play on particular servers I know are there. 

If you can make your own topic we can focus on your issues. Does Ping Heatmap say the servers are in that location?

Share this post


Link to post
Share on other sites
Posted (edited)

I am having issues with the dumaos every time when I set up the geofilter map and the Xbox One S on my geofilter it tries to find the game but it doesn't load into the game it kicks me out after the timer goes live I'm trying to play Call of Duty Modern Warfare 2019 I even restored it factory default and it's still doing it I don't understand what the hell's happening I have strict mode activated I have auto pinghost I also flush the cloud and I disabled fast search and I put ping assist on 0 it keeps trying to auto find a server

16227883229373921198071678494466.jpg

Edited by fpsmercs

Share this post


Link to post
Share on other sites
4 hours ago, fpsmercs said:

I am having issues with the dumaos every time when I set up the geofilter map and the Xbox One S on my geofilter it tries to find the game but it doesn't load into the game it kicks me out after the timer goes live I'm trying to play Call of Duty Modern Warfare 2019 I even restored it factory default and it's still doing it I don't understand what the hell's happening I have strict mode activated I have auto pinghost I also flush the cloud and I disabled fast search and I put ping assist on 0 it keeps trying to auto find a server

Does there appear to be anything blocked on the map when you get kicked? - You may need to zoom out completely on the map to see anything. Where abouts are you located?

Share this post


Link to post
Share on other sites
Posted (edited)
56 minutes ago, Netduma Fraser said:

Does there appear to be anything blocked on the map when you get kicked? - You may need to zoom out completely on the map to see anything. Where abouts are you located?

I don't know I'm in New Hampshire I was trying to set up the geofilter so I can block out some bad connection but instead it tries to join a game and on Modern Warfare I almost went in a game timer it hits the timer that makes me go in the game and then once it hits the timer it kicks me out and instant finds another game I don't know what's happening to this geofilter I did everything I restored the router I downgraded the firmware to the regular non beta firmware and that didn't work I updated the firmware back to the beta that didn't work and I formatted the beta and I also formatted the regular firmware that didn't work I'm getting very very frustrated I don't know how anything is getting blocked there might be some shit getting blocked because I have seen some getting blocked but I'm not too sure I'm not on there anymore I gave up Call of Duty Black Ops is working every other game is working except Modern Warfare

Edited by fpsmercs

Share this post


Link to post
Share on other sites
34 minutes ago, fpsmercs said:

I don't know I'm in New Hampshire I was trying to set up the geofilter so I can block out some bad connection but instead it tries to join a game and on Modern Warfare I almost went in a game timer it hits the timer that makes me go in the game and then once it hits the timer it kicks me out and instant finds another game I don't know what's happening to this geofilter I did everything I restored the router I downgraded the firmware to the regular non beta firmware and that didn't work I updated the firmware back to the beta that didn't work and I formatted the beta and I also formatted the regular firmware that didn't work I'm getting very very frustrated I don't know how anything is getting blocked there might be some shit getting blocked because I have seen some getting blocked but I'm not too sure I'm not on there anymore I gave up Call of Duty Black Ops is working every other game is working except Modern Warfare

There is almost certainly something being blocked when that happens - as soon as it occurs have a look, you'll need to be quick as it can disappear, anything that appears blocked add to your allow list and then it should allow you in when you try again

Share this post


Link to post
Share on other sites

I'll try again later today I'm extremely tired I was up all night trying to fix it I was trying to play a game for hours earlier It's 8:52 a.m. over here now I'm going to bed goodnight technically good morning but goodnight for me

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...