Jump to content
scoobypreza

Geo filter and cold war

Recommended Posts

50 minutes ago, m3gtr8 said:

I'm having the same issue, I live in the UK and want to play on French and German servers as the connection quality is better than the servers in the UK. 

I set my home location in france and wanted to filter out any servers in the UK. It works but not 100%, I keep getting connected to UK servers every now and then. 

Ping assist is off. filter mode is on. platform xbox one. 

tried both strict mode on and off. 

I have the netduma R1 with the V3 beta software.

Hey, welcome to the forum, happy holidays!

Could you provide a screenshot of what you're seeing when you get games that you shouldn't please?

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Fraser said:

Hey, welcome to the forum, happy holidays!

Could you provide a screenshot of what you're seeing when you get games that you shouldn't please?

Happy holidays ! As you can see, the host is someone in the UK despite me filtering out the UK from my geo-filter. It's not a glitch because the players are british and are from london. Don't know why this keeps happening. My ping assist is set to zero. 

The game doesn't show any errors, it just connects as if there is no filter applied. 

net.png

Share this post


Link to post
Share on other sites
11 hours ago, m3gtr8 said:

Happy holidays ! As you can see, the host is someone in the UK despite me filtering out the UK from my geo-filter. It's not a glitch because the players are british and are from london. Don't know why this keeps happening. My ping assist is set to zero. 

The game doesn't show any errors, it just connects as if there is no filter applied. 

The host has been Ping Assisted but you have this on 0, did you change the Ping Assist/Geo-Filter settings while you were already on the game/console? If so that will be the cause so you need to set that before the console is even on. Also it is possible for London players to join other servers like France.

Share this post


Link to post
Share on other sites

So, I did what you said. I deleted the profile, switched xbox off. Re-created the geo-filter and started the xbox back on again. It works much better but still there's about a 20% chance that the game will throw me on a server in the UK. However, there's no more ping assisted hosts (that seems to be fixed). 

The lag compensation is insane in this game, playing on the dedicated servers in France/Belgium is life-changing. Wish there was an option in the DumaOs to only play on dedicated hosts.

Thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...