Jump to content
Orell

PS4 Internet Speed is Low

Recommended Posts

Hi, I've done an connection speed test using my Netduma R2 and I am paying for 500 mbps, however, when I run a connection speed test on my PS4 it only gives me a connection speed at around 79 mbps. I've followed the instructions as close to what is instructed as possible. What could be the issue and how can I resolve it?

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

Console speed tests are not 100% accurate. However, it is most likely that you're receiving slower speeds as QoS is setup to prioritize game packets rather than the speed test portion which is only helpful for downloading updates etc as games use very little bandwidth/speed - usually less than 1Mbps. Disable DumaOS Classified Games on Traffic Prioritization and see if it speeds up.

Share this post


Link to post
Share on other sites

@Netduma Fraser Thank you very much for your speedy reply. I am going to test it out now. For some reason the speed test on the Connection Benchmark is giving me a "D" reading. The other two are A+. I'm not sure why but I just upgraded from a 150 mbps modem to a 500 mbps modem. I'm trying to figure out how to get all 3 tests to show A+. 

Share this post


Link to post
Share on other sites

I was able to get an A+ rating under the speed test by changing my bandwidth speed option to Autodetect instead of setting it at the speeds that I am buying which is 500 mpbs/10 mbps. It gave me a speed test rating of 361 mpbs and a A+ rating (I'm not sure why it's still that low), however, the speed I am getting on my PS4 is 82 mbps. Shouldn't it be substantially higher if I have the Netduma R2 router and I am paying for 500 mbps? When I connect my PS4 directly to my modem it gives me higher speeds. I'm not sure what the issue is. 

Share this post


Link to post
Share on other sites

Don't worry about the speed on Benchmark, that is reporting lower than it should be so we're improving that currently. The R2 focus isn't on bandwidth speeds as that doesn't matter for gaming, was that speed with Classified Games disabled and any other Traffic Prio rules disabled?

Share this post


Link to post
Share on other sites

@Netduma Fraser Yes, that is the speed it gives me with Classified Games disabled. The picture below are my results. My bandwidth speed is set to 348 because that was the auto-setup feature gave me. However, I'm paying for 500 mbps. Should I increase the bandwidth speed to 500 mbps?

Netdumas Test Results.JPG

Share this post


Link to post
Share on other sites

@jb68 Thank you very much. I will use that website from now on. My playstation speed gives me 82 mbps but the website gave me 250 mbps. Why is that?

Share this post


Link to post
Share on other sites

Set the speeds to what you actually get as otherwise it will skew the results of the test, then redo the test please and post the screenshot again.

The console speed test says it is only an estimate and they're generally not that reliable. I have The same speeds as you and don't get anywhere close to it regardless of the router used.

Share this post


Link to post
Share on other sites

@Netduma Fraser Yes, in the previous test results I sent you I set the speeds to the speeds the feature auto-detect gave me. The speeds they gave me is 348 mbps. When I set it at the speeds I am paying for the picture below are the results I am getting. What are your thoughts?

Thank you for the clarification regarding the console speed test results. I assumed that it would be more reliable as the speed tests occurred directly on the console. 

Netdumas Test Results 2.JPG

Share this post


Link to post
Share on other sites

@Netduma Fraser I've also been trying to get in a specific server but although it is within the polygon, it is not placing me in the server I desire. It is placing me in a server that is not within my polygon. It isn't placing me in the best server. I've attached the picture below. Why is that?

Netdumas Geofilter.JPG

Share this post


Link to post
Share on other sites

The results are pretty good but the download Ping Under Load could be reduced so experiment with Congestion Control on Always and just adjust the download slider to see if you can get that down as much as possible. The server you have circled is an authentication server required for online play, it isn't actually the game server. The game server is the biggest icon and so is the one in the polygon on the East Coast.

Share this post


Link to post
Share on other sites

@Netduma Fraser Thank you for that advice. However, I'm not nearly as knowledgeable as you are in regards to the router so I will need you to help me understand what you mean. When you said the Ping Under Load could be reduced, what is the approximate test results for the Ping Underload so that I know exactly what I should be looking for as I'm experimenting? To be honest, I'm not too familiar with what the Ping Underload is designed for.   

Also,  as you can see, the green circle is where my polygon is located. Since I received my router last month until last week it was putting me in that particular server. Now it's only showing the authentication server that you spoke about when I am trying to join a lobby. How do I get into that server? I have been having issues with the server that it has been putting me in lately. 

Lastly, you stated that the game server is the "biggest icon". I am not seeing where any bigger icons are shown in the previous picture I sent you. What "biggest icon" are you referring to?

Netdumas Ping Heatmap.JPG

Share this post


Link to post
Share on other sites

You should aim to get the Ping Under Load test results as close as possible to the Ping Test results(middle test on Benchmark). Ping Test Under Load is a test which shows you what your ping would be if you had a lot going on the network at the time e.g downloads, streams etc. So by getting this down as close as possible to the Ping Test results when your connection is being used heavily the ping should be unaffected.

Sometimes depending on server load etc not all servers will be joinable, they'll try and force you onto another server. In your previous screenshot with the polygon on the East Coast you had a peer icon that is bigger than the other icons, that is how you can tell (if there are a few icons on the map) which is the game server.

Share this post


Link to post
Share on other sites

@Netduma Fraser Thank you for the clarification. The only thing I knew was that the Underload results should be low as possible. 

I had no idea that the size of the icons signified something nor that peer icons represents game servers. The icons you see are my friends who joined my game. 

Here are my test results after spending about 3 hours modifying the settings to get the best results. I know the stats can be much better as I have seen a person on YouTube get their pings down to 2ms, etc. I have tried to follow their instructions as close as possible and but I'm still not getting the best stats. Is there any suggestions you have to get the best results such as equipment we should buy? I bought this router to have the best experience while gaming. I have seen improvements but I am still getting hit marker delays in games such as Call of Duty. 

Netdumas Test Results 3.JPG

Share this post


Link to post
Share on other sites

That person will have had a 2ms base ping to start with then, you won't be able to get that low as your base ping is around 20ms and considering that your Ping Under Load results aren't too bad to be honest, if you've been experimenting for that long then that is probably the best you will get but it's pretty good to be honest. Other than looking into another ISP that may offer better base ping/stability then getting a PS5 could help - better network card (I assume), SSD will help. Things like low response monitors, higher refresh rates etc all help to an extent.

Share this post


Link to post
Share on other sites

@Netduma Fraser I will look into another ISP. I know the PS5 will help which is why I'm getting it. I currently have a PS4 Pro in which I took it off of 4K and put it on 1080p to improve the framerate. I will look at modifying the settings on my monitor as well. Thank you for your assistance. I will continue to test it out. The auto-setup for the Congestion Control kept placing the stat percentages at 1%. I'm not sure if a bug in the router's system caused that to happen but I tested it with the Congestion Benchmark anyway. The stats was a little better than before (believe it or not) but I put the upload and download speeds at 75% and 11% after testing out the sliders for a while. I'll continue trying to improve it. If I have any further questions, I will reach out to you. Thanks!

Share this post


Link to post
Share on other sites

@Netduma Fraser I've been having issues joining solo games in Warzone. Why is it that it takes more than 10 minutes for me to join a lobby (sometimes it doesn't happen at all)? I followed the instructions but am not sure why it happens. On the other hand, it doesn't take nearly as long when I am hosting a game and am playing with friends. 

Share this post


Link to post
Share on other sites

It will be very hard to tell regarding ISP what will provide you with the best routing/base ping will be. I'm not sure what the offerings are like for you in the US for smaller ISPs but we have some 'gaming' broadband companies that promise better routing to game servers. Yeah Auto Setup at the moment is very aggressive so we're making major improvements to that which should hopefully be part of the next firmware version. 

Switch off filtering mode and search for a game, pay close attention to the map, what is allowed that is normally blocked and when it is allowed does it get you into a quick game?

Share this post


Link to post
Share on other sites

@Netduma Fraser Thank you for that information. To be honest, it doesn't seem like the router has made any improvements for me compared to before I bought the router. I was hoping that there would be changes but I still have the same latency and lagging issues as before. It seems as though literally nothing has changed. I hate to say that but it's the God honest truth. 😕

Share this post


Link to post
Share on other sites

It's not going to give you perfect games every single time, there are things we can't control like ISP congestion, server load etc but it will optimize as best as it can for your network and if there is a time when local congestion would be an issue you won't even remember that was an issue as it won't happen. Don't forget to try forcing some other servers, people try advanced ports etc for Traffic Prioritization. There is a lot of experimentation you can do.

Share this post


Link to post
Share on other sites

@Netduma Fraser I've tried to force different servers but it takes extremely long for the games to start, and sometimes they don't start at all. How do I set up advanced ports? This is the main issue I have always been having which is why I bought the router in the first place. As you can see in the first picture I am aiming at and shooting him immediately as he opens the door. The as he runs in I am shooting him then he turns and kills me. He has no body armor but I do. The second picture shows what he sees on his end. The still picture shows that I am aiming about 2 feet away from him although I am actually shooting and hitting him directly. If you look at his body armor by the time he's standing in the corner, it appears as though I barely hit him but I shot him with 15 bullets from the time he opened the door until the time he ran in the corner. AGAIN, HE DIDN'T HAVE A SINGLE PLATE OF BODY ARMOR WHEN HE WALKED IN. I thought the Netduma R2 is supposed to help with hit detection but I am not experiencing it whatsoever. The 3rd picture also shows where I am aiming and shooting but the 4th picture shows that I am aiming several feet off to his right. What could be changed to fix this because it happens every match?

IMG_3396.PNG

IMG_3397.PNG

IMG_3399.PNG

IMG_3400.PNG

Share this post


Link to post
Share on other sites
18 hours ago, Netduma Fraser said:

Switch off filtering mode and search for a game, pay close attention to the map, what is allowed that is normally blocked and when it is allowed does it get you into a quick game?

@Netduma Fraser this is one server that keeps popping up then it will disappear. It will happen repeatedly but nothing ever happens. It also keeps showing a server in the UK but I'm not sure why. I've currently been waiting to join a lobby for over 10 minutes. My game is currently showing 200ms ping but nothing is happening. This is the best server which is at 25ms ping. I also have forwarded the ports and have my my NAT Type Open. Why isn't it allowing me to join a lobby?

Netdumas Geofilter Map 2.JPG

Share this post


Link to post
Share on other sites

Toggle Filtering Mode off so you're not restricting but can still see connections. How quick do you get into a game? Where does it place you on the map? Zoom out as well just in case it is outside your radius.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...