Jump to content
RaulMenendez_Xx

Geo-Filter not working

Recommended Posts

Hi,

I have been using the Nighthawk XR500 for a month now. The Geo-filter worked pretty much fine until last week ensuring all games were around 70 ms. Now even though it is on strict mode, ping assist set to 70 and fast search is disabled, i find games with 150+ ping (The server in Saudi Arabia always shows up and also appears on Auto-Ping with around 55ms ping). But during matchmaking, most of the times i seem to not connect to the Saudi one and rather European or American ones. I have tried restarting the router, removing and adding the PS4 and it still doesn't seem to work. Please help me out since I am unable to figure out what has gone wrong.

Share this post


Link to post
Share on other sites

It varies from Around 43-50ms. It shows up on Auto-Ping host, but in-game I think it actually connects me to the EU servers since the ping is always above 150. Rarely it is around 60-70

Share this post


Link to post
Share on other sites

If the Geo-Filter shows you that via Auto Ping then that's the direct ping from your router to the server so it's definitely somewhere close. In game differs as they include things like processing delay into the calculation so it might be the server is under load at the moment.

Share this post


Link to post
Share on other sites

I understand. But sometimes, although the Geo-FIlter radius is set only till SA, the EU and Amercan Servers also pop up randomly in a few games even though i have Filtering mode, strict mode, ping assist set at 70 and Fast search disabled. Those servers give me pings between 150-300 which makes it really difficult to play.

Share this post


Link to post
Share on other sites

That’s actually the same problem that I posted a topic on a few weeks ago. The members here helped me with what they know but our conclusion for this server is kinda considered as a secondary Warzone server sometimes you find lobbies and many times you don’t which is a bit unfortunate. Only the game can fix that, they put a lot of effort in the other servers in US and UK because there are a lot of players that plays Warzone there. On the other hand, in this server ( the Middle East server) not many players likes Warzone because the most of them only played multiplayer and this is not ideal for those who really enjoy Warzone. What I would say is just forget about the ping and try to play in more conservative style with such a high ping (+ 150 ms ). 

 

I apologize for the bad English. 

Share this post


Link to post
Share on other sites

I have done the steps and i still seem to get higher ping games. Just realized that when i am connecting to a dedicated server, the ping is around 60-70, but most of the games, I am connecting via Peer. What is this and how do i fix this?

Share this post


Link to post
Share on other sites

The SEA server is also mislocated and shows in India usually (physical location Singapore) . So you could try moving your filter radius closer around the SA server. I suspect you're getting connected to the SEA server.

Share this post


Link to post
Share on other sites

I’ve tried what Bert has advised. It still doesn’t seem to work. Few games, I connect to the dedicated server with 70 ping, but most of the games I’m connecting to peer and having greater than 150 ping. Also, I live in India, so the SEA server in Singapore is also pretty close to me. It shouldn’t actually give me ping higher than 70.

The Geo-Filter worked pretty much fine until last week. Until last week, I never got into lobbies with >70ms.

Share this post


Link to post
Share on other sites

Have you signed up for the XR500 beta? I think the Ping Heatmap feature would help you specifically so you can find out where the lowest ping server is - even if it is mislocated. 

Share this post


Link to post
Share on other sites

Yes i have! Could you by any chance prioritize my beta? Cause having this router and still getting high pings is pretty frustrating.

 

Also, why do you think this is happening all of a sudden? I mean it was fine until last week or so

Share this post


Link to post
Share on other sites

Yes we can try to bump you up the list, what is your Netgear username? It could be the servers have moved location but that might have thrown out where the Geo-Filter thinks that IP is. Hard to say.

Share this post


Link to post
Share on other sites

Username is the same as this one, RaulMenendez_Xx

Any idea when i could get access to it? I feel like i am not making complete use of this router because of this issue

Share this post


Link to post
Share on other sites
2 hours ago, RaulMenendez_Xx said:

Username is the same as this one, RaulMenendez_Xx

Any idea when i could get access to it? I feel like i am not making complete use of this router because of this issue

Thanks, I'll put that forward. I couldn't say, it's entirely up to Netgear to send the invites, my hope is with the next beta build that a lot more people will be added.

Share this post


Link to post
Share on other sites

The geofilter still isn't working. I cant even use flush cloud. It always says there is an error. Ive tried different browsers, factory resetting the router, nothing seems to work!

Share this post


Link to post
Share on other sites

Flush cloud works, when the message appears wait a minute and refresh the page, it will have applied. You said it was all working fine until a certain point, did you make any settings changes or setup changes prior to this?

Share this post


Link to post
Share on other sites

Okay! I have waited, refreshed and tried again, but the same error appears, so I’m not sure if it actually applied.
 

And no, I haven’t changed any settings since I bought the router and set up the Geo-Filter in June. I occasionally set the ping assist up and down and nothing else apart from that

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...