Jump to content

Recommended Posts

Hey Everyone! I absolutely love my Nighthawk XR500 and it has blown me away with all of it's features. I really debating on getting the new R2 but trying to decide if it would be worth the upgrade. Netduma deserves my money over Netgear for all the hard work they have been putting into the new DumaOS 3. Let me know what you guys think! 

Cory

Share this post


Link to post
Share on other sites

Thanks for the kind words! It is really up to you - the XR500 is the more powerful hardware so if that is what concerns you then would suggest sticking with that. The R2 however is optimized for DumaOS and will also be getting updates quicker due to less steps in publishing firmware. The R2 can support around 800-900mbps QoS on/off as well so should be able to support most speed as well.

Share this post


Link to post
Share on other sites
48 minutes ago, Zirkawn said:

does the netduma r2 support 1000/35 download and upload

It does support it but you'll likely receive 800-900mbps max download as that's what we have gotten in a lab environment. A home environment may differ.

Share this post


Link to post
Share on other sites
19 hours ago, Alongcory said:

Is there any way to pre-order the R2 from bestbuy? I like having Geeksquad warranty on my products. 

No there isn't unfortunately. We are only selling the R2 on our website at the moment.

Share this post


Link to post
Share on other sites
On 7/30/2020 at 1:02 PM, Netduma Fraser said:

Thanks for the kind words! It is really up to you - the XR500 is the more powerful hardware so if that is what concerns you then would suggest sticking with that. The R2 however is optimized for DumaOS and will also be getting updates quicker due to less steps in publishing firmware. The R2 can support around 800-900mbps QoS on/off as well so should be able to support most speed as well.

The XR500 and R2 have the same QoS performance then? So I can ask my ISP to upgrade me on 1000D/100U cable internet? I have XR500.
When you say slower firmware publishing, what timeframe difference we are looking at? 2 weeks? 6 months?
Regarding firmware version, even if the published firmware comes late, is the 2 pieces of hardware will have the same version and feature at the end of the day?

Share this post


Link to post
Share on other sites
1 hour ago, Joel Azar said:

The XR500 and R2 have the same QoS performance then? So I can ask my ISP to upgrade me on 1000D/100U cable internet? I have XR500.
When you say slower firmware publishing, what timeframe difference we are looking at? 2 weeks? 6 months?
Regarding firmware version, even if the published firmware comes late, is the 2 pieces of hardware will have the same version and feature at the end of the day?

Hey, welcome to the forum!

They both use DumaOS so the QoS will work the same yes. That is really impossible to say as development is always subject to change. They will be the same but likely not at the same time.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

Hey, welcome to the forum!

They both use DumaOS so the QoS will work the same yes. That is really impossible to say as development is always subject to change. They will be the same but likely not at the same time.

Thank you 💖

Share this post


Link to post
Share on other sites
5 minutes ago, ripndip74 said:

is there anything the r2 can do that the xr500 can't? can both routers do geo filtering?

I don’t believe the XR500 has adblocker but both have geo filter. 
it boils down to hardware, the XR500 is higher priced due to its hardware and WiFi capacities, faster processors, better WiFi coverage, beamforming, throughput and so on. 

The R2 is a replacement for the R1, priced to be competitive and is Netdumas own router. While it’s WiFi might not match those of the XR500 if your router that you use now has good WiFi and is able to be put in Access mode you could use that instead of the R2 WiFi.

It just boils down to what you want and what devices you have to your network requirements.

Share this post


Link to post
Share on other sites
26 minutes ago, ripndip74 said:

is there anything the r2 can do that the xr500 can't? can both routers do geo filtering?

Hey, welcome to the forum!

Some good points above. R2 is if you're mainly interested in the software - DumaOS is more optimized for it, it has all our developed features and we'll be able to get faster updates out. The XR500 has DumaOS 3.0 in beta at the moment so not as refined on that front at the moment and does not have Adblocker. The XR500 does have better hardware. Both can Geo-Filter.

Share this post


Link to post
Share on other sites

Sorry for the thread revival but I'm currently in the same boat.

I've got an aging TPlink router that does the basics, I have Ubiquity kit for the wifi. I had the R1 for many years before the hardware just couldn't cope with the software anymore and it was unusable. 

I want DumaOS again but not sure if its worth spending £150 on the R2 or £70 more on the XR500. Presumably I can get rid of my TPLink and just use the R2 for the router. I only have 30/7 speeds

Share this post


Link to post
Share on other sites

What do you mean the R1 couldn't cope with the software anymore? What issues were you having? 

We usually say if you care more about software than hardware then the R2, if hardware then XR500. Given your speeds and if you're not planning to upgrade that anytime soon then the R2 would be what I recommend.

Share this post


Link to post
Share on other sites
Just now, Netduma Fraser said:

What do you mean the R1 couldn't cope with the software anymore? What issues were you having? 

We usually say if you care more about software than hardware then the R2, if hardware then XR500. Given your speeds and if you're not planning to upgrade that anytime soon then the R2 would be what I recommend.

I think I posted a few threads on here but ultimately when I upgraded the firmware to 2.0 at the time (I think) it just couldn't cope with the applets, all I was ever doing is waiting for the thing to load or "The operation is taking longer than expected. Please briefly wait before using this R-App." for each section I wanted to browse. I have loooooads of devices on my network, not sure if that had some bearing but I tried everything you guys suggested and gave up in the end.

I got it out a few months back and same issues. It does look like the memory was maxing out constantly. I'm weary of the R2 being like that in a few years time, I know the XR500 has better hardware (memory) and I'm all about future proofing, especially if paying £150+ for a device.

Share this post


Link to post
Share on other sites

@andybtsn if 2.0 was your issue I'd recommend at least trying the 3.0 beta for the R1 before you decide on purchasing another router as it may just work fine for you and your connection: https://forum.netduma.com/topic/35821-new-r1-firmware-30207/ make sure you do a factory reset once it's finished upgrading and see if it performs any better for you. If it doesn't seem to load after the upgrade you'll need to clear your browser cache/cookies.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Netduma Fraser said:

@andybtsn if 2.0 was your issue I'd recommend at least trying the 3.0 beta for the R1 before you decide on purchasing another router as it may just work fine for you and your connection: https://forum.netduma.com/topic/35821-new-r1-firmware-30207/ make sure you do a factory reset once it's finished upgrading and see if it performs any better for you. If it doesn't seem to load after the upgrade you'll need to clear your browser cache/cookies.

 

Cheers, I'll give it a shot before forking out on a new one

Share this post


Link to post
Share on other sites
7 minutes ago, Netduma Fraser said:

@andybtsn if 2.0 was your issue I'd recommend at least trying the 3.0 beta for the R1 before you decide on purchasing another router as it may just work fine for you and your connection: https://forum.netduma.com/topic/35821-new-r1-firmware-30207/ make sure you do a factory reset once it's finished upgrading and see if it performs any better for you. If it doesn't seem to load after the upgrade you'll need to clear your browser cache/cookies.

 

If I can click on that link Fraser it says I don't have permission to view?

Share this post


Link to post
Share on other sites
6 hours ago, Netduma Fraser said:

Ahh sorry about that, you can download it directly here: https://www.dropbox.com/s/8z4kcynmo3glplp/DumaOS-R1-3.0.207.sig?dl=0

Well I dug it out, upgraded to 3.0, reset to factory settings, stuck my router in bridge mode, all setup. Let the 3.0 guide run through, get to the dashboard and click on QOS, the dreaded spinning/loading circles appear and then eventually the good old error: "The operation is taking longer than expected. Please briefly wait before using this Rapp."

I'm not sure what to do, I don't understand how others are still using the R1 or I just have a broken one.

Just clicking into system info, takes around 20 seconds to load and then the CPU is maxing out at 100%. RAM usage 25% free. This is all just plug and play, I have configured nothing so far. I'm just watching the system info and the CPU just fluctuates between 80-100 so I'm still assuming this is hardware related?

Share this post


Link to post
Share on other sites
42 minutes ago, andybtsn said:

Well I dug it out, upgraded to 3.0, reset to factory settings, stuck my router in bridge mode, all setup. Let the 3.0 guide run through, get to the dashboard and click on QOS, the dreaded spinning/loading circles appear and then eventually the good old error: "The operation is taking longer than expected. Please briefly wait before using this Rapp."

I'm not sure what to do, I don't understand how others are still using the R1 or I just have a broken one.

Just clicking into system info, takes around 20 seconds to load and then the CPU is maxing out at 100%. RAM usage 25% free. This is all just plug and play, I have configured nothing so far. I'm just watching the system info and the CPU just fluctuates between 80-100 so I'm still assuming this is hardware related?

How did you do the factory reset, via the interface or using the button in the back of the router? It is quite odd it's doing that. 

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

How did you do the factory reset, via the interface or using the button in the back of the router? It is quite odd it's doing that. 

Interface but like I said it was like this on 2.0 so not a massive surprise

Share this post


Link to post
Share on other sites
47 minutes ago, andybtsn said:

Interface but like I said it was like this on 2.0 so not a massive surprise

Do it via the hardware button, if there is a software issue it should bypass this and offer a new slate. Hold the reset button for 30 seconds, release, wait 2 minutes then access, go through the wizard and see if it loads correctly.

Share this post


Link to post
Share on other sites
8 hours ago, Netduma Fraser said:

Do it via the hardware button, if there is a software issue it should bypass this and offer a new slate. Hold the reset button for 30 seconds, release, wait 2 minutes then access, go through the wizard and see if it loads correctly.

I will give it a go. I noticed something a bit odd when using my PC this morning, I loaded it up as I normally would and the internet page wasn't resolving as in if the internet was down, it took around 10/15 seconds for the page to appear. Not a reported problem on 3.0? I will keep tabs on it just a bit strange.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...