Jump to content
Netduma Luke

ANNOUNCEMENT: DUMAOS 3.0 IS HERE

Recommended Posts

50 minutes ago, Mobel said:

Still no 3.0 for XR700 ?

Haven't heard nothing about XR700 DumaOs upgrade, the topmodel that didn't get a upgrade or support for a year this is ridiculous.

Netgear should be ashamed of the very low level of support for a 400€,£,$ router.

I am using my 2016 ASUS now because I am done with this very slow updates that literally take ages. 

How can ASUS push almost every month a firmware update for a 4-5 year old model and keep updating their routers to work good and Netgear totally fails on this one.

It feels like a big middle finger to us the clients, from Netgear to us.

I get your frustration, we are much closer to having the beta available. I would envisage just a few more weeks if all goes to plan.

28 minutes ago, Telebubbies said:

Same with the XR500! No updates for over a YEAR. Not even security updates. The XR500 was marketed by people (including LinusTechTips) saying that there will be frequent updates and that DumaOS will just get better with time. But as I said, there has not been an update for over a year..

There was the exact same router from Netgear but without DumaOS that was 120 euros cheaper. That means I spent 120 euros on a operating system that isn't even supported anymore. Since I bought the router, there has not been a single update.

At least give us security updates! https://vuldb.com/?id.154181

Hey, welcome to the forum!

That link says to use .32 to fix the security update - the latest pre beta version is .56. XR500 is also in Open Beta at the moment so you can try 3.0 and help us find bugs. The latest firmware there has been removed for the moment while we fix a connectivity issue but we'll put another up soon.

Share this post


Link to post
Share on other sites

@Netduma Fraser

It is really frustrating that Netgear leave buyers of one of their topmodel routers with such a big lack of support for that product almost none updates for drivers, upnp, security cert, even for the DPI I can imagine it needs updates so it can categorize the packets.

It is really disappointing.

Share this post


Link to post
Share on other sites

I ordered my second Netgear xr700 it should arrive very soon.

I sold my first router because it was lack of updates but I realized now that I missing the Plex server functionality alote.

My question is when the beta 3.0 will came out for xr700, how long is the time span between beta and stable version?

Share this post


Link to post
Share on other sites
1 hour ago, Xrv said:

I ordered my second Netgear xr700 it should arrive very soon.

I sold my first router because it was lack of updates but I realized now that I missing the Plex server functionality alote.

My question is when the beta 3.0 will came out for xr700, how long is the time span between beta and stable version?

That's really impossible to say as it depends on how many issues are found during the beta. 

Share this post


Link to post
Share on other sites
10 minutes ago, Netduma Fraser said:

That isn't available at the moment but will be available in the future.

Ahhh, looking forward to that feature the most!

Love the new update!

Share this post


Link to post
Share on other sites

Everything I go to the Dashboard and some other pages, keeps saying *Applying Changes*.

 

Is that meant to happen

Share this post


Link to post
Share on other sites
21 minutes ago, jb68 said:

Everything I go to the Dashboard and some other pages, keeps saying *Applying Changes*.

Is that meant to happen

Clear your browser cache/cookies and refresh the page and should be fine. Please post any beta issues in the beta section.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

Clear your browser cache/cookies and refresh the page and should be fine. Please post any beta issues in the beta section.

Ahhh, It was to do with the Congestion Control Pinned on the Dashboard causes the *applying settings* and I will do!

Share this post


Link to post
Share on other sites

No its not, its been disabled again... 

What is going on there? Why does this takes ages to finish? and why does the download link getting disabled and re-enabled again.. 

Seriously, it should never take this long to pride us new firmware.. I blame Netgear though, last product i bought from them for sure. 

Share this post


Link to post
Share on other sites
48 minutes ago, hurricane1984 said:

No its not, its been disabled again... 

What is going on there? Why does this takes ages to finish? and why does the download link getting disabled and re-enabled again.. 

Seriously, it should never take this long to pride us new firmware.. I blame Netgear though, last product i bought from them for sure. 

link is workin for me

Share this post


Link to post
Share on other sites

Afternoon. Downloaded and installed the beta, no issues thus far. I was looking on how to install the AdBlocker feature via the R-App store, is this still pending implementation on the XR-500?

Share this post


Link to post
Share on other sites
4 hours ago, hurricane1984 said:

No its not, its been disabled again... 

What is going on there? Why does this takes ages to finish? and why does the download link getting disabled and re-enabled again.. 

Seriously, it should never take this long to pride us new firmware.. I blame Netgear though, last product i bought from them for sure. 

It hasn't been disabled again, the version has been up since Tuesday https://community.netgear.com/t5/Nighthawk-Pro-Gaming-DumaOS-3-0/Latest-firmware-download/td-p/1976833

48 minutes ago, MyersUK said:

Afternoon. Downloaded and installed the beta, no issues thus far. I was looking on how to install the AdBlocker feature via the R-App store, is this still pending implementation on the XR-500?

Hey, welcome to the forum!

It is up to Netgear to decide what features make it onto the router as it is their hardware so we'll have to see.

Share this post


Link to post
Share on other sites

Thank you!

FYI, if the link doesn't work for you, refresh or delete cookies.  I had a similar result until I did those steps, then the link worked!

Share this post


Link to post
Share on other sites
30 minutes ago, santa78 said:

Hi @Netduma Fraser the R-app store is not the same store for all DumaOS 3 routeur ?

Netgear must firt validate each application on the store ?

As with all their routers they will decide which features will appear on the router. For example the XR300 doesn't have the Hybrid VPN.

Share this post


Link to post
Share on other sites

@Netduma Fraser 

it's a shame to have its restrictions.
When the news on DumaOS 3 with the rappstore was published it was not indicated that its options would be restricted depending on the model.

Too bad that NetDuma does not offer its own DumasOS 3 router with SFP + connectivity, I would have to switch directly to your place to avoid these constraints ... :( 

Share this post


Link to post
Share on other sites
20 hours ago, Netduma Fraser said:

It hasn't been disabled again, the version has been up since Tuesday https://community.netgear.com/t5/Nighthawk-Pro-Gaming-DumaOS-3-0/Latest-firmware-download/td-p/1976833

Hey, welcome to the forum!

It is up to Netgear to decide what features make it onto the router as it is their hardware so we'll have to see.

I see, its working, thnx. 

Can you tell me or point me in the direction as to what has changed in the new os 3.0 compared to the previous one? 

Share this post


Link to post
Share on other sites
10 hours ago, Mobel said:

Any news about DumaOs 3.0 beta for XR700 ?

That should be pretty soon, within the next few weeks I suspect.

8 hours ago, santa78 said:

@Netduma Fraser 

it's a shame to have its restrictions.
When the news on DumaOS 3 with the rappstore was published it was not indicated that its options would be restricted depending on the model.

Too bad that NetDuma does not offer its own DumasOS 3 router with SFP + connectivity, I would have to switch directly to your place to avoid these constraints ... :( 

The Rapp store will be included but as it's not our hardware it is up to Netgear what they want on it - I can't imagine they won't want the features.

7 hours ago, hurricane1984 said:

I see, its working, thnx. 

Can you tell me or point me in the direction as to what has changed in the new os 3.0 compared to the previous one? 

The change log has been included in the post :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...