Jump to content
jsz

wifi calling intermittently working. (Soft fix)

Recommended Posts

I appreciate all the advice. I need the "wifi for Dummies" version. I am not a programmer/wifi expert and there is a lot of foreign language here. I will have to find some time to decipher and try some of these tips. Thanks! 

Share this post


Link to post
Share on other sites
12 minutes ago, JxRYE said:

I appreciate all the advice. I need the "wifi for Dummies" version. I am not a programmer/wifi expert and there is a lot of foreign language here. I will have to find some time to decipher and try some of these tips. Thanks! 

Here is a guide on how to disable private addresses on iOS 

https://support.apple.com/en-us/HT211227

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Fraser said:

I've got two ideas that might help and prevent you having to disable QoS each time:

  1. Make a guest WiFi network and connect the phone to it - does this work with QoS on?
  2. Put the phone IP in the DMZ in WAN Setup - if it does work then disable DMZ and let us know

So - the plot thickens. 
 

as for the dmz- I went into wan setup and used my app to get my phones IP address and applied that to the one line pertaining to dmz (hope that’s all that took) and this did nothing. 
 

I then started a guest network and even though I can’t seem to get any security set for it (I applied wpa2-psk security) it’s still an open network which I definitely don’t like but it worked and wifi calls can be made and received. This is all with qos enabled. 
 

I say the plot thickens because my wife’s iPhone this whole time also was on wifi calling. I used it to check my phone. This was never on the guest network and only has its connection to my main non-guest network set to no private Mac addresses. I tried turning airplane mode off and on on her phone and it connects to successful wifi calling regardless. Strange. 
 

she has an iPhone X. I have an iPhone 8+. Both are running iOS 14.6 which is the latest released os for all relatively modern iPhones. As I disabled guest network just now my phone will not reconnect to wifi calling. 

Share this post


Link to post
Share on other sites
6 hours ago, Netduma Fraser said:

Interesting! Re-enable the Guest WiFi again and then reboot from the interface, wait 2 minutes - does the Guest WiFi appear to be secured then?

So I guess I was just turning on the guest 2.4ghz security instead of the one I needed. It seems to work as intended now. It also allows wifi calling even when left in private Mac mode so so far so good. 
 

Also- my wife’s phone did drop a call yesterday so leaving her on the main network with qos on didn’t work for long it seems. 

Share this post


Link to post
Share on other sites
9 hours ago, DmyTgregu said:

So I guess I was just turning on the guest 2.4ghz security instead of the one I needed. It seems to work as intended now. It also allows wifi calling even when left in private Mac mode so so far so good. 
 

Also- my wife’s phone did drop a call yesterday so leaving her on the main network with qos on didn’t work for long it seems. 

Okay great, that seems to be the best workaround for the moment while still allowing you to use QoS - we'll be looking into the issue to get it fixed

Share this post


Link to post
Share on other sites

Has this issue been fixed? I have tried with my Qos off and on and still have the same problems. Sometimes the phone rings in my house, but 95% of the time I still have to stand in my driveway and turn wifi off to talk on the phone. (Reminder I am not a internet wizard so a lot of this DMZ,WAN, change your IP address talk goes right over my head). Cheers!

Share this post


Link to post
Share on other sites
17 hours ago, JxRYE said:

Has this issue been fixed? I have tried with my Qos off and on and still have the same problems. Sometimes the phone rings in my house, but 95% of the time I still have to stand in my driveway and turn wifi off to talk on the phone. (Reminder I am not a internet wizard so a lot of this DMZ,WAN, change your IP address talk goes right over my head). Cheers!

We don't have a fix for it as yet I'm afraid. Did disabling Private addresses on iOS devices not help you?

Share this post


Link to post
Share on other sites

Disabling private addresses did not help at all. This is becoming a problem as I am on call occasional weekends, and if my phone isn't able to ring....

Share this post


Link to post
Share on other sites
1 hour ago, JxRYE said:

Disabling private addresses did not help at all. This is becoming a problem as I am on call occasional weekends, and if my phone isn't able to ring....

OK thanks for confirming. Did you try enabling the Guest Wi-Fi Network as mentioned in this thread? If so, were you then able to make calls when connected to that network?

Share this post


Link to post
Share on other sites

The guest network did not help when I had it setup last year. I will have to try and figure out how to set it up again. We also have an UBI extender hardwired through the house (people who built it). I will have to see how that is connected and try that also (but only covers a small part of the house). My wife just shockingly called me from our living room, no breaking up or drop in the call. She googled it and went into her phone and reset the network settings in the phone. Don't know if maybe the phone saved information for the network from the old house causing issues or something!? We are occasionally able to make calls through house wifi, so will have to give it a day or two and see if this was the fix. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...