Jump to content
acoop133

OpenVpn putting mobile on a different subnet

Recommended Posts

My home network is on 192.168.1.x
So ive noticed that for some reason, when connecting to my router hosted OpenVpn:
* On android mobile, it puts me on the wrong subnet. 192.168.2.x.

* On laptop, it puts me on the correct subnet.192.168.1.x.

Any ideas?

Share this post


Link to post
Share on other sites

Do you have an ISP hub or another router that is on that subnet at all? Just to confirm when disabled does it go back to 1.1.? You're using the VPN service in the Netgear settings correct? Do you use it to access remotely?

Share this post


Link to post
Share on other sites

Virgin Media in modem mode, XR500 as only router; with OpenVpn set up on the XR500.

im not sure what you mean by this "Just to confirm when disabled does it go back to 1.1.?"

I use OpenVpn hosted on the XR500 to access network attached storage and password vault on the home network, remotely.

So in this situation, when im remote, i can access those two via laptop but cant on my mobile because its put on the wrong subnet.

Share this post


Link to post
Share on other sites

Have you selected "All sites on the Internet & Home Network" in the VPN settings?

I'll admit I haven't come across this problem before. The VPN Service is a feature that we're not involved in testing as it's provided by Netgear. 

The problem could be with the VPN Service, or it could be an issue with the configuration of the Android phone.

Share this post


Link to post
Share on other sites

Yes i have selected All sites on the Internet & Home Network.
 

it most likely could be the OpenVPN android configuration being incorrect. I havent made any changes manually so id expect more people would have this issue??

No idea.

Share this post


Link to post
Share on other sites

I just don't understand why two different devices would end up on different subnets.

If I have time today i'll test this using hardware in the office to see if the same thing is happening.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...