Jump to content

Recommended Posts

So I have a 200MBPS download and 20 ish upload package, works fine when connected directly to my ISP router at full speed however, no matter what settings/cables I use I never exceed 100mb using the netduma. This is using speedtest.net with nothing running in the background and all other devices turned off. test is run on a very good desktop PC as well so its not an issue of testing it incorrectly. I have also tested it on wifi and i get around 80 down with full connection but the full 200 when testing from the ISP router alone. I have tried numerous resoluttions such as turning on/off turbo mode, turning off the congestion control, resetting to factory defaults, turning off ipv6, among other solutions but none has made any difference at all.

 

Any Ideas?

Share this post


Link to post
Share on other sites

Do you run turbo mode?

 

And make sure you're not running PPPoE because this will restrict your bandwidth severely.

Share this post


Link to post
Share on other sites

I am not sure if i use PPPoE as i dont know how to check that, and i use the duma OS which has no direct turbo mode or so the research ive done tells me but they said turning the QoS off is like enabling turbo mode, nevertheless with it on or off makes no difference to the speed

Share this post


Link to post
Share on other sites

When doing a speed test, could you go to the System Information section of DumaOS and look at the CPU usage? Does it hit 100%?

Share this post


Link to post
Share on other sites

rereading your first post. Have you tried testing with cable from you PC straight to the ISP router. (it says wifi but not cable....)

 

100mbit cap is always a bit suspicious when it comes to cables.

 

In DumaOS settings -> monitoring -> statistics make sure it reads 1000M/Full at the WAN port.

 

The cables need to be CAT5E minimum. If it is 5E or higher but R1 reads 100M/Full, it has a internal damaged strand. 1GBit uses all 8 internal wires and 100M uses just 4, so on a damaged wire it will fall back to 100M.

Share this post


Link to post
Share on other sites

@Bert all tests were done wired and wireless so yes, also i can't find the monitoring section

 

@Netduma Alex

no, in the DumaOS it peaks at 90 and averages around 50 during the test, task manager never exceeded 40 during the test

 

 

Ok so I found this page in DumaOS. if I understand this correctly it is the wire going from the ISP router to the netduma that is the issue? however, I have tested with several known CAT6 cables before and had the same issue 

 

1(PoE)ConnectedFullDuplex100mbits

2DisconnectedN/AN/A

3ConnectedFullDuplex1000mbits

4DisconnectedN/AN/A

5ConnectedFullDuplex1000mbits

 

Share this post


Link to post
Share on other sites

Yes that looks to be the case that the cable between the ISP router to the R1 is only allowing 100mbits so whatever settings you change on the R1 will not have an affect until a new cable is used. Have you tried switching this specific cable for anything higher than Cat 6 or a new (recently bought) cable?

Share this post


Link to post
Share on other sites

As i said above, I have unplugged everything and set up my netduma right next to the ISP router using multiple different cat 6 cables, this was to test if it was the ethernet I am currently using or the length of it was the problem, this is not the case, the tests done with the cat 6 cables came back with the same results

Share this post


Link to post
Share on other sites

On the ISP router how have you set it up to use with the router? Is it in modem mode or bridge or are you using the DMZ? Does the modem have QoS? If so could you disable this please.

Share this post


Link to post
Share on other sites

I think it can't be done on the R1, but can you adjust port settings on the ISP router? Ie force it to 1000M full duplex.

 

That is definitly your issue. Either something is wrong with the autonegotiating handshake between the two routers, or there is an issue with the WAN port on the R1. If one of the pins is broken it will have the same effect as a broken strand in the cable, ie fall back to 100M.

 

I would expect the port on your ISP router to be ok since you have tried that, and it went to gigabit just fine connected to your PC.

 

 

Share this post


Link to post
Share on other sites

I can access the port settings sure but I will need a guide through it, as for the WAN port, it is fairly old the netduma itself but I can't see it being damaged although it is a possibility I would assume its a very small one

Share this post


Link to post
Share on other sites

I'm with Virgin Media as well, as far as I'm aware there is nothing in the settings that will be hindering you. Could you have a look at the WAN port on the R1 and see if it looks the same (no pins out of place etc) as the other LAN ports?

Share this post


Link to post
Share on other sites

I will check tomorrow for the WAN ports, in the meantime, you got any more possible fixes? If the WAN port isnt the problem that is

Share this post


Link to post
Share on other sites

You can always try the following:

 

1. plug your LAN cable from PC into the WAN port of the R1. This won't do anything connection wise since the R1 won't get a IP, but it wil perform the auto negotiating handshake, ie detect the cable type.

2. log into your R1 over wifi with PC and check the ports menu again, see if you get 100M or 1000M.

 

This will give you another datapoint on the WAN port of the R1, if it's stuck on 100M or if it jumps to 1000M.

 

Share this post


Link to post
Share on other sites

Some of the other ports are reporting correctly so could you switch the ethernet cables from one of the working LAN ports to the WAN port and vice versa and see if they switch or change the same in the device manager please?

Share this post


Link to post
Share on other sites

I built my pc myself and didnt include a wifi adapter because I never expected to use it via wifi so can't do that @Bert and @Netduma Fraser I tried that but because it is in modem mode the ISP router must be connected to the wan port in order for me to get internet. I checked the wan port as well for broken pins but they all seem to be intact and not bent

Share this post


Link to post
Share on other sites

Actually these things don't really matter.

 

You can also use your phone for example to log into the R1 and check the menu.

 

What Fraser and me are suggesting is that you merely use another device connected to the WAN port of the R1 and then check in the R1 menu if the WAN port still shows 100M or 1000M. You don't need internet acces for this, there just needs to be a cable inserted with a device on the other side and you need some means to log into the R1.

 

You can also leave your PC connected to LAN1 on the R1 and log in through that. Move your cable from the ISP router from WAN on the R1 to a open LAN port on the R1 and see if it changes. But I would prefer to use the PC or another device since if there is autonegotiating mismatch there is chance it also shows on the LAN ports.

Share this post


Link to post
Share on other sites

ah i see but how can I get into DumaOS to check the ports to see if it is 100 or 1000mb if I have no connection to the internet through the netduma?

Share this post


Link to post
Share on other sites

It wil show the status of that port regardless of your internet connection. Even if it doesn't give you internet, it will still autodetect the link speed on that port.

 

The handshake between the two devices is purely a hardware thing.

 

Like I just moved my WAN cable on my XR500 to LAN4 and it shows WAN link down and LAN4 1000M/Full. Move it back to WAN, my internet works again and now WAN will show 1000M/Full.

Share this post


Link to post
Share on other sites

I see, I just did that after a lot of faffing around, while trying tro switch the ethernets around my internet dropped and wouldnt recognise the network even when putting it back to normal but it seems fine now. 

 

The port changed to 1(PoE) connected fullduplex 1000mbits when i put the ISP ethernet into port 5 and put my computer ethernet into the WAN port

Share this post


Link to post
Share on other sites

Yeah so it does handshake at 1000M/Full between R1 and your PC, meaning the WAN port is fine.

 

So there is an issue with the cable between both your ISP router and R1 or simply with how the two systems interact, ie somehow they don't handshake properly at 1000M.

 

Did port 5 go down to 100M when you swapped the cables by coincidence?

Share this post


Link to post
Share on other sites

As above it does indicate it is the ethernet cable, leave it the way it is setup at the moment, get the internet back and then speed test from a device that has 1000M and see if it works properly then.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...