Jump to content
kinel

how to get better hit detection

Recommended Posts

It seems to happen after an update to the game for whatever reason. When it happens I go back to the drawing board, meaning I try all the suggested tips from these posts to dial in what works again. It’s maddening but for me necessary. All I can suggest is tweak the settings until you find it playable again. 

Share this post


Link to post
Share on other sites
1 hour ago, K0NSPIRACY said:

My hit reg has noticeably and literally turned to shit the last few days playing COD WZ on Xbox One X. I haven't changed any settings on my router or R2 (geo filter, QoS and ports), my wired internet connection is stable and all games are connected to UK servers with 15-25ms ping. Is anyone else experiencing similar issues, and is there a definitive guide/advice/tips for better hit reg playing on Xbox?

Have you rebooted your router? For me sometimes a reboot is all it needs, sometimes. But it could be the game too.

Share this post


Link to post
Share on other sites
34 minutes ago, Kfetish said:

It seems to happen after an update to the game for whatever reason. When it happens I go back to the drawing board, meaning I try all the suggested tips from these posts to dial in what works again. It’s maddening but for me necessary. All I can suggest is tweak the settings until you find it playable again. 

What settings would you suggest tweaking and what are you using? I’m not sure what I need to change as I haven’t added any major configuration changes in geo filter, qos or ports.

Share this post


Link to post
Share on other sites
Just now, Alex49H said:

Have you rebooted your router? For me sometimes a reboot is all it needs, sometimes. But it could be the game too.

I’ll give that a try next time I play and if/when I experience the issue again. I have a BT Openreach engineer coming out tomorrow for an issue with significant drops in download speeds during the evening...however I don’t play at all during these times until normal service is resumed (usually happens from approx 6pm-11pm), and I sincerely doubt they’ll find any issues (they never do tbh) so I doubt these speed drops are anything to do with my hit reg in game.

Do you mean rebooting the ISP router or the R2 as well? Pretty sure I read on here somewhere that we shouldn’t reboot the R2 unless we really need to?

Share this post


Link to post
Share on other sites

For me after an update I always have to find the sweet spot on anti bufferbloat, sometimes never works best, other times always does. I also have to adjust the amount of speed both up and down. Share excess both checked sometimes is best then other times neither checked is better or only share excess ticked does the trick. It’s a shame to have to do all this in order to enjoy the game. My hit detection seems consistent, the bigger hurdle for me is getting on the right side of lag compensation. Even with great hit detection I’m usually a half second behind. The killcam proves it. I’ve tried servers far from home, close to home, I’ve tried the magic “between 40-60ms ping servers”, to no avail. Sometimes throttling my speed to absurdly low helps, but normally only for a game or two. 

Share this post


Link to post
Share on other sites
1 hour ago, Kfetish said:

For me after an update I always have to find the sweet spot on anti bufferbloat, sometimes never works best, other times always does. I also have to adjust the amount of speed both up and down. Share excess both checked sometimes is best then other times neither checked is better or only share excess ticked does the trick. It’s a shame to have to do all this in order to enjoy the game. My hit detection seems consistent, the bigger hurdle for me is getting on the right side of lag compensation. Even with great hit detection I’m usually a half second behind. The killcam proves it. I’ve tried servers far from home, close to home, I’ve tried the magic “between 40-60ms ping servers”, to no avail. Sometimes throttling my speed to absurdly low helps, but normally only for a game or two. 

SBMM hits everyone in "real time" it is always there...even  during a match..thats why when you start a game maybe you have perfect hit detection..but in the middle of tha game "something" changed and your hit detection is crap...your character is "heavy" to run..bullets dont register quickly and so on....server sends to you big streams of tcp traffic to "flood" your line in upload traffic with ACK packets...so your udp traffic "DURING" the match is delayed  by "artificial lag".

Game what ever bandwidth you have sends in a clock tick rate of 64 packets per second...so if your line has to many tcp packets from "flooded"....in one second etc it sends to server 50 tcp packets that is useless to game and only 14 udp packets....so that is your delay to server!!!!

Share this post


Link to post
Share on other sites
On 1/11/2021 at 6:57 PM, Dyson350 said:

What port ranges and protocol should I be setting my Traffic Prioritization to for PS5 Cold War? I have tried looking through the thread but tbh its way too unorganized and all over the place for me to make sense of any of it.

Thank you you are correct its  was way to confusing   so its been edited

Btw this thread was originally meant for mw2019 

If its still to confusing i will try to efit a bit more

Thank you for poining it out

Share this post


Link to post
Share on other sites

VERY interesting. There’s been several matches where I started off unstoppable and went on say an 8 or 9 kill streak and then...BAM, all of a sudden I can’t kill anyone and get insta melted. Like I all of a sudden forgot how to aim. I always chalked it up to ppl rage quitting and it making me host mid match. Hmmm 🤔

Share this post


Link to post
Share on other sites

Last couple of weeks I've been getting alot of shoot first die first. Nothing has changed my end. CW didn't sell well despite what they claim...

CW is currently 4th in the UK weekly charts with GTAV above it LOLZ. What does that tell you!? 

The recent CoD is usually 1st or 2nd all year round and CW is 4th after just 2 months after release with a 7 year old game above it and the latest FIFA.

Acti know peoples wanna stay on MW, hence turning MW into an advert for CW and wiping the MW name from the game. I believe they messing up the game on purpose at this point.

Share this post


Link to post
Share on other sites

 I was doing some more testing today and i noticed

The game is now using  port 443 tcp  a lot

It is  the destination not source

If any one wants to try it as i havent worked out the exact port ranges yet 

I need more testing

But you all could try this it should be good

Rule 3  source  50000 -65535 source 443  tcp only

 

Share this post


Link to post
Share on other sites
On 1/6/2021 at 4:57 PM, Kfetish said:

Just wanted to update the post by saying those settings helped overall. Thanks again. I guess my bigger issue is lag comp. I’m almost always a half second behind, and in a game where you die in milliseconds, it’s a major disadvantage. I’ve tried pc in dmz, pc not in dmz, WiFi 2.4 and 5ghz, congestion control on always from almost no bandwidth all the way up to full speed in small increments, congestion control on never also from almost no bandwidth to full speeds, share excess on, share excess off, upnp on, upnp off, only share upload ticked, close servers, far servers, in between servers, cross play enabled, cross play disabled. I’ve pretty much exhausted all options. Like everyone I’m just searching for a consistent, fair experience. 🤷🏽‍♂️

Upload speed 0.5 with share excess unticked ... works for me,  download does not really matter . Make sure you close down the game and re start . Check settings in game and your bandwidth should show very low 120 - 300 ish  and should improve your experience 

Share this post


Link to post
Share on other sites
On 1/14/2021 at 12:18 PM, Kfetish said:

VERY interesting. There’s been several matches where I started off unstoppable and went on say an 8 or 9 kill streak and then...BAM, all of a sudden I can’t kill anyone and get insta melted. Like I all of a sudden forgot how to aim. I always chalked it up to ppl rage quitting and it making me host mid match. Hmmm 🤔

Been there many times .... and the reverse playing poorly can’t hit shit just about to quit and them boom I am a beast ..... crazy things they have done to the game  !!

Share this post


Link to post
Share on other sites

its the lag compression engineering changing mid game to make the match fair. i would do the same thing drop a 10 to 20 bomb then die 5 times in a row right after like i forgot how to play. they started that in b04

Share this post


Link to post
Share on other sites

Like I mentioned on the previous page when I looked at an old capture there were 3 TCP ports in use during my game, 1 of which was 443. The IP was from "akamai technologies" which is a CDN so in my case it looks like my ps4 was maybe checking for an update for one of my games or maybe even downloading one..

I personally wouldn't prioritise any tcp ports, especially 443 cause it's not gaming traffic.

Share this post


Link to post
Share on other sites
7 hours ago, TODDzillaInLA said:

its the lag compression engineering changing mid game to make the match fair. i would do the same thing drop a 10 to 20 bomb then die 5 times in a row right after like i forgot how to play. they started that in b04

I have experienced this a lot, first round of domination im doing great - hit reg is spot on then second round i'm shooting rubber bullets. I've also been on the other side though, nt being able to kill anything first round then second round coming back and dominating, hearing people rage in the killcam, saying they can't kill me etc

Share this post


Link to post
Share on other sites
17 hours ago, TODDzillaInLA said:

they started that in b04

I had so many matches just like that on IW so I believe they've being using this system for alot longer.

Share this post


Link to post
Share on other sites
On 1/14/2021 at 5:12 AM, K0NSPIRACY said:

My hit reg has noticeably and literally turned to shit the last few days playing COD WZ on Xbox One X. I haven't changed any settings on my router or R2 (geo filter, QoS and ports), my wired internet connection is stable and all games are connected to UK servers with 15-25ms ping. Is anyone else experiencing similar issues, and is there a definitive guide/advice/tips for better hit reg playing on Xbox?

Yesterday when i started  (17:00 gmt) i could normally play warzone for the first time ever, solo 3 wins in one day and many kills. Today activision release shit update and again cod is unplayable.  You know  when you think you should kill someone but you  not its just shit netcode/ lag compensation of this game.

Share this post


Link to post
Share on other sites

Guys use 1-65535 source, and 3074-65535 destination.UDPTCP

 

you’ll pull high bandwidth and have better games trust me. Make sure you download more than upload, if not, restart ur console and router until u do. Then you’ll know it’s working

Share this post


Link to post
Share on other sites

Interesting. Will try and report back. I’m very pleased with my settings atm but will always shoot for better lol. 

Share this post


Link to post
Share on other sites
23 minutes ago, fiefo said:

Guys use 1-65535 source, and 3074-65535 destination.UDPTCP

 

you’ll pull high bandwidth and have better games trust me. Make sure you download more than upload, if not, restart ur console and router until u do. Then you’ll know it’s working

Im laughing, you know you give a prioritization for all ports?

Share this post


Link to post
Share on other sites

Fraser said Source is always 1-65535, this is the game. 
 

the destination , is what we’re are prioritizing 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...