Jump to content
East

Traffic Prioritization Settings: Modern Warefare (BO4)

Recommended Posts

2 hours ago, Grafti said:

That's why I quit playing CoD on PC.

I turnned me crazy. Reading steam forum topìcs about settings... that if you lower your resolution you get less lag, that if you modify that game file with different values it will help you against lag-comp, that if you do that, if you do these... and at the end (like always) nothing worked at all. If router settings were not enough for blowing up my head, I had to add PC settings, so I feded up and returned to console gaming. And, even though, I still have headache trying to fix my connection, because despite all settings, I'm still having 7-8 bad games every 10 matches

One thing I've been messing with the last couple of sessions that has made things a little better for me at least is lowering the speed on your device (for me, my Xbox) in Bandwidth Allocation on DumaOS to 0.12 and leaving Anti BB on but with silders @ 100/100.

I'm finding peoples seem to drop quicker when I try this BUT... it also kinda seems that I also drop quicker lol.

Try see... see how it goes for you. I'm finding that 'shoot first die first' is happening a hell of alot less.

Share this post


Link to post
Share on other sites
1 hour ago, N3CR0 said:

One thing I've been messing with the last couple of sessions that has made things a little better for me at least is lowering the speed on your device (for me, my Xbox) in Bandwidth Allocation on DumaOS to 0.12 and leaving Anti BB on but with silders @ 100/100.

You mean 0,12 mb/s in dowload speed?

I was trying to set bandwich allocation to 25/5, but... meeehh

 

 

Share this post


Link to post
Share on other sites

I did that as well the other day, was getting disconnects at 128kbit. I did it via PC software though. At 256kbit it was playable but still I feel just full open connection is better most of the time.

Share this post


Link to post
Share on other sites
25 minutes ago, blackfirehawk said:

Tried that .. laggy Like hell for me

Doesn't lag at all for me but then again, I have slow ass internet anyways.

Share this post


Link to post
Share on other sites

On the OG firmware, I’m curious how just switching from reactive to preemptive would do? This in itself I think would take my 300/300 & tone it down. It’s a different algorithm so I wonder how that’d work since it’s designed for slower internet speeds. 

Share this post


Link to post
Share on other sites
3 hours ago, Bert said:

I did that as well the other day, was getting disconnects at 128kbit. I did it via PC software though. At 256kbit it was playable but still I feel just full open connection is better most of the time.

Forgot to mention, turn off Share Excess for both down and up.

Share this post


Link to post
Share on other sites

If any of you are hindering your bandwidth but prioritizing the call of duty port it will still give you full speeds.  So if your looking to restrict your bandwidth make sure your Cod ports are not prioritized.

Share this post


Link to post
Share on other sites
1 hour ago, N3CR0 said:

Forgot to mention, turn off Share Excess for both down and up.

 

I did it on PC actually. 

 

So PS4 -> PC -> XR500.

 

I limit my UDP connection from the PS4 specificly that way. 

 

I tried setting the network card to 10mbit half duplex as well but that was unnoticable.

Share this post


Link to post
Share on other sites
Just now, Bert said:

 

I did it on PC actually. 

 

So PS4 -> PC -> XR500.

 

I limit my UDP connection from the PS4 specificly that way. 

 

I tried setting the network card to 10mbit half duplex as well but that was unnoticable.

It seems to not be working for me now anyways. Tried it tonight, everyone was sponging.

Share this post


Link to post
Share on other sites

I'm playing shipment to level some weapons on my second account and it's the laggiest shitshow I have ever seen LOL.

Share this post


Link to post
Share on other sites
16 minutes ago, Bert said:

I'm playing shipment to level some weapons on my second account and it's the laggiest shitshow I have ever seen LOL.

Yup. Just went 60 - 30 on Shipment Dom. Enemies literally standing on my claymores and not setting them off!

Share this post


Link to post
Share on other sites
16 hours ago, East said:

I will defer to those who use R1 in this thread.  However, trial and error is the best advise I can give.  There is no one way fix for all.  However, it does seem that creating a port range for traffic prioritization for those ports not listed does help.  I would suggest you start by creating the 4 rules mentioned and play a few matches of both MW and BO4 to see if you notice any difference or not.  I hope that helps.

Perfect, I’m going to start with the ports as this is one thing I’ve yet to try. 

Share this post


Link to post
Share on other sites

I think we have to wait for the next Game Update (or dumaos) 

 

At the Moment there is notting we can do against the ingame syncing.. 

I tried many Things.. even Put my PC direkt into Modem (as only device) didnt make a differents in First Shot First die moments

Prio Helps only with multiply devices Connected to the netduma Router. 

Bufferbloat and some settings Helps with hitdetection

But nothing Helps against the desync and First Shot First die bullshit Moments

 

Its a Server Thing we cant change.. WE only can optimize what we will have local

 

Share this post


Link to post
Share on other sites

I’m on xr500 and I’ve been messing with setting. I prioritized UDP 3074-45000:30000-45000 my traffic prioritization light doesn’t come on, but I’ve noticed a huge difference In hit detection both on my pc and PS4 I have my thing set to never as well. So far it’s the best it’s felt so far in this game. 

its either that or 3074-45000:3074-45000 whichever one doesn’t trigger the traffic prioritization. I apologize I’m not home to check it to be sure which one Is the exact one.

Share this post


Link to post
Share on other sites

Actually both should work. But you might want to check the in game menu under external IP and see what port it uses. Maybe 3074 isn't the right one for you.

 

I have 3074 when I connect straight to the XR500 and above 60.000 when I connect through my PC.

Share this post


Link to post
Share on other sites

So, you’re using 3074-45000 as source? I’m using 3074-3075 source, then 30000-45000 for destination (all UDP only). I’m on OG R1 firmware but not sure if that matters? 

Share this post


Link to post
Share on other sites

okay, today i testet something.. i use a tool that let me emulate connection issues

 

Unbenannt.PNG.487c729b23e4a06b9dc805628bfe8429.PNG

 

this  tool let me add connections issues to my connections or to specific Ports

it let me add 

Latency

Packetloss

Paket Duplication

Paket Reordering

Corruption of Pakets

Limit bandwitch

and i can set upload and Download different

 

i have testet it the whole morning..after every setting i make a fresh gamestart

  and i have come to a conclusion..

 

Latency isnt the issue.. adding latency both ways just add only latency.. the game itself dosnt improve.. you only get the feeling that you play on a higher latency

Packetloss..  yeah its what it is.. you can how many % latency get lost.. hitdetection sucks really really bad.. beaming around corners.. choppy feeling game is unplayable

Paket reordering/corruption lags like hell.. unplayable

Limit Bandwith... no difference.. under 256kbit its unplayable

 

what actuell does a big different is follow

Paket Duplication!.. it duplicate every arrived and sendet paket from the game.. (udp port 3074).. every paket is send 2 times.. 

Enemys are slow.. and die like its hardcore.. 3 bullets from a  AK47 .. i had Lanparty feeling.. like iam a second ahead

wish i could record it..but my PC is to slow to record and play at the same time without stutter :(

 

 

seems like normal the game suffer from big paketloss.. and you get only a paketloss warning under 12 pakets/sec ..

so maybe some pakets are going lost on the way to client.... or the game itself has a problem with the paketflow and discard some pakets 

but aktuell the gameplay feeling and the feeling a secound behind is becouse of lost/discarded pakets and the game trys to compensate for that and calculate the enemy movement wrong

 

i will try to record a gameplay this evening..

 

 

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, blackfirehawk said:

okay, today i testet something.. i use a tool that let me emulate connection issues

 

Unbenannt.PNG.487c729b23e4a06b9dc805628bfe8429.PNG

 

this  tool let me add connections issues to my connections or to specific Ports

it let me add 

Latency

Packetloss

Paket Duplication

Paket Reordering

Corruption of Pakets

Limit bandwitch

and i can set upload and Download different

 

i have testet it the whole morning..after every setting i make a fresh gamestart

  and i have come to a conclusion..

 

Latency isnt the issue.. adding latency both ways just add only latency.. the game itself dosnt improve.. you only get the feeling that you play on a higher latency

Packetloss..  yeah its what it is.. you can how many % latency get lost.. hitdetection sucks really really bad.. beaming around corners.. choppy feeling game is unplayable

Paket reordering/corruption lags like hell.. unplayable

Limit Bandwith... no difference.. under 256kbit its unplayable

 

what actuell does a big different is follow

Paket Duplication!.. it duplicate every arrived and sendet paket from the game.. (udp port 3074).. every paket is send 2 times.. 

Enemys are slow.. and die like its hardcore.. 3 bullets from a  AK47 .. i had Lanparty feeling.. like iam a second ahead

wish i could record it..but my PC is to slow to record and play at the same time without stutter :(

 

 

seems like normal the game suffer from big paketloss.. and you get only a paketloss warning under 12 pakets/sec ..

so maybe some pakets are going lost on the way to client.... or the game itself has a problem with the paketflow and discard some pakets 

but aktuell the gameplay feeling and the feeling a secound behind is becouse of lost/discarded pakets and the game trys to compensate for that and calculate the enemy movement wrong

 

i will try to record a gameplay this evening..

 

 

 

 

 

How is your setting? Do you have console through PC? Briged connection?

Man, this info is GOLD! Thnaks for that!

Share this post


Link to post
Share on other sites
42 minutes ago, Grafti said:

How is your setting? Do you have console through PC? Briged connection?

Man, this info is GOLD! Thnaks for that!

I Play on pc... Just only installed the tool

Maybe it will Work If a console is Bridget true a PC.. but i dont know

Share this post


Link to post
Share on other sites
39 minutes ago, blackfirehawk said:

I Play on pc... Just only installed the tool

Maybe it will Work If a console is Bridget true a PC.. but i dont know

Surely it would affect your entire network thus should affect your console without bridging to your PC... right? (Could be wrong, a little over my head probably lol)

Prehaps you could do the same thing with Putty? It can increase latency, duno what else exactly it can do.

Share this post


Link to post
Share on other sites
3 minutes ago, N3CR0 said:

Surely it would affect your entire network thus should affect your console without bridging to your PC... right? (Could be wrong, a little over my head probably lol)

Prehaps you could do the same thing with Putty? It can increase latency, duno what else exactly it can do.

Look for Paket duplication...

 

 

I can Set Ports in this Tool.. Like in netduma i have Set a source Port  (3074) and a Destination Port (30000-45000)

And i can Set specific IPs Too so i dont think it will affect with the entire Network..

 

Its Just affect the Computer that Tool is running.

Its Like a additional Driver..

I Play on that pc too (PC Gamer) and interfere only with my Networkcard ( i can choose what Networkcard It is hooked in)

And i only duplicate Pakets that Go in and Out  on Port UDP 3074

Every Paket is sendet two Times..so even there is a Paket that is lost.. there will be a second after that

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...