Jump to content
DOGGAVELI

XR700 Cod Modern Warfare Xbox Moderate Nat

Recommended Posts

Hi All,

          Just recently I have been getting Moderate Nat in Call of Duty on Modern Warfare on Xbox. I have two Xbox consoles an S & X may daughter was playing Blacks Ops 4 and I was playing Modern Warfare. My Daughter turned of the S and I rebooted the X and still had moderate nat. I tried DMZ the X and that still didn't work.

I using my ISP Router connected to XR700 (ISP modem DMZ XR700) then I have an SX10 Switch for all my wired devices and UPNP is enabled in ISP Modem, XR700 & Switch.

I have attached the UPNP page which shows both Xbox's are using the 3075 port but the S was Switched off and only the X was on.

 

Any help appreciated I'm rock Firmware version 1.12 in the XR700.

 

Cheers Dogga

 

UPNP XR700 MW.jpg

Share this post


Link to post
Share on other sites
On 11/30/2019 at 5:24 AM, Netduma Fraser said:

Do the consoles both report open NAT in settings? Also in the Settings change the port they’re using to the respective ones shown on UPnP. If you disable the Geo-Filter then boot up the game does it show as open?

Hi Fraser,

                I fixed it mate I have my ISP DMZ to XR700 then I needed to DMZ the Switch in the XR700 now getting open nat on both consoles.

Kind Regards,

Dogga

 

Share this post


Link to post
Share on other sites
On 12/10/2019 at 6:09 AM, e38BimmerFN said:

Since you have two xbox consoles online at the same time, set NAT Filter to OPEN:

https://badmodems.com/Forum/viewtopic.php?f=6&t=21&sid=4fc0cc16534a4866e70b4d7aa85a031a

 

Don't DMZ the switch. 

Hi E38,

            Tried that and one gets open and the other get moderate nat still.

On our second console if we close Cod MF and re launch it gets open Nat the second attempt just not the first.

On our ISP modem I have UPNP disabled but DMZ the XR700, then I have the XR700 connected to the Sx10 switch which has all our wired connections running from it.

UPNP in enabled in the XR700 and also in the Sx10 Switch.

@Netduma Fraser @e38BimmerFN

Kind Regards,


Rob.

 

Share this post


Link to post
Share on other sites

Also check and see if NAT Filter set to OPEN changes anything. For two or more game consoles, NAT Filter should be set to OPEN. However I remember that NAT Filter wasn't working correctly when set to OPEN. Not sure if this was ever fixed or not. 

Share this post


Link to post
Share on other sites
13 hours ago, Netduma Fraser said:

Hey Rob, just checking are you still have the issue or is it still fixed with the Switch in the DMZ?

Hi @Netduma Fraser,

                Still having it mate its got me absolutely beat.

Yesterday I removed the switch and tried connecting both consoles to the XR700 with the Nat set to open in the XR700 not secured.

Both Consoles got open nat in Cod MW no issues. As soon as I reconnected the Switch same thing happens the X always get open Nat.

The S gets moderate first attempt but if you close the game and re launch it gets open the second time.

In the switch i have messed around with turning UPNP on and off and not matter what it still does the same thing.

I tried to turn off UPNP in the Xr700 and DMZ the Switch and still the same issue occurs.

Kind Regards,
Rob.

Share this post


Link to post
Share on other sites
1 hour ago, e38BimmerFN said:

Also check and see if NAT Filter set to OPEN changes anything. For two or more game consoles, NAT Filter should be set to OPEN. However I remember that NAT Filter wasn't working correctly when set to OPEN. Not sure if this was ever fixed or not. 

It appears to be fine tried that and it worked fine, but once i connect the sx10 switch same problem

Share this post


Link to post
Share on other sites

Remove the switch if you can't disable the features on the switch. I believe this switch has it's own QoS. Something to disable if you can. If not, find you a non managed non green ethernet switch. HP ProCurve 1400/1800 series are good switches. 

Share this post


Link to post
Share on other sites
On 6/18/2020 at 3:40 AM, Netduma Fraser said:

Are you able to make the switch unmanaged/disable all features at all? 

@Netduma Fraser @e38BimmerFN Hi Fraser & e38 Appreciate your advice/help the last couple of days with this ongoing problem I have with my current setup.

Unfortunately I was unable to turn of all the features of the SX10 Switch as it has very little options to tweak and change settings.

However after many many hours of trialing different setup and options in both devices I have managed to work out how to get everything running correctly; and found out there are two options to get the Nats right in any COD game.

  1. XR700 with UPNP enabled and DMZ the second Xbox IP address with Nat open in the XR700 and UPNP off in the switch. (Both Consoles always had open Nat in any Cod game WW2, Black Ops 4 & MW)
  2. XR700 UPNP turned off Port Forwarded Both Xbox Console Ports only and Nat open on XR700 and UPNP off in the Switch. (Both Consoles always had open Nat in any Cod game WW2, Black Ops 4 & MW)

I wanted to post/share the results so now anybody using the same setup as me has two solutions to work with. I researched this everywhere and found no other posts from anyone with my current setup. 

Just out of curiosity Fraser of the two options I found what one do you think would give me the best network connection? I'm not much of a network expert but glad/relieved that I will always have open nats now with COD and can continue to use my current setup as I'm using the 10GB setup from Xr700 to the Switch.

Thanks again Fraser and E38 for your help and advice.

Kind Regards,

Rob.

Share this post


Link to post
Share on other sites

I would not use DMZ and use the 2nd option. Of course, you should need to configure anything if you left uPnP enabled and removed the switch and put in a non manged non QOS featured switch. Seems that the SX10 switch is the cause of the problems. Seems that the NAT, uPnP and Port handling of the SX10 switch is causing problems when in the mix or maybe casing a double configuration since there is both NAT, uPNP and Port already being handled by the XR router. Putting the SX online is doing something again that really isn't needed beyond the XR router. If you had a different switch with out all these features on the switch, you would only need uPnP, NAT Filter set to OPEN on the XR router and both xboxes would be OPEN, both in networking settings and in game. How my XR450 works with my switches I have in use. 

Good Luck. 

 

 

Share this post


Link to post
Share on other sites

Well done for figuring out a workaround and thanks for posting it for others to use if needed. I would agree with e38 in that the second option is the better of the two - it is definitely more secure than the first option. Just remember if you haven't already done so to set static/reserved IP addresses for these devices so that your port forwards always apply.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...