Jump to content
kymadn

High Priority Traffic possible bug with Indicator light?

Recommended Posts

12 hours ago, kymadn said:

So when can we expect a patch to fix this? This is a pretty significant issue. The router is suppose to improve Qos but is actually causing throttling. 

Can the software code be changed to disable High Priority Detect, if no High Priority packets are sent or received within 60 seconds rather then triggering off High Priority ports?

If its a  Netgear bug yes, from what has been said if its a Netduma's issue, then no. They are working on DumaOS 3.0 which has been prioritised over bug patching in Milestone 1.3. There is no ETA on 3.0 at this time.

Share this post


Link to post
Share on other sites

I have found something interesting while testing this.. The only thing that seems to work better is knowing your actual Source Port.. So instead of using any of the Netduma preconfig settings I used the advanced tab and input the ports manually. But this only worked when knowing my own Source Port. You cant use the start port 1 and end port 65535. You have to know your actual port for each given rule you add.. The light then seems to go off in a fairly timely manner and doesn't get stuck on.. Even though I feel it seems to get slower as time goes on but it doesn't get stuck.. So heres an example of what I did..

Source Port 

Start 50038

End 50038

Destination Port

Start 30000

End 30010

UDP.

Right now the way I have mine setup is where the light only comes on when im actually playing a game. The light doesn't come on when I first turn my console on only when im playing a game. Meaning each time a game is done and im back in the lobby not playing a game the light goes off.. Until I start the next game and once the server is selected for the next match the light comes back on..

I game on the Xbox One X. I have not tested this yet using the tunneling port 3544 as a separate rule.. Anytime anyone adds 3544 that will kick the light on right when one turns there console on. And im not entirely sure that tunneling port should be used or not.. Will test that tomorrow though to see what kind of game impact it has.. If I do add this it will be a separate rule added like above but instead the Source Port number would be different then above.. So heres an example of what that would look like. It would be another added rule separate from the one above..

Source Port

Start 57300

End 57300

Destination Port

Start 3544

End 3544

UDP.

Hope this isn't confusing for some to understand. But the key would be knowing what your Source Port is for each Destination Port that one targets..

Zippy.

Share this post


Link to post
Share on other sites

@Zippy i dont have the issue while gaming from a console. Only gaming on a PC causes the stuck high priority traffic

Share this post


Link to post
Share on other sites
19 minutes ago, kymadn said:

@Zippy i dont have the issue while gaming from a console. Only gaming on a PC causes the stuck high priority traffic

I find that interesting.. I think Jack mentioned that a PC uses Netdumas own DPI engine for this. So maybe there is a bug in Netdumas DPI engine in your case?? Lets see what Alex finds out for you.. I have to say whatever is the cause I feel the light should still respond much faster then it does.. I still notice it gets sluggish the longer I play.. Have you tried manually adding ports also?  Im also a bit surprised your console works fine! Maybe we should exchange routers! lol.. I have seen others list there PC as a console and it worked for some that way.. Doesn't seem to be a fix for everyone though. Makes me think its a tunneling port causing this.. 

Zippy.

Share this post


Link to post
Share on other sites
5 hours ago, Zippy said:

I find that interesting.. I think Jack mentioned that a PC uses Netdumas own DPI engine for this. So maybe there is a bug in Netdumas DPI engine in your case?? Lets see what Alex finds out for you.. I have to say whatever is the cause I feel the light should still respond much faster then it does.. I still notice it gets sluggish the longer I play.. Have you tried manually adding ports also?  Im also a bit surprised your console works fine! Maybe we should exchange routers! lol.. I have seen others list there PC as a console and it worked for some that way.. Doesn't seem to be a fix for everyone though. Makes me think its a tunneling port causing this.. 

Zippy.

Never liked IPv6 tunnelling,. From what I know (I'm a PS4 user) you should ideally use IPv6 with the Xbox or it will resort to Teredo tunnelling, is that correct, Zippy? I know Windows used to do that, but its been over ten years since I have used windows myself.

Share this post


Link to post
Share on other sites
2 hours ago, Killhippie said:

Never liked IPv6 tunnelling,. From what I know (I'm a PS4 user) you should ideally use IPv6 with the Xbox or it will resort to Teredo tunnelling, is that correct, Zippy? I know Windows used to do that, but its been over ten years since I have used windows myself.

Im not a fan of the tunneling port either. And I do believe that is correct Teredo tunneling. Something MS added to help the transition from IPV4 to IPV6. Once IPV6 is full on and or Native IPV6 can be used one will no longer need the tunneling port 3544. Currently the port number ones console is using gets tunneled to 3544 the minute one turns there console on.. So example of this would look like this 3074 console port to Destination port 3544. UDP. Before IPV6 was a thing there would be no 3544. It would have been 3074 to 3074 or whatever ones console port is to 3074 UDP.. The thing is about this is even if one turns off IPV6 on our end we still get ran through a tunneling protocol. That is something we cant help. What I would like to know is what parts of DumaOS aren't compatible with IPV6?? Is it just the Anti Buffer Bloat? Or is it all of the QoS? Or is it everything?? I may have to do more digging into this because I see the MS server in my Geo Filter pop up as IPV6.. If that's the case then MS is assigning me a IPV6 address through there tunneling protocol.. Which can cause extra latency or odd game play.. So then the question becomes does one enable IPV6 regardless to avoid this..

Zippy.

Share this post


Link to post
Share on other sites
On 10/21/2019 at 10:41 PM, kymadn said:

Can the software code be changed to disable High Priority Detect, if no High Priority packets are sent or received within 60 seconds rather then triggering off High Priority ports?

I just noticed this when I was re-reading the thread. This is pretty much how it already works. There is a window of time that the high priority light will stay on, but it will turn off if it sees nothing high priority for a few minutes. I think it's a few minutes anyway, I should check.

Share this post


Link to post
Share on other sites

Thanks Alex for your reply.. What does one do when the light stays on for those that are having that issue like kymadn? Is there any type of work around?

Separate question also.. Can you or Fraser please tell me if one should prioritize port 3544 UDP? Its a tunneling port. Is that port being prioritized in your guys preconfig settings? Like DumaOS classified games?

Also sense im full of questions today and just want to double check I understand this correctly.. Does one apply DumaOS Classified Games and also add Gaming Console to traffic prioritization? Or do we pick one or the other?  Thanks!

Zippy.

Share this post


Link to post
Share on other sites
39 minutes ago, Zippy said:

Thanks Alex for your reply.. What does one do when the light stays on for those that are having that issue like kymadn? Is there any type of work around?

Separate question also.. Can you or Fraser please tell me if one should prioritize port 3544 UDP? Its a tunneling port. Is that port being prioritized in your guys preconfig settings? Like DumaOS classified games?

Also sense im full of questions today and just want to double check I understand this correctly.. Does one apply DumaOS Classified Games and also add Gaming Console to traffic prioritization? Or do we pick one or the other?  Thanks!

Zippy.

The workaround would be to disable all Traffic Prioritization rules to ensure theres nothing lingering around that's being prioritized. Even a packet a minute could keep this on. If it's stuck essentially then a reboot would resolve it. DumaOS Classified Games will use DPI to prioritize ports so if it is needed then it will prioritize them. The console service itself won't use DPI but will prioritize all the ports the console/games would need - 1024-65535. Pick one or the other, it's a bit redundant to have them both enabled - it certainly wouldn't improve anything but would likely cause the router unnecessary load trying to prioritize twice.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

The workaround would be to disable all Traffic Prioritization rules to ensure theres nothing lingering around that's being prioritized. Even a packet a minute could keep this on. If it's stuck essentially then a reboot would resolve it. DumaOS Classified Games will use DPI to prioritize ports so if it is needed then it will prioritize them. The console service itself won't use DPI but will prioritize all the ports the console/games would need - 1024-65535. Pick one or the other, it's a bit redundant to have them both enabled - it certainly wouldn't improve anything but would likely cause the router unnecessary load trying to prioritize twice.

Thanks Fraser for clarifying that. I had figured it was one or the other and not both..  Since ive been doing all my ports manually can I get your thoughts on port 3544 UDP. Would you recommend to prioritize that port or not? Its a tunneling port and just wanted to get your thoughts on this.. I understand that your busy but when you do find the time id like to get your thoughts on that. If your unsure maybe one of the Devs might know this answer. In the UK do you guys ever come across port 3544? Or some form of tunneling port? 

Thanks again!

Zippy.

Share this post


Link to post
Share on other sites

Can we please stay on topic. The more we speculate or discuss unrelated problems the more this information provided for admins starts becoming confusing.

 

6 hours ago, Netduma Alex said:

I just noticed this when I was re-reading the thread. This is pretty much how it already works. There is a window of time that the high priority light will stay on, but it will turn off if it sees nothing high priority for a few minutes. I think it's a few minutes anyway, I should check.

@Netduma Alex This doesn't appear to be the case as you can see in a few of my posts and screenshots. There is no high priority packets within 30min to 1 hour and High Priority traffic stays on. It only takes 1 or 2 games on PC before it gets stuck for me every time. I have tried both methods of no added ports using DumaOs classifieds games. Also disabling classifieds games and adding manual ports had the same issue.

so if your lead engineer is aware of this problem can you guys explain why this happens so frequently for me?

Share this post


Link to post
Share on other sites
36 minutes ago, Zippy said:

Thanks Fraser for clarifying that. I had figured it was one or the other and not both..  Since ive been doing all my ports manually can I get your thoughts on port 3544 UDP. Would you recommend to prioritize that port or not? Its a tunneling port and just wanted to get your thoughts on this.. I understand that your busy but when you do find the time id like to get your thoughts on that. If your unsure maybe one of the Devs might know this answer. In the UK do you guys ever come across port 3544? Or some form of tunneling port? 

Thanks again!

Zippy.

That's the teredo port which I know Xbox uses so if you're manually prioritizing ports then I would include it as well. Not too much traffic should pass through it so I don't think there will be any issues there but if there is then remove it.

5 minutes ago, kymadn said:

Can we please stay on topic. The more we speculate or discuss unrelated problems the more this information provided for admins starts becoming confusing.

@Netduma Alex This doesn't appear to be the case as you can see in a few of my posts and screenshots. There is no high priority packets within 30min to 1 hour and High Priority traffic stays on. It only takes 1 or 2 games on PC before it gets stuck for me every time. I have tried both methods of no added ports using DumaOs classifieds games. Also disabling classifieds games and adding manual ports had the same issue.

so if your lead engineer is aware of this problem can you guys explain why this happens so frequently for me?

It's sounds like a bug then that we need to investigate, I'll make sure the guys test this but could you try disabling IPv6 and see if it still happens please?

Share this post


Link to post
Share on other sites

@kymadn Sorry about that. I didn't mean to high jack your topic. I was thinking possibly that port 3544 was causing this in your case. When you said you were playing from a PC I thought it was possible that its a MS Windows 10 driven PC and they shared some the same tunneling ports like 3544. Since the Xbox One X is running basically the same Windows 10 or something similar.

One other thing I would do in your case is when your PC is off and you have physically unplugged it from your router I would go into Device Manager and see if its still being showed as online or offline.. That might help them trouble shoot your issue better.. Just a friendly suggestion..

Zippy.

Share this post


Link to post
Share on other sites

@Zippy thanks for the advice. Appreciate your help. I am just interested to hear from @Netduma Alex, @Netduma Fraser and @Netduma Jack about what they find in testing now.

Will wait to here back from admins. I want to know: 

1) what they find in testing causing the issue.

2) how it can be fixed

3) when it will be patched if the problem is software

As requested I will try disable IPV6 and report back. However i would really like to hear from admins about their testing of this issue.

Share this post


Link to post
Share on other sites

@Netduma Alex, @Netduma Fraser

Have you guys been able to replicate my issue? 

Some extra information for you guys, my background applications on my PC include:

NZXT CAM, Logitech G Hub, Asus GPU Tweak, Glass Wire and Malwarebytes. Windows 10 Xbox services and game bar is disabled.  That's pretty much it. 


I tried to find what ports these programs might be using, but haven't found much info. However it probably wouldn't matter. As when my High Priority Traffic was stuck, closing these applications and a PC shutdown did not resolve it. Also IPV6 was disabled.

My PS4 seems to have no issue.

 

 

Share this post


Link to post
Share on other sites

Thanks for the extra information! We'll be testing this using DumaOS 3.0 in house to ensure that if the issue is present we can fix it quickly, it is possible that it is already been fixed just through our reworking of the software. Rest assured this issue won't be present in 3.0.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...