Jump to content
Kahari

Strict and Moderate NAT Type on PC

Recommended Posts

You might need to do some port forwarding. Look up online what ports need to be forwarded for the game you're playing.

Also, let me know what your XR500 is connected to upstream, it might be that we need to put the XR500 into the DMZ of the upstream router.

Share this post


Link to post
Share on other sites

I’m completely new to PC so I would need a step by step tutorial on what to do. How would I find out if is connected to upstream? I did add it to my geofilter. How would I forward the ports? I do know the port numbers.

Share this post


Link to post
Share on other sites

Sorry I should've made that clearer, what I mean by "upstream" is, what is the XR500's yellow WAN port connected to?

To do port forwarding, go to Settings > Advanced Settings > Port Forwarding and then Add Custom Service. Now you need to enter the required ports, you can usually find this on the website of the game you're playing, or by searching "<game title> port forwarding" on Google.

Now select your device from the list, hopefully you'll be able to see it by it's title. If not, you could open Command Prompt on your PC and type "ipconfig", this will show you your IP address.

Share this post


Link to post
Share on other sites

The WAN port is connected to my modem via ethernet. (always has been) I don't have this NAT problem with console. Only with PC.

 

Share this post


Link to post
Share on other sites

If you remove your PC from the Geo-Filter is the NAT then open? Have you also performed the port forwards as suggested by Alex? What game(s) are you playing on PC? PC games usually don't show a NAT status unless it's something like CoD.

Share this post


Link to post
Share on other sites

I’m playing COD on PC. When it was removed from the Geofilter, NAT type was strict. (Which led me to try adding it to the geofilter) It is now moderate. Tried the port forwarding and it’s still moderate.

Share this post


Link to post
Share on other sites

Have you put your console in the router DMZ by any chance? If so then you may be having port conflicts so I would suggest removing that and then just using UPnP and see if you get an open NAT then.

Share this post


Link to post
Share on other sites

Well Fraser appears to be suggesting not to do it, but you can put your PS4 into the DMZ by going to DumaOS > Settings > Setup > WAN Setup. Now tick Default DMZ Server and enter the PS4's IP address. You can find the IP address in device manager if you don't know it, or the connection information on the PS4 itself.

Once you've done that, go to LAN Setup, press ADD at the bottom, choose your PS4 from the list and press ADD again.

Share this post


Link to post
Share on other sites

Hey Alex, this topic is actually for PC. Does the same method apply?

But I don't think I was completely clear as well. I don't believe I've put the PC in DMZ. Only in the Geofilter. My question is,  How would I go about only using uPnP?

Share this post


Link to post
Share on other sites
17 hours ago, Kahari said:

Hey Alex, this topic is actually for PC. Does the same method apply?

But I don't think I was completely clear as well. I don't believe I've put the PC in DMZ. Only in the Geofilter. My question is,  How would I go about only using uPnP?

Yes still applies for PC. UPnP is enabled by default so if you didn't disable this before trying port forwarding then you may be getting conflicts here so if you remove your port forwarding rules that will just allow UPnP to open ports that are needed. Try it that way, then if that doesn't work you could actually try putting it into the DMZ or the suggestion above as well.

Share this post


Link to post
Share on other sites
3 hours ago, Kahari said:

Putting it in the DMZ worked. But how much of a risk is it to my computer using that method?

It's not ideal so I wouldn't suggest keeping it like that. So using UPnP on its own didn't keep the NAT Open?

Share this post


Link to post
Share on other sites

The Geo-Filter can sometimes cause misreadings for the CoD NAT status. This just means that you're actually open but it's showing as moderate most likely because the filter is blocking their NAT server. Easiest way to tell is to boot up the game with the Geo-Filter in Spectating Mode and see if it appears open then. If so then you can just keep it in Filtering Mode and ignore the reading they give you.

Share this post


Link to post
Share on other sites

Tried booting the game up in spectating mode with the DMZ unchecked, and it went back to Moderate. The message it gives is: “The game tried to use UDP port 3074 to open the required port for an open NAT in-game.”

Share this post


Link to post
Share on other sites

DMZ is a good troubleshooting step but is a bad long term solution due to it's security vulnerabilities, especially if you're using a PC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...