Jump to content
Dmaune

To filter or not to filter that is the question

Recommended Posts

8 hours ago, MrLuKeSsT said:

I tried a factory reset and did the above strategy, so far so good. It currently blocking players outside the circle.

Hey, welcome to the forum!

Great to hear that, keep us updated on how you get on!

Share this post


Link to post
Share on other sites

So, what I noticed last night.

I have two Xboxes and match myself in comp. Yes I know I'm scum.

When I matchmake within 10 seconds it is always my other Xbox I match against.

 

If I match instantly then I can match people outside of my circle. If this is the case, I only connect to 3 IP addresses, so I think the fourth is somehow invisible and that's how the others manage to connect.

 

If it takes longer than 20/30 seconds I can match seemingly anywhere.

This makes me think that the matchmaking system is a hybrid of peer to peer as well as somehow using the servers to match you. This would make sense as all of the servers are whitelisted.

After 20/30 seconds try and match players on a server level rather than their own P2P.

 

Anyway, they were my observations from last night.

 

For info, geofilter set to 69 miles in middle of ocean. Ping assist set to zero. Fresh reset and fresh adding of Xboxes before whitelisting anyone in party. Then loading D2.

Share this post


Link to post
Share on other sites

I think you might have something there. As you say, it might make attempts at doing a peer to peer connection and then eventually give up and route you through servers.

Share this post


Link to post
Share on other sites
3 minutes ago, Netduma Alex said:

I think you might have something there. As you say, it might make attempts at doing a peer to peer connection and then eventually give up and route you through servers.

Might explain why it used to work more efficiently before the servers were whitelisted.

 

If I use strict mode, can I then whitelist the servers I want to?

Share this post


Link to post
Share on other sites

Not 100% sure on that one. The problem is that often what we consider a server in gaming terms is actually building full of servers with different addresses so that might involve a lot of whitelisting.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Alex said:

Not 100% sure on that one. The problem is that often what we consider a server in gaming terms is actually building full of servers with different addresses so that might involve a lot of whitelisting.

If you whitelist a whole building, could that mean a player might be whitelisted if they live within a radius of the server building?

Share this post


Link to post
Share on other sites

Ok this week is Iron Banner and I have been playing with settings and I have found something I did not expect.  So I run geo-filter almost always and decided to switch to ping assist and it improved my iron banner game play no more ghost bullets lag etc.  I dont know if this is just an Iron Banner thing but seems strange to me since I have used ping assist before and felt it was more laggy but who knows.  My settings are ping assist 25ms and have been having great matches .

Share this post


Link to post
Share on other sites
15 minutes ago, Bmann said:

Ok this week is Iron Banner and I have been playing with settings and I have found something I did not expect.  So I run geo-filter almost always and decided to switch to ping assist and it improved my iron banner game play no more ghost bullets lag etc.  I dont know if this is just an Iron Banner thing but seems strange to me since I have used ping assist before and felt it was more laggy but who knows.  My settings are ping assist 25ms and have been having great matches .

It's Iron Banner? Time to boot up Destiny again!

Share this post


Link to post
Share on other sites
3 hours ago, Bmann said:

Ok this week is Iron Banner and I have been playing with settings and I have found something I did not expect.  So I run geo-filter almost always and decided to switch to ping assist and it improved my iron banner game play no more ghost bullets lag etc.  I dont know if this is just an Iron Banner thing but seems strange to me since I have used ping assist before and felt it was more laggy but who knows.  My settings are ping assist 25ms and have been having great matches .

Have you been paying attention to the ping assist while connecting to people?  What happens when you set your assist to 1?  

Share this post


Link to post
Share on other sites

Dmaune I have not paid attention grinding out Iron banana lol.  for whatever reason ping assist is working pretty good right now but I have not looked into anything as to the reason why.  I will run some tests when I am done tonight.

Share this post


Link to post
Share on other sites
2 hours ago, Bmann said:

Dmaune I have not paid attention grinding out Iron banana lol.  for whatever reason ping assist is working pretty good right now but I have not looked into anything as to the reason why.  I will run some tests when I am done tonight.

Ping assist wasn't doing anything for me so I started using geofilter instead.  That worked after I deleted my console and then added it again.  That being said anytime I'm playing destiny using the geofilter the XR500 drops my internet connection after about 5 minutes.  Man I just can't win with this thing.  

Share this post


Link to post
Share on other sites
23 minutes ago, Bmann said:

1ms felt laggy but the map is correct 

I'm guessing maybe 25ms feeling good may have just been placebo?  I mean you really shouldn't have found a match at all at 1ms.  

I've moved on from ping assist for the time being.  Just doesn't work like it used to.  Now i just have to figure out why i lose internet connection when im using geofilter.  

Share this post


Link to post
Share on other sites

Can anyone help me with my internet disconnect problem?  With the update release today i'd like to get some play time in but can't really do so if the geofilter knocks my connection out every time.  

Share this post


Link to post
Share on other sites

Ok so apart from the Ping assist not working like, at all

1 hour ago, Dmaune said:

Can anyone help me with my internet disconnect problem?  With the update release today i'd like to get some play time in but can't really do so if the geofilter knocks my connection out every time.  

Just wanted to give a description of what's happening now.  

Since ping assist literally filters nothing for me I decided to go with using the geofilter instead.  Initially geofilter wasn't working either so I turned off the console, deleted the console from the XR500 both in qos and geofilter, set ping assist to 0, set my geofilter location over my location, rebooted the XR500, started my ps4 and added it back in then started the game.  

Geofilter was now working just fine.  Only allowing connections from within my radius so I thought, OK I'll just use geofilter until they get the ping assist issue squared away.  Well now I have a problem with losing internet connection or at least a problem with it slowing down to an absolute crawl.  

When I first start Destiny I'll search for a match and while the geofilter is doing it's thing I run a speed test on my PC.  For the first 5 minutes or so I have no issues, but then all of a sudden I lose my internet connection on all devices connected to the XR500.  Well I guess I don't lose it, it just slows down so much that I can't even run a speed test on the PC.  It simply tells me I don't have a connection.  I try opening a webpage on my phone, same result.  Meanwhile I'm still in Destiny playing but it's so laggy it's unplayable.  

So I turn off my console and reboot the router.  As long as I'm not playing Destiny, I have absolutely no issues with my internet dropping out over wifi or ethernet.  I can post the log when this happens when i jump on today if necessary.  

 

P.S. I still would love you guys to figure out the ping assist issue.  Mine isn't the only post I've seen that's experiencing a problem with it. 

Share this post


Link to post
Share on other sites

It's really strange, why would playing destiny cause this problem? What is destiny doing that's different from other web applications.

These are questions i'll ask the devs.

Share this post


Link to post
Share on other sites
On 7/20/2019 at 7:19 PM, Dmaune said:

I appreciate your help i really do but if i have the ping assist set at 1 how is setting it higher going to help? It's obvious it filters nothing

Man if I knew I'd tell you.  Would a pic of my logs help?  

P.S. been running some speed tests just a second ago toggling the QOS on and off.  Keep in mind my PS4 is off so there is no high priority traffic but still the XR500 is throttling my speeds.  What's weird is it's not throttling it to where I have my bufferbloat set.  I even have it in "never" same result.  Strange things. 

I'm consistently 40 down, 18up with qos disabled and with it enabled I'm 31 down and 12 up.  Nothing else in the house is connected atm. 

Share this post


Link to post
Share on other sites

Your last sentence explains your issue. Your speeds aren't the fastest and you're running a speed test while playing with QoS off. You are saturating your connection and causing network queues which is why the game becomes laggy and sites are slower. When you have QoS enabled and select Always then it will continue to throttle the connection until you say otherwise.

Share this post


Link to post
Share on other sites
10 minutes ago, Netduma Fraser said:

Your last sentence explains your issue. Your speeds aren't the fastest and you're running a speed test while playing with QoS off. You are saturating your connection and causing network queues which is why the game becomes laggy and sites are slower. When you have QoS enabled and select Always then it will continue to throttle the connection until you say otherwise.

Incorrect.  I did all these speed tests with the PS4 off.  Not only was it off but I had deleted the console from the XR500.  I was simply toggling qos on and off running a speed test each time.  My PC was the only thing connected to the network.  

Share this post


Link to post
Share on other sites

You mentioned you were playing a game and running a speed test at the time, so what QoS settings were you using at that time? Also what do you mean by toggling on/off precisely?

Share this post


Link to post
Share on other sites
16 hours ago, Dmaune said:

I'm guessing maybe 25ms feeling good may have just been placebo?  I mean you really shouldn't have found a match at all at 1ms.  

I've moved on from ping assist for the time being.  Just doesn't work like it used to.  Now i just have to figure out why i lose internet connection when im using geofilter.  

Right now I am having good luck with 25ms ping for Destiny but now that Iron Banner is over I am going to continue with these setting and see how it goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...