Jump to content
RehivaE

Can't download and update games ps4 xr500

Recommended Posts

14 minutes ago, Netduma Fraser said:

Have you got port forwarding/UPnP enabled on the HS8? Does it interact with the connection at all or just passes through to the XR500? Are you using port forwarding/DMZ on the XR500 over UPnP for the PS4?

Upnp and port forwarding are disabled on the hs8, on the xr500 I'm using only upnp. I don't understand what do you mean by interact with the connection.

Share this post


Link to post
Share on other sites
33 minutes ago, RehivaE said:

Upnp and port forwarding are disabled on the hs8, on the xr500 I'm using only upnp. I don't understand what do you mean by interact with the connection.

As in do you have any other devices connected to it, wireless devices etc. 

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Fraser said:

As in do you have any other devices connected to it, wireless devices etc. 

every devices is connected to the xr500: phones, laptops, tablets.

Share this post


Link to post
Share on other sites

It doesn't make sense that PS4 reports open and the Xbox is getting double NAT. It's using all automatic settings to connect correct? Just to test if you put the Xbox in the XR500 DMZ what does it show then?

Share this post


Link to post
Share on other sites
58 minutes ago, Netduma Fraser said:

It doesn't make sense that PS4 reports open and the Xbox is getting double NAT. It's using all automatic settings to connect correct? Just to test if you put the Xbox in the XR500 DMZ what does it show then?

Just tried it but nothing still on double nat, can be the ethernet cat5 fault? Back when I was on 5ghz I had open nat on the xbox.

Share this post


Link to post
Share on other sites

I don't see how it's possible that you could still be getting double NAT. Maybe you're under carrier grade NAT or something.

Share this post


Link to post
Share on other sites
35 minutes ago, Netduma Alex said:

I don't see how it's possible that you could still be getting double NAT. Maybe you're under carrier grade NAT or something.

What is better, play 5ghz and open nat or play with lan and nat moderate? I think this are the only options.

Share this post


Link to post
Share on other sites

That doesn't really make much sense at all unless you're using static information for one and not the other connection method. Do you know if this is the case? If you reconnect them as new connection methods do they then report open NAT or still differ? I feel like if that is not the case then it must be a misreading some how. Is it open on 2.4GHz as that would be better than 5GHz.

Share this post


Link to post
Share on other sites
On 8/14/2019 at 7:24 PM, Netduma Fraser said:

That doesn't really make much sense at all unless you're using static information for one and not the other connection method. Do you know if this is the case? If you reconnect them as new connection methods do they then report open NAT or still differ? I feel like if that is not the case then it must be a misreading some how. Is it open on 2.4GHz as that would be better than 5GHz.

Playing lan and still can't have an open nat, is not just bo4, I tried with ww2, bo3, iw, all of them shows me moderate nat. I tried disabling upnp and using port forward for the ps4 with the cod ports but I still not able to have an open nat. Also, if I go to the upnp page of the xr500 every port needed to get an open nat for bo4 is opened, especially the 3074 udp, the game says is not open but the upnp page says yes. I also tested on pc black ops 3 and also have moderate nat.

Share this post


Link to post
Share on other sites

Is that all tested with the Geo-Filter disabled as that could cause a misreading? It sounds like if UPnP has opened the ports that the game has requested those ports to be opened and so must be an issue with them reporting the correct NAT status.

Share this post


Link to post
Share on other sites
13 hours ago, Netduma Fraser said:

Is that all tested with the Geo-Filter disabled as that could cause a misreading? It sounds like if UPnP has opened the ports that the game has requested those ports to be opened and so must be an issue with them reporting the correct NAT status.

geo filter is always disabled.

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Alex said:

Is your upstream router/modem definitely opening all ports for the XR500?

How can I know that?

Share this post


Link to post
Share on other sites

Good question... Just make sure that the XR500 is in the DMZ of the upstream router/modem. This is safe to do as the XR500 has it's own firewall.

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Alex said:

Good question... Just make sure that the XR500 is in the DMZ of the upstream router/modem. This is safe to do as the XR500 has it's own firewall.

It's already in the dmz.

Share this post


Link to post
Share on other sites

I'm almost certain this is a misreading as it doesn't make sense otherwise. Do you have any friends online who could make their NAT strict for a test? If you could successfully connect to them with 'moderate' NAT then you're definitely open.

Share this post


Link to post
Share on other sites

The reason your bridge mode didn't work is because you bridged one extra port (previous page) and if it's done like that you need two IP addresses. The first connection you saw is programmed in by your provider. The bridge mode is extra. So if you disabled the first connection it could have worked, because otherwise that snags the IP address meant for the XR500.  Multicast VLAN should have just been set to 10, which seems default for your conection judging by the name of the first connection. Actually if you look at the page for your present WAN connection, just changing the setting from Routing to Bridge and set binding to LAN1 would already have done the trick. Your present setting binds to SS

 

I have a huawai router from my ISP that is programmed like that and it only works for stuff where you have 2 separate WAN's or have acces to multiple public IP's.

 

The reason you had issues with downloading games on your PS4 is in the DNS setting at XR500. You have added a local IP as DNS server, the one of your Huawai Router. If this goes out of whack it will prevent downloading and doing stuff like uploading video's etc. I would set that to automatic from ISP so it just uses your ISP's DNS, or something like google (8.8.8.8) or cloudflare so you know it won't be an issue.

 

Important to note is that setting something in DMZ just opens all the ports to that device, it will never get rid of double NAT.

If you use Huawai Router - XR500(DMZ) - XBOX for example. Huawai forward all ports to the XR500. But you will still need to set up either port forwarding on the XR500, or set the xbox in XR500 DMZ. Ideally it should all work on uPNP but I found that not always to work right on the XR500. For CoD in PS4 I just forward UDP 3074 and that gives you open NAT regardless of Geofilter settings. But I don't know how that is if you use a XBOX and PS4 at the same time. Ideally you need uPNP for this. You can't forward ports to say PS4 and use XBOX in DMZ, in that case 3074 will be used by PS4 and the XBOX will still have NAT issues.

 

You could try something else:

Plug your WAN ethernet cable straight into the XR500.

Enter the static IP data like you had in your Huawai router

Under advanced setttings, go to VLAN / Bridge and enable VLAN / Bridge settings. Take the bottom setting and add VLAN 10.

This should make your XR500 the main router and simplfy things.

Share this post


Link to post
Share on other sites
16 hours ago, Bert said:

The reason your bridge mode didn't work is because you bridged one extra port (previous page) and if it's done like that you need two IP addresses. The first connection you saw is programmed in by your provider. The bridge mode is extra. So if you disabled the first connection it could have worked, because otherwise that snags the IP address meant for the XR500.  Multicast VLAN should have just been set to 10, which seems default for your conection judging by the name of the first connection. Actually if you look at the page for your present WAN connection, just changing the setting from Routing to Bridge and set binding to LAN1 would already have done the trick. Your present setting binds to SS

 

I have a huawai router from my ISP that is programmed like that and it only works for stuff where you have 2 separate WAN's or have acces to multiple public IP's.

 

The reason you had issues with downloading games on your PS4 is in the DNS setting at XR500. You have added a local IP as DNS server, the one of your Huawai Router. If this goes out of whack it will prevent downloading and doing stuff like uploading video's etc. I would set that to automatic from ISP so it just uses your ISP's DNS, or something like google (8.8.8.8) or cloudflare so you know it won't be an issue.

 

Important to note is that setting something in DMZ just opens all the ports to that device, it will never get rid of double NAT.

If you use Huawai Router - XR500(DMZ) - XBOX for example. Huawai forward all ports to the XR500. But you will still need to set up either port forwarding on the XR500, or set the xbox in XR500 DMZ. Ideally it should all work on uPNP but I found that not always to work right on the XR500. For CoD in PS4 I just forward UDP 3074 and that gives you open NAT regardless of Geofilter settings. But I don't know how that is if you use a XBOX and PS4 at the same time. Ideally you need uPNP for this. You can't forward ports to say PS4 and use XBOX in DMZ, in that case 3074 will be used by PS4 and the XBOX will still have NAT issues.

 

You could try something else:

Plug your WAN ethernet cable straight into the XR500.

Enter the static IP data like you had in your Huawai router

Under advanced setttings, go to VLAN / Bridge and enable VLAN / Bridge settings. Take the bottom setting and add VLAN 10.

This should make your XR500 the main router and simplfy things.

I tried just switching to bridge like you said but I still have no internet access. I deleted the isp connection and only added the bridge connection and still having no internet access.

I can't plug my wan ethernet cable directly to the xr500 because my connection use a fiber optic cable cs, the xr500 doesn't have that type of port.

Share this post


Link to post
Share on other sites

Did you give it VLAN 10?

 

The line in the top should read something like: 1_INTERNET_B_VID_10

Share this post


Link to post
Share on other sites
7 hours ago, Bert said:

Did you give it VLAN 10?

 

The line in the top should read something like: 1_INTERNET_B_VID_10

yes, but still having no internet

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Fraser said:

If you're still having issues with that I'd just go back to the DMZ. Did you get a chance to test with friends using my suggestion?

no, all my friends have open nat 😂😂

 

Share this post


Link to post
Share on other sites
33 minutes ago, RehivaE said:

no, all my friends have open nat 😂😂

 

They could make their connections strict by not using modem mode/DMZ and turning off UPnP on the router for example

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...