Jump to content
Sneakybeaky

Apple devices lose internet connection

Recommended Posts

As previously reported, all apple devices in the house are losing internet connection whilst still being connected to the xr500.  My PC remained connected and uneffected by this bug.

So far this has only happened in the late evening since it was installed. Basically you can be connected and all of sudden you cant browse or watch youtube. If you turn the wireless off/on on the device the internet comes back but then it will go off again. 

This well below expectation for what I expect of a new router so Im hoping someone can assist me here.

Thanks

( Primary DNS server appeared to be the source of a reported ddos attack last night just before this issue occured )

Share this post


Link to post
Share on other sites

I’ve all Apple setup and one issue that pops up is if I change channels sometimes my iPad Pro does not auto join for some reason. I’m using the latest iOS. 

Are you on Auto channel selection?

I'm on one name, smart connect and the router is set for channel 6 on the 2.4 and channel 100dfs on 5ghz. Only happens occasionally on the iPad Pro, all my other Apple devices seem fine if I change channel. 

The other thing I have noticed is I’ve tried a guest network and that for some reason seems to be very iffy with Apple gear where like you my internet just stops out of the blue. It’s connected but just stops working. 

Share this post


Link to post
Share on other sites

All Apple devices here and no issues at all oddly. I have smart connect off, its apain and isnt that smart tbh. Also I have all device set up with DHCP reservation. iPad Pro 12.9 1TB connects flawlessly, as does my iPhone Xs and 27" iMac. In fact I've never had any issues with Apple gear connecting since this router came out, but I have always used the settings above. Maybe try DHCP reservation and don't use smart connect, stick modern Apple devices on 5Ghz maybe since they work well on 802ac and see how it goes. :) 

Share this post


Link to post
Share on other sites
4 hours ago, Sneakybeaky said:

As previously reported, all apple devices in the house are losing internet connection whilst still being connected to the xr500.  My PC remained connected and uneffected by this bug.

So far this has only happened in the late evening since it was installed. Basically you can be connected and all of sudden you cant browse or watch youtube. If you turn the wireless off/on on the device the internet comes back but then it will go off again. 

Does this happen across both bands (2.4GHz and 5GHz)? Also is this happening on wired devices?

Could simply be WiFi range if it's on 5GHz, though it could be a DHCP thing. I'd recommend checking out DHCP reservation as Killhippie suggested above, let us know if that works out :)

Share this post


Link to post
Share on other sites

I believe it happens on both and most Apple devices are currently on 5ghz. Definitely not a range issue as it happens one room away and majority of the day everything is connected. Like I mentioned before it is happening late evening.

We did experience a range issue for the garden but a quick adjustment of the router position and everything worked as should. 

Smart connect is already off as I don’t like that feature.

i find it strange that it would bring up a issue in the log about the dns server and it being a source of a ddos attack. Would it not be reasonable to suggest that this could be the issue ?

Share this post


Link to post
Share on other sites

DDOS is mentioned in the logs a lot and is actually a symptom of bad wording that something which is definitely a problem...

That said, if you want to rule out the DNS problem you could set manual DNS servers in Settings > Internet Setup.

For example, try 8.8.8.8 and 8.8.4.4 (Google's public DNS servers)

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Alex said:

DDOS is mentioned in the logs a lot and is actually a symptom of bad wording that something which is definitely a problem...

That said, if you want to rule out the DNS problem you could set manual DNS servers in Settings > Internet Setup.

For example, try 8.8.8.8 and 8.8.4.4 (Google's public DNS servers)

Hi,

 

yeah I am already over that after I saw a post else where whilst searching this issue.  So far the router has made it 1 day but, the next day or so will truly tell me if this is resolved. I have also setup static ips for all devices so fingers crossed.

Share this post


Link to post
Share on other sites
18 hours ago, Netduma Alex said:

DDOS is mentioned in the logs a lot and is actually a symptom of bad wording that something which is definitely a problem...

That said, if you want to rule out the DNS problem you could set manual DNS servers in Settings > Internet Setup.

For example, try 8.8.8.8 and 8.8.4.4 (Google's public DNS servers)

The dns change has not fixed the issue ,which has again repeated itself in the late evening once more. It seems to be around the same time every time.

 

Here is the log from around the time this issue seems to occur

log.txt

Share this post


Link to post
Share on other sites

Hmm... Could you go to Settings > Monitoring > Connection Status and press to renew the lease

Do this at a time you'd be happy for the lease to be changed, like... late at night or when you're at work... this might be tricky

But I think that will change the time that the disconnection happens to something more convenient

This is a bit of a shot in the dark but it worked before for somebody on the NETGEAR forums so let's give it a go

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Alex said:

Hmm... Could you go to Settings > Monitoring > Connection Status and press to renew the lease

Do this at a time you'd be happy for the lease to be changed, like... late at night or when you're at work... this might be tricky

But I think that will change the time that the disconnection happens to something more convenient

This is a bit of a shot in the dark but it worked before for somebody on the NETGEAR forums so let's give it a go

SImply moving the problem to a different time isn't actually fixing the issue though Alex. What you are proposing is that I still up late to simply hit a renew lease button in order to avoid this issue, because otherwise im stuck with this issue but at a different time.

There is obviously an issue be it firmware or hardware  and given that this is a brand new router Ive bought, I would ideally like to have the problem fixed.Having seen in forums that this has been a long term issue, is there going to be a fix ?

Share this post


Link to post
Share on other sites
19 minutes ago, Sneakybeaky said:

SImply moving the problem to a different time isn't actually fixing the issue though Alex. What you are proposing is that I still up late to simply hit a renew lease button in order to avoid this issue, because otherwise im stuck with this issue but at a different time.

There is obviously an issue be it firmware or hardware  and given that this is a brand new router Ive bought, I would ideally like to have the problem fixed.Having seen in forums that this has been a long term issue, is there going to be a fix ?

I dont think this is a known issue. Ive not seen masses of people mentioning it tbh, and as I said and I know it does not help but none of my device have any issue with the the XR500. I know that's not any good for you to hear, but a thought did occur, to me. When you set up your new router did you keep the same SSID and password as the old one? So you could just turn on and start up without adding network names passwords into the Apple devices? If you did do this did you "forget" the previous router in settings? Otherwise that can cause Apple devices to bet bogged down sometimes due to MAC Address Randomization glitches. If you have not got the old router any more reset network settings and type the SSID and password back in manually on your devices,. If you still have the old router try turning off the XR500 let the devices connect to the old router and then use "forget network"  while attached to the old network before booting up to the XR500 then reconnect. I Hope it helps, otherwise I would look at possibly faulty hardware, but first as boring as it sounds have you done a factory reset after updating the firmware on the XR500 after forgetting the old network of your old router?

Share this post


Link to post
Share on other sites

Well, people have been reporting this issue, albeit perhaps not specific to apple devices since last August. So this has been an issue for quite some time now.

I really hoped that static ips and the google dns would have been enough to fix this issue but as seen in my log, it is not.  Nope, Im using the SSID that of the xr500 with 2ghz and 5ghz having their own name. 

My old router is a modem/router combo provided by Virgin Media, so the option of plugging that back in would mean removing the xr500 and taking the superhub out of modem mode by using the hard reset button and setting everything back up.

Since this issue I have factory reset the router 3 times and updated the firmware twice( latest and hotfix) 

Share this post


Link to post
Share on other sites

So this isn't an Apple device specific problem? I've heard of people having problems with Apple devices specifically on the 5GHz network. This is a problem we're aware of and we're working on. However this issue with lease timing is a little strange. I find it weird that only certain devices would be affected.

Share this post


Link to post
Share on other sites
3 minutes ago, Netduma Alex said:

So this isn't an Apple device specific problem? I've heard of people having problems with Apple devices specifically on the 5GHz network. This is a problem we're aware of and we're working on. However this issue with lease timing is a little strange. I find it weird that only certain devices would be affected.

The devices in the house consist of; Windows PC(Unaffected), Imac(affected), Macbook Air(affected), Iphone 6+,7,8(affected),LGTV smart (unsure if affected)

Both 2.4 and 5 are affected by this issue.

Share this post


Link to post
Share on other sites

Under Settings > Setup > WAN Setup, can you make sure that IGMP Proxying is disabled?

Another idea: Could you create a Guest Network using Settings > Setup > Guest Network... See if the issues still occur when connected to this network.

 

Share this post


Link to post
Share on other sites
1 hour ago, Netduma Alex said:

Under Settings > Setup > WAN Setup, can you make sure that IGMP Proxying is disabled?

Another idea: Could you create a Guest Network using Settings > Setup > Guest Network... See if the issues still occur when connected to this network.

 

Ok, I will try these and see how we get on. I will try the downgrade on the firmware to V2.3.2.22 as mentioned on the other forum

Share this post


Link to post
Share on other sites
5 hours ago, Netduma Alex said:

So this isn't an Apple device specific problem? I've heard of people having problems with Apple devices specifically on the 5GHz network. This is a problem we're aware of and we're working on. However this issue with lease timing is a little strange. I find it weird that only certain devices would be affected.

Once again all my apple device are connected to 5Ghz and not had an issue at all since launch. All my Apple devices are connected to 5Ghz to take advantage of 802.11ac, and not one Wi-Fi issue has ever occurred and that's on iOS 11 and 12. (The R7800 which is basically the same router as the XR500 but with less flash memory) had issues at launch with Apple only devices but that was cleared up in 2016 when a few of us noticed devices would not reconnect out of the box on initial firmware it took a few updates to fix that issue, never saw it come back on the R7800 and that was in 2016 and its exactly the same SoC in the XR500 just with128mb more flash that is unused.

5 hours ago, Sneakybeaky said:

Well, people have been reporting this issue, albeit perhaps not specific to apple devices since last August. So this has been an issue for quite some time now.

I really hoped that static ips and the google dns would have been enough to fix this issue but as seen in my log, it is not.  Nope, Im using the SSID that of the xr500 with 2ghz and 5ghz having their own name. 

My old router is a modem/router combo provided by Virgin Media, so the option of plugging that back in would mean removing the xr500 and taking the superhub out of modem mode by using the hard reset button and setting everything back up.

Since this issue I have factory reset the router 3 times and updated the firmware twice( latest and hotfix) 

Have you tried giving DHCP reservation for each of your devices? Just thinking of what works in my set up that may help, not had any issues like yours at all. Also its odd it happens late evening, that sounds like interference. Most devices when smart connect is enabled will grab 2.4Ghz which has greater distance but less bandwidth and more interference, hence why I separate mine so devices that I know are bandwidth hungry get to use 5Hhz (802.11ac) if compatible which recent apple products like yours, devices that just need a connection but use very little bandwidth get connected to 2.4Ghz. Its a shame you don't have an android phone, or cant borrow one, Wi-Fi analyser is a free app that alas is not available on the Apple App store and would maybe show you what's going on when you see a drop out and also who is using what frequency in great detail, its fantastic app.

 I would split both bands, and try connecting the devices that drop out to 5Ghz and see how they fair, as I said that's how mine are set up so just a suggestion, the only thing connected to 2.4Ghz is a soundbar and a printer, the soundbar just has lousy Wi-Fi on both bands and is better on 2.4Ghz and the printer can only use 2.4Ghz. I've had no issues at all though with that set up, you may have to experiment and tune your network to your environment as 2.4Ghz may be better for your needs depending on your routers positioning and the thickness of your walls. I live in a 1950's bungalow though and 5Ghz covers the while building. I hope either Alex's or my ideas help, also make sure not to have the router connected to a power strip with loads of devices (a UPS is fine) as if something turns on and consumes a lot of power in the evening maybe that is drawing power from the strip and anything plugged into it like a router, or you have a device in your home or surrounding area that's kicking out a lot of RFI at whatever frequency your devices connect at. Did you ever contact Netgear about this as that's who would deal with hardware issues generally. It could be down to bad luck and its a faulty router, a RMA would have let you know for sure and your are still in warranty I imagine.

Share this post


Link to post
Share on other sites
4 minutes ago, Killhippie said:

Have you tried giving DHCP reservation for each of your devices? Just thinking of what works in my set up that may help, not had any issues like yours at all. Also its odd it happens late evening, that sounds like interference. Most devices when smart connect is enabled will grab 2.4Ghz which has greater distance but less bandwidth and more interference, hence why I separate mine so devices that I know are bandwidth hungry get to use 5Hhz (802.11ac) if compatible which recent apple products like yours, devices that just need a connection but use very little bandwidth get connected to 2.4Ghz. Its a shame you don't have an android phone, or cant borrow one, Wi-Fi analyser is a free app that alas is not available on the Apple App store and would maybe show you what's going on when you see a drop out and also who is using what frequency in great detail, its fantastic app.

 I would split both bands, and try connecting the devices that drop out to 5Ghz and see how they fair, as I said that's how mine are set up so just a suggestion, the only thing connected to 2.4Ghz is a soundbar and a printer, the soundbar just has lousy Wi-Fi on both bands and is better on 2.4Ghz and the printer can only use 2.4Ghz. I've had no issues at all though with that set up, you may have to experiment and tune your network to your environment as 2.4Ghz may be better for your needs depending on your routers positioning and the thickness of your walls. I live in a 1950's bungalow though and 5Ghz covers the while building. I hope either Alex's or my ideas help, also make sure not to have the router connected to a power strip with loads of devices (a UPS is fine) as if something turns on and consumes a lot of power in the evening maybe that is drawing power from the strip and anything plugged into it like a router, or you have a device in your home or surrounding area that's kicking out a lot of RFI at whatever frequency your devices connect at. Did you ever contact Netgear about this as that's who would deal with hardware issues generally. It could be down to bad luck and its a faulty router, a RMA would have let you know for sure and your are still in warranty I imagine.

Yeah mate, I have tried all of the suggestions I have found on these netgear forums. Unfortunately it still happened with static ips but, its only Apple devices that are affected by the DHCP lease changes in the evening. There just must be a conflict within this firmware and Apple, thats the answer I have because otherwise, why does my PC not suffer the same fate?

WIFI was split from the get go. Id rather we have the option to dictate what band we are on.

I bought this router new from an ebay user. It was still all wrapped up but the user had it in storage so no longer has a receipt.  

Share this post


Link to post
Share on other sites

With regards to reserving IP addresses, if your DHCP range is .100 - .250 for example try setting one of the affected devices to under .100 and see if setting it outside the range helps, we've seen instances where this has worked before. Meanwhile I will let the team know to pass this on to Netgear for them to test also.

Share this post


Link to post
Share on other sites

So far so good. We are into day number 3 and no one is reporting any disconnects.  Something I've noticed which is separate from all this is Traffic prioritization does not appear to work if my PC is listed as computer but, soon as I select Xbox or PS4 the red light appears but, it stays on until I change the type of device it is. This didnt happen before I think. Will it have something to do with me going back to an early firmware version? Or am I making this all up and it only works for console?

 

 

Share this post


Link to post
Share on other sites

Great to hear that, keep us updated. It depends on what PC game you're playing, what game is it? We may need to update it if it's not working when it should.

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

Great to hear that, keep us updated. It depends on what PC game you're playing, what game is it? We may need to update it if it's not working when it should.

We all are! Thanks to all who have taken the time to assist me where they could. Mucho appreciado 

Fifa 19 mate.

Share this post


Link to post
Share on other sites
20 hours ago, Netduma Fraser said:

I've asked the team to test the game on PC if possible but as you know use it as a console and should work correctly :)

Quick update on that traffic prioritization. I found that if I add my device, in this case my PC under Traffic Prioritization and select games console it will enable when  I play fifa so, I dont actually need to change my PC to Xbox/PS4 under device management. 

I thought with manually inputting FIFA19's ports that it would effectively see this as Traffic it needed to prioritise but apparently not.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...