Jump to content
MatthiasN

xr500 QoS w/ Samsung Smart TV

Recommended Posts

Hello, 

I have just purchased a new Netgear Nighthawk XR500 with the hopes of using QoS features and bandwidth limiting.

Frustratingly though, ever since I set up the router, I've had to disable QoS in order to get the Samsung Q8F's smart tv functions (such as the TVPlus app or the 3rd party Twitch.tv app available on Samsung's platform) to be able to work. Weirdly enough the Netflix app worked with QoS still on, it's just other apps that do streaming on this TV that struggle.

I've played around in the settings in both the TV and the router, but nothing has worked. Is it true this is an issue with the software and that the QoS is buggy with these devices? Every thread I've found so far here or on the Netgear forum is a dead end. Is there any fix in the works? I'd hate to have to return this already.

Share this post


Link to post
Share on other sites

QoS shouldn’t have any affect on this, so did you toggle anything else? 

This sounds like a NAT problem, so could you go to >Settings >Advanced >UPNP and make sure UPNP is enabled 

Could you then either put your modem into modem mode or bridge mode. If that’s not possible, then you want to put the XR500 into your modem’s DMZ. Guide here: http://support.netduma.com/support/solutions/articles/16000076587-dumaos-optimal-settings-guide-open-nat

Share this post


Link to post
Share on other sites

No I did not toggle anything else.

UPnP is on

My modem is my own bought Netgear CM1000. There is no bridge mode. It's just a modem not a modem/router. 

I also attempted putting the TVs IP into the router's DMZ and it did not work. 

The only setting I toggle that changes these apps working is QoS on/off.

Share this post


Link to post
Share on other sites
13 hours ago, MatthiasN said:

No I did not toggle anything else.

UPnP is on

My modem is my own bought Netgear CM1000. There is no bridge mode. It's just a modem not a modem/router. 

I also attempted putting the TVs IP into the router's DMZ and it did not work. 

The only setting I toggle that changes these apps working is QoS on/off.

 MatthiasN, when you toggle your QoS and leave it off does your apps work fine there after or do you need to keep toggling the QoS every so often? Thanks!

Zippy.

Share this post


Link to post
Share on other sites
18 hours ago, MatthiasN said:

No I did not toggle anything else.

UPnP is on

My modem is my own bought Netgear CM1000. There is no bridge mode. It's just a modem not a modem/router. 

I also attempted putting the TVs IP into the router's DMZ and it did not work. 

The only setting I toggle that changes these apps working is QoS on/off.

Thanks for the update. Let me run this by a developer to see what could be happening.

In the meantime, could you enable QoS but uncheck 'DumaOS Classified Games' in Traffic Prioritisation. Does that make any difference?

Share this post


Link to post
Share on other sites
18 hours ago, MatthiasN said:

No I did not toggle anything else.

UPnP is on

My modem is my own bought Netgear CM1000. There is no bridge mode. It's just a modem not a modem/router. 

I also attempted putting the TVs IP into the router's DMZ and it did not work. 

The only setting I toggle that changes these apps working is QoS on/off.

Just to add on top of Admins question - try enabling QoS, set Anti-Bufferbloat to 'never', reset distribution and enable Share Excess. Does the issue persist?

Share this post


Link to post
Share on other sites

Hey so I had this same problem with a sony 4k and sony blu ray player . I dont know if it apply s to you or not but I was running them through a switch (s8000 ) and when QoS was on I would have all kinds of problems network error messages streaming apps just buffering nonstop  but would work perfectly fine with QoS off.  I spent many many hours with netduma trying to figure it out but it was the switch's problem. 

Share this post


Link to post
Share on other sites

Hello Danny

I am running through wifi so I'm not sure if any switch is the issuem. Connection is Coax > Modem > Router > 2.4GHz WiFi > Samsung Q8F TV 

--

Thanks for the other trouble shooting steps. 

I will try them and report back shortly.

Share this post


Link to post
Share on other sites
20 hours ago, Zippy said:

 MatthiasN, when you toggle your QoS and leave it off does your apps work fine there after or do you need to keep toggling the QoS every so often? Thanks!

Zippy.

Completed this test.

Left QoS off and had no app issues at all. Watched for a few hours.

Didn't need to toggle it to continue watching or load new streams etc.

As soon as I I turned QoS back on, current stream continued as long as I watched.. But if I stopped watching, then tried to watch a new stream again it wouldn't connect anymore. 

Going to try the other steps mentioned.

Share this post


Link to post
Share on other sites

Completed these both:

15 hours ago, Netduma Jack said:

Just to add on top of Admins question - try enabling QoS, set Anti-Bufferbloat to 'never', reset distribution and enable Share Excess. Does the issue persist?

 

15 hours ago, Netduma Admin said:

Thanks for the update. Let me run this by a developer to see what could be happening.

In the meantime, could you enable QoS but uncheck 'DumaOS Classified Games' in Traffic Prioritisation. Does that make any difference?

Completed both of these together.

Streams still cannot establish any connection. 

Share this post


Link to post
Share on other sites

FYI here is with QoS off, watching streams on TV Plus, showing my network traffic. 

I have a 400MB down 25 upload connection. Not even close to maxing it out but we're barely using the network right now. The only other active device is our PCs

Screenshot_20190401-212501_Chrome.jpg

Screenshot_20190401-212540_Chrome.jpg

Share this post


Link to post
Share on other sites
2 hours ago, MatthiasN said:

Completed this test.

Left QoS off and had no app issues at all. Watched for a few hours.

Didn't need to toggle it to continue watching or load new streams etc.

As soon as I I turned QoS back on, current stream continued as long as I watched.. But if I stopped watching, then tried to watch a new stream again it wouldn't connect anymore. 

Going to try the other steps mentioned.

Do this once... When you toggle your QoS on see if there is a DHCP lease change or Renew in your routers Log file..  See if in your routers log if there is a DHCP change of some sort.. Something is telling me it might not be QoS related but more of something else behind the scenes taking place that is losing track of devices and thus QoS stops functioning..  Watch the timeframe you do this and see if you see a lease change or something of that nature..  curious about this.. Good luck!

Zippy..

Share this post


Link to post
Share on other sites

I'm going to pass this on to our developers - this should be something we can resolve. Thank you for providing so much information about your issue :)

Share this post


Link to post
Share on other sites

One thing Netduma had me try was making a custom rule under QoS that had port 1 - 9999 Open for QoS and uncheck the box that says something about Netduma games sorry I am on my phone and I don’t remember what it’s called 100% 

another weird thing to try did you by chance change the led settings from default ? I have had really strange things that have happened when I change from default and do no or just solid colors . 

Last thing would be to do a factory reset a couple times in row and not change any settings or anything and see if that works 

By any chance the streams that are failing are they 4K ? Do regular hd and Sd work? When I was having problems 4K streams did the same thing you mentioned with same behaviors but my theory on that is the switch I have has a QoS built in that cannot be disabled and as it was passing traffic into the Netduma QoS and was having a weird double QoS effect. 

On the Samsung you could try to make a static IP address on the tv then go into the router settings under lan and make a dhcp reservation and see if that helps . 

Share this post


Link to post
Share on other sites

Hi. I have the same problem.. Only thing that works for me is to disable QoS, that sucks :(

Share this post


Link to post
Share on other sites
4 hours ago, jodafi said:

Hi. I have the same problem.. Only thing that works for me is to disable QoS, that sucks :(

Hey, welcome to the forum!

Sorry to hear that, have you tried the other suggestions like toggling IGMP Proxying and SIP ALG in WAN Settings?

Share this post


Link to post
Share on other sites

I have the same problem on my xr500 and Samsung q7fn TV.

Why has this not been fixed yet?

Without QoS I might as well have bought a cheaper, more basic router.

Share this post


Link to post
Share on other sites
2 hours ago, Kinag said:

I have the same problem on my xr500 and Samsung q7fn TV.

Why has this not been fixed yet?

Without QoS I might as well have bought a cheaper, more basic router.

Hey, welcome to the forum!

Have you tried with QoS on but just DumaOS Classified Games disabled as previously suggested? As that is most likely the QoS feature that would be affecting it.

Share this post


Link to post
Share on other sites

My Sony AF8 never had issues with the XR500 but since QoS is a bit a mess and doesn't seem to deal with streaming that well from my experience I would suggest you either return the router in all honesty if you can and buy something else as there is no ETA on a fix for this yet. There have been no updates since August last year from what I remember and that wast really a Netduma update, but a important security patch from Netgear and a few game issues fixed for good measure. No bug patches to Milestone 1.3 since it was released in around December 2018. :(

Share this post


Link to post
Share on other sites

Unfortunatly it's out of return warranty. Purchased for over a year ago, but I disconnected it when I had issues with streams and used a cheaper alternative.

 

Problem is the cheaper alternative wasnt very good and caused other issues.

The router is good, but unfortunatly doesn't work well with my TV.

This should be a priority fix since a lot of people have these TVs.

Share this post


Link to post
Share on other sites
20 minutes ago, Kinag said:

Unfortunatly it's out of return warranty. Purchased for over a year ago, but I disconnected it when I had issues with streams and used a cheaper alternative.

 

Problem is the cheaper alternative wasnt very good and caused other issues.

The router is good, but unfortunatly doesn't work well with my TV.

This should be a priority fix since a lot of people have these TVs.

I don’t think it will be updated. Perhaps a R7800 might be a good second router for you using firmware from Voxel which is very nice if you want more control than Netgear’s standard stuff.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...