Jump to content
GHOST-1-EC

GeoFilter slow in reacting

Recommended Posts

4 hours ago, Netduma Admin said:

Appreciate the feedback guys. When BO4 first came out there were a bunch of teething issues because they were using many new servers (compared to previous CoDs), as well as a different approach to how their netcode worked. So we had to do a lot to improve our cloud to solve these problems - which we did as quickly as we could and as far as we have been able to tell solved the issues people had at launch. 

What's hard for us is when there are isolated issues being reported, because the vast majority of the time these are user error (e.g. wrong settings) or user's misunderstanding how something works. That's what tech support is for of course - most posts on this subforum are not actual bugs being reported, rather just users needing help or advice to get everything setup working optimally.

So the difficulty we have with your reports is you are saying there are still many problems and we know you guys are experienced with the router, so it's either that there is something else we need to look into, or something weird is happening on the game side. 

The best thing we can do next is gather as much info from you as possible, which we can then share with the developers to look into. So in the interests of moving forward and improving, two things to say:

  1. We recognize we can do better with direct communication from devs to you, so we'll work on this.
  2. Could you bullet point your main issue, and what you suspect may be the problem.  From what I have understood, a big need from you is for us to move mislocated servers as soon as possible. Is there anything else you can identify as not working as expected?

Thanks for your engagement - we know you just want what's best for the product.

@Netduma Admin

Your understanding is correct, 

My location again is South Africa (ZA).

I have not been able to consistently connect or at times connect at all to lobbies/servers i have added to my allowed list, even when clearly restricting my location/radius to exactly where these servers are located on the geofilter.

Neither the Geofilter radius nor the Ping Assist features are working as intended either within my exact location or when moving my location to another continent and limiting my radius to where the servers i want to connect to are located (i tested this for both BO4 and Apex Legends).

Servers i have added to my Denied list countless times are still being connected to with a 400-500ms ping, and i would be the only person pinging that high to that server/s even though the server location is in ZA and my teammates are all pinging between 30-60ms to it (i have submitted this server id/s several times without any action being taken or feedback given regarding it) - see the submissions form for ZA area and you'll be able to identify it as i am the only active member from this region reporting on the issues faced in ZA using DumaOS/XR500.

I will create individual threads for any other issue, for now i just want to be able to turn on my console and play the game without any connectivity to white-listed server/s issues.

Share this post


Link to post
Share on other sites

So to summarise:

  1. Trouble connecting to games from Allow list (BO4 & Apex) - This could be that they have many servers in a cluster and so others are trying to get through or the ones you've allowed are offline sometimes.
  2. Cannot force servers & Ping assist allowing higher than the limit?
  3. Denied servers not truly denied? - Can you confirm the ones you have denied are definitely being connected to? I.e it shows the same ID/name you've given it?

Share this post


Link to post
Share on other sites
36 minutes ago, Netduma Fraser said:

So to summarise:

  1. Trouble connecting to games from Allow list (BO4 & Apex) - This could be that they have many servers in a cluster and so others are trying to get through or the ones you've allowed are offline sometimes.
  2. Cannot force servers & Ping assist allowing higher than the limit?
  3. Denied servers not truly denied? - Can you confirm the ones you have denied are definitely being connected to? I.e it shows the same ID/name you've given it?

1. No, the servers cannot be offline one minute and then immediately upon restarting the game once or after a few attempts then its miraculously back online again or i am on actually playing on the server, then the game ends and the very next lobby the server cannot be connected to. 

2. I have set Ping Assist as high as 200ms and still could connect any servers, anything higher than 90ms in this game is unplayable and defeats the purpose of buying this router.

3. Denied server/s are connected to exactly as they have been blocked (same id's).

Share this post


Link to post
Share on other sites
29 minutes ago, GHOST-1-EC said:

1. No, the servers cannot be offline one minute and then immediately upon restarting the game once or after a few attempts then its miraculously back online again or i am on actually playing on the server, then the game ends and the very next lobby the server cannot be connected to. 

2. I have set Ping Assist as high as 200ms and still could connect any servers, anything higher than 90ms in this game is unplayable and defeats the purpose of buying this router.

3. Denied server/s are connected to exactly as they have been blocked (same id's).

1. If the Geo-Filter is allowing you to connect to it once then it should not be affecting future connections to that server if settings have not been changed. It could be the server is full when you try again or other variables. In spectating mode do you consistently connect to it?

2. Okay thanks, we can look into that, not seen that before.

3. Thank you, we'll look into it. I've passed your extra information on to the team.

Share this post


Link to post
Share on other sites
4 minutes ago, Netduma Fraser said:

1. If the Geo-Filter is allowing you to connect to it once then it should not be affecting future connections to that server if settings have not been changed. It could be the server is full when you try again or other variables. In spectating mode do you consistently connect to it?

2. Okay thanks, we can look into that, not seen that before.

3. Thank you, we'll look into it. I've passed your extra information on to the team.

1. No changes to any settings, logically i should continue to connect to it yes, but i cannot, like right now this very moment, i cannot for the life of me connect to any of the allowed servers within my radius, the server being full would be valid if i did not connect to it when then opening the radius, restarting the game and trying to play blackout as an alternative and then connect to the exact server which i had intended to with the radius reduced. Your next suggestion would be for me to leave the radius opened up abit more but i cannot do this, as when i complete one game and try to play another in either blackout or multiplayer, i would only be connected to the server/s i have denied. Using spectating mode would connect me to the desired server randomly, sometimes on first attempt or not at all and if not, i would just end up on the denied server/s.

2. Hopefully the return with positive feedback which is replied to on this thread.

3. Same as 2. above.

Share this post


Link to post
Share on other sites

I've given you the server id's, 

I've given you my location,

I've given you the game, console and device i'm experiencing the issue on,

I've posted pics on previous threads of the high ping server/s,

I've even posted a link to my competitive league play gameplay when i played on the intended allowed server/s which had no connectivity issues at all.

I cannot afterall the back and forth now still make a video illustrating everything i and everyone else has said.

Do what you guys have to do with what was requested from me and others to provide and then provided to you, i am not going to go to any further lengths to repeat what is known.

At this rate i'm just going to keep having to repeat myself everyday about the same thing as you are spending more time asking me the same questions over and over and over again, focus that energy on getting this fixed my guy.

You are making it seem now like i dont know what i'm talking about or doing when using the router or its software.

 

This gameplay is on an allowed server, you figure it out!!!

Share this post


Link to post
Share on other sites

I was asking for a video because for us being in the UK it will be very hard for us to force servers that far away to accurately reproduce the issue. As I understand so far we can't reproduce the issues testing within Europe, by trying to force servers in your location we may hit a ping limit that prevents that. I understand you don't want to provide anything else so we'll go on what is provided, I've passed it to the team, thanks.

Share this post


Link to post
Share on other sites

Thats odd, when the geofilter worked/works...... i played Apex Legends on the dedicated servers in UK (London to be exact) my best ping was 175ms but on average it used to always be 220ms and i never struggled to get lobbies and the gameplay was good. 

So you not being able 'force servers' this side is very unusual. 

Nonetheless, i hope this can get resolved as soon as possible for everyone. 

Share this post


Link to post
Share on other sites
23 minutes ago, Netduma Fraser said:

I was asking for a video because for us being in the UK it will be very hard for us to force servers that far away to accurately reproduce the issue. As I understand so far we can't reproduce the issues testing within Europe, by trying to force servers in your location we may hit a ping limit that prevents that. I understand you don't want to provide anything else so we'll go on what is provided, I've passed it to the team, thanks.

what hes saying is alot alike to what I was experiencing. I could have the strict on with a radius set and still get forced to play on another server thats outside of it anyways. Sometimes lobbies are impossible to connect to and it eventually forces a player host connection instead (if any connection is made that is). I have the same issue where ive denied that damn texas server over and over and it just has a new IP to issue me. I know the lobbies are not full because the old firmware connects me instantly to the one I usually play on without fail. Same settings, just a radius with strict on, that way the game cant force me outside of it (and my radius is like 850 miles too). Eventually all that does is force me to connect to east side servers no matter what. I set up the DumaOS the same way as I would the old firmware, thats what confuses me. I have checked my setting many many times to make sure I didnt mess up, just in case I was to blame. I dont even have the version with ping assist because it didnt all the time anyways. That isnt to say it doesnt work for some people, but for the two of us Geo just isnt functional. Maybe its our routers? Idk. Going back to old firmware works fine. Its just not as good as DumaOS in every aspect. I usually set my Radius 700 miles out and pinned as such. I am in Maine, but this always makes me connect to east coast and fast. Geo on connects me over to Texas when it shouldn't, so as OP states it seems "slow" to react as in it doesn't block it quick enough or just stalls. Now I know the cloud is fine because I have connected to east side a few times and the servers were dedicated. Our cases are virtually identical.

image.png.e47ef04bb38755c4d4c4f866df57029b.png

Share this post


Link to post
Share on other sites
3 minutes ago, GHOST-1-EC said:

Thats odd, when the geofilter worked/works...... i played Apex Legends on the dedicated servers in UK (London to be exact) my best ping was 175ms but on average it used to always be 220ms and i never struggled to get lobbies and the gameplay was good. 

So you not being able 'force servers' this side is very unusual. 

Nonetheless, i hope this can get resolved as soon as possible for everyone. 

exactly, usually once your radius is over it, the game just accepts it and lets you in. typically its instantly too when its working full force. 

Share this post


Link to post
Share on other sites
13 minutes ago, GHOST-1-EC said:

Thats odd, when the geofilter worked/works...... i played Apex Legends on the dedicated servers in UK (London to be exact) my best ping was 175ms but on average it used to always be 220ms and i never struggled to get lobbies and the gameplay was good. 

So you not being able 'force servers' this side is very unusual. 

Nonetheless, i hope this can get resolved as soon as possible for everyone. 

I was just saying that may be the case as we've had that before on other games so I was attempting to be prepared so we had everything possible and not have to come back to you at a later date.

10 minutes ago, bbursley said:

what hes saying is alot alike to what I was experiencing. I could have the strict on with a radius set and still get forced to play on another server thats outside of it anyways. Sometimes lobbies are impossible to connect to and it eventually forces a player host connection instead (if any connection is made that is). I have the same issue where ive denied that damn texas server over and over and it just has a new IP to issue me. I know the lobbies are not full because the old firmware connects me instantly to the one I usually play on without fail. Same settings, just a radius with strict on, that way the game cant force me outside of it (and my radius is like 850 miles too). Eventually all that does is force me to connect to east side servers no matter what. I set up the DumaOS the same way as I would the old firmware, thats what confuses me. I have checked my setting many many times to make sure I didnt mess up, just in case I was to blame. I dont even have the version with ping assist because it didnt all the time anyways. That isnt to say it doesnt work for some people, but for the two of us Geo just isnt functional. Maybe its our routers? Idk. Going back to old firmware works fine. Its just not as good as DumaOS in every aspect. I usually set my Radius 700 miles out and pinned as such. I am in Maine, but this always makes me connect to east coast and fast. Geo on connects me over to Texas when it shouldn't, so as OP states it seems "slow" to react as in it doesn't block it quick enough or just stalls. Now I know the cloud is fine because I have connected to east side a few times and the servers were dedicated. Our cases are virtually identical.

We'll look at the information you've both provided when it comes to trying to reproduce it/resolve it. Glad to hear they seem to be the same issue rather than different issues. bbursley, does your issue still seem to be resolved with the IP change outside DHCP range?

Share this post


Link to post
Share on other sites
7 minutes ago, Netduma Fraser said:

I was just saying that may be the case as we've had that before on other games so I was attempting to be prepared so we had everything possible and not have to come back to you at a later date.

We'll look at the information you've both provided when it comes to trying to reproduce it/resolve it. Glad to hear they seem to be the same issue rather than different issues. bbursley, does your issue still seem to be resolved with the IP change outside DHCP range?

Sadly no, I think it was just chance that it worked out well. I almost half wonder if it has anything to do with NAT. Maybe geo causes nat issues that mess up its ability to work properly? Have you noticed if others using DMZ on the Netgear routers have had less of an issue? I mean DMZ would absolutely prevent any chance of NAT issues (you'd think). Also just so happens the one game that I get issues with the most also gets moderate nat. Now is this a geo cause or just an issue somewhere in NAT causing ports to say they are open only to get hindered by the filtering process. I dont/cant really use port forwarding because its obnoxious to forward every possible port Id ever need for games. I could forward all ports and point them at the router, but that would be a security risk. I would find Nat being an unusual possibility though since even if I had moderate it would connect me outside, sometimes inside. Idk I can only speculate some thoughts based off what I have observed. I know its a pain to narrow down.

Share this post


Link to post
Share on other sites

Thanks for the extra info guys. We'll get a cloud update with all the changes you guys have submitted as soon as possible, as I'm hopeful this will root out the issues you're having. We'll post in this thread once it has been done. Hopefully get this out to you next week.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×