Jump to content

Recommended Posts

I enjoy this game but I'm about at my wits end for dealing with the connection issues. I don't know what to do.

For reference on CoD Blackout I ping avg 15 ms consistently in every lobby buttery smooth and have done so for months upon months. My connection is extremely stable high speed FTTP fiber connection.

However, more than half the games I try to play on Apex Legends experience absurd lag/rubber banding/high pings and it's extremely inconsistent. For example I watch the ping and some games I'll run 400+ ms for a couple mins then slowly drop down into the 50-60s, then spike back up etc. Every once in a while I'll get a nice low 30ms ish consistent ping and the game feels great but I'll go some entire 2-3 hour sessions where every game has horrible lag.

I've done the trick to change data centers to other acceptable ping ones based on their in game selection w/o much luck. I live in Indiana and was wondering if anyone has identified any good data centers I can try to connect too that seem consistent or have any other suggestions.

Best Regards,

Share this post


Link to post
Share on other sites

Hi there - best thing to do is switch between different servers to see which plays best. It sounds like some of them are giving you big lag spikes, so I'd recommend trying other ones.

This online tool might offer some insight as to the best servers to try out: https://titanfall.cf/status/r2

Also, your network doesn't have any congestion does it i.e. have you enabled QoS etc?

Share this post


Link to post
Share on other sites

I have a Eero mesh system that handles the WIFI for my house due to the size the R1 wasn't adequate so can't use QOS, the R1 is my first router and acts as a bridge to the main Router for the mesh system and my xbox is wired to the R1 and hypethreading is set for the Xbox.

Like I said though Blackout plays perfectly with god mode ping (sometimes under 10) with no spikes and I can swap to Apex and have massive issues, swap back and be fine so it doesn't appear to be anything locally.

I'll check out the server status link.

Another thing that doesn't make much sense to me regarding the data centers is what exactly is that doing in regards to my client? I figured everyone in the same match would be connected to the same server. Also, if I'm partied up with 2 other people and they both select different data centers what does that do?

I always thought everyone in a BR match would always be connected to the same server.

Share this post


Link to post
Share on other sites

Hey Butcher,

I will say this, as many may know here on the forums. I've consistently been trying to play on an Oregon server.  I'll select the server and would watch my geo-filter, and will not be placed on Oregon. I have yet to play on an Oregon server since the release of the game. As I begin to speculate if it's something to do with ISP's, because I will be completely thrown on a Virginia, Dallas, and Utah Server, as I do live in the west coast of Los Angeles. I have tried ping assist, strict and or just restricting myGeo_Filter to Oregon. Don't work, but the server will show once I am rejected or forwarded back to the title screen. As I stated regarding ISP's might be at play here, because I had changed my IP with VPN and though the game still sometimes recognizes me in California, I was able to play on a server or hosted peer in Kansas, able to connect to Sao Paulo, and less than a handful of other locations. All I've been trying to do is stick to a server with a moderate amount of players to enjoy a certain amount of consistency with the latency to the server, and in this case, Oregon is that server from tracing it. I just can't play on that server AT ALL. No matter what I do, yes even using Seattle based IP, still doesn't connect me to either of the four Oregon servers (though it's more in the state).  So yeah, even I am at a loss on what to do lol.

Share this post


Link to post
Share on other sites

Why are you unable to use QoS? If the R1 is the first router then it should be able to. Do Individual devices connected to the mesh show on the device manager? You mean hyper traffic?

I know people have been having some issues with the online, I follow the subreddit closely. So it could just be that it's a new game, they're still working out all the kinks. I assume everyone would be on the same server also but I must admit I play with my friend in Japan frequently and we're somehow able to play together without one of us experiencing too much lag. Whether they auto negotiate the middle server between you or what I'm not sure. 

Tray, I'd double check that the servers just aren't mis located on the map.

 

Share this post


Link to post
Share on other sites
2 hours ago, Netduma Fraser said:

Why are you unable to use QoS? If the R1 is the first router then it should be able to. Do Individual devices connected to the mesh show on the device manager? You mean hyper traffic?

I know people have been having some issues with the online, I follow the subreddit closely. So it could just be that it's a new game, they're still working out all the kinks. I assume everyone would be on the same server also but I must admit I play with my friend in Japan frequently and we're somehow able to play together without one of us experiencing too much lag. Whether they auto negotiate the middle server between you or what I'm not sure. 

Tray, I'd double check that the servers just aren't mis located on the map.

 

Yeah hyper traffic, and you're right sorry I do have QOS set up with xbox prioritized and share excess ticked.

Share this post


Link to post
Share on other sites

Okay that's great. I would say that it's likely down to the game, I'm sure you've been in those 'matrix' style games where EVERYONE is going super slow and it's only when people start being killed and leaving the game that it becomes playable. So that's nothing to do with you but rather the server load. Especially with the Battle Pass having just been released I imagine the player base has jumped back up close to that initial launch period. 

Share this post


Link to post
Share on other sites
9 minutes ago, Netduma Fraser said:

Okay that's great. I would say that it's likely down to the game, I'm sure you've been in those 'matrix' style games where EVERYONE is going super slow and it's only when people start being killed and leaving the game that it becomes playable. So that's nothing to do with you but rather the server load. Especially with the Battle Pass having just been released I imagine the player base has jumped back up close to that initial launch period. 

Yeah, I'm fairly confident of that as Blackout plays like I'm on a LAN. Of course the BO server I always connect to so I get like 10-15ms I did run a few Apex games testing some things pining like 19-30 so can't really ask for much better than that. Even though with a low ping I did run into one of those "matrix" style games at the start where everyone was moving at like quarter speed.

Share this post


Link to post
Share on other sites

Yeah everyone gets them as far as I'm aware so I wouldn't worry, it doesn't appear to be your connection. As time goes on it will get better! All you can do is make sure you've got your side sorted which sounds like you do.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...