Jump to content
Azlios

Waking up every morning to no WiFi

Recommended Posts

Every morning I'm waking up to an angry family saying they have no WiFi, all my wired connections work flawlessly but the wifi is so intermittent its painful. The only fix I have found is to change the wifi channel and it comes back instantly doesn't matter what channel i put it on. I've done an analyser and found that channel 6 is best for me at the moment, so I always have it set to that.

My set up is simply the Netduma plugged into at BT Smart Hub, Netduma is in the smart hubs DMZ and everything in the house goes through the Netduma as WiFi is turned off on the Smart Hub.

My Smart Hub and Netduma are completely segregated from anything wireless. they sit on their own in the middle of the living room.

The system log on the Netduma constantly shows these messages -

                  user.warn com.netdumasoftware.settings: Error opening wireless-mirror with error wireless-mirror: No such file or directory.

                  kern.info dpiclass-daemon: Kill flow due to timeout

                  kern.warn kernel: [145584.580000] HTB: quantum of class 10001 is big. Consider r2q change.

any help would be appreciated, my Netduma is getting old now got it in October 2015, could it be on its last legs?

Share this post


Link to post
Share on other sites

Are you in the latest firmware?

WiFi isn't the R1s best feature. It may not be your preferred option but you could add a second router (if you have one) bridged to provide the WiFi. The R1 handles all the connections.

You can even hard wire the second router to the best place in the house if you have weak reception spots.

Share this post


Link to post
Share on other sites

around 10 devices can be connected at one time, mostly iPhones, iPads and Kindle tablet.

 

The Kindle tablet had an unusually high bandwidth use so I lowered it in the QoS, but nothing else is using much at all.

 

No, i do no turn off the router at night.

Share this post


Link to post
Share on other sites

WiFI was on and working fine this morning with QoS turned off.

 

I done some more digging and I think it may not be the Duma at all. I think it may be my Smart Hubs fault, there's something happening around 4am where it disconnects the duma on its own even though its plugged into the ethernet port and then reconnects it and then says - ":DHCP Confirmation of Request" It does this every morning at 4am. Could this be why my WiFi is so intermittent? The problem most of the time is that I can see the duma outputting a signal and everything is connected but it says no internet access, very rarely can I not find the Duma signal.

 

So basically the software in the so called BT SmartHub is disconnecting my duma every morning at 4 am.

Share this post


Link to post
Share on other sites

Okay very interesting. Could you increase the DHCP lease on the Smart Hub and see if that resolves it please. If not likewise could you do the same on the R1 and see if that resolves it. If they're set to 24 hrs then that could be it.

Share this post


Link to post
Share on other sites

They are indeed set to 24 hours, I'll increase it now and let you know if anything changes. Might be time to just remove the BT Hub from the equation all together, wil have to wait for payday for that though.

Share this post


Link to post
Share on other sites

I've done a factory reset on both the Smart Hub and the Duma, put a static IP back on the Duma and placed it in the DMZ in the hub, increased the DHCP lease time on both boxes and will now wait and see. I'm 90% sure now though that this isn't a Duma issue and is a BT issue.

 

When I was changing the lease time I saw there was an option for "Authoritative DHCP" that was set to on, don't know if that has anything to do with it?

Its description is - "If your device is using the wrong IP address, the BT Smart Hub will try to correct it so the connection doesn't break."

Share this post


Link to post
Share on other sites

Authoritative DHCP sounds like it could potentially be causing this issue. If your WiFi is dropping and switching channel fixes it, it seems highly likely that the issue is linked to DHCP or your IP address somehow. Definitely keep that setting disabled and see if that improves your situation.

If you have a spare modem anywhere it's definitely worth testing that to see if the issue continues. I'm convinced this has something to do with the modem as well - WiFi drop-outs caused by the router itself are extremely rare, and usually caused by user error (if the user has been fiddling with complex settings without knowing how to use them).

It doesn't sound like you've been playing with complex settings on the XR500, so the Smart Hub is in the firing line.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...