Jump to content
Netduma Admin

Open Beta of DumaOS on the Netduma R1: General Discussion

Recommended Posts

On 10/24/2018 at 5:52 PM, gianluca.cec said:

why i can't acces to dumaos? i dowloaded and upgrade the file (dumaos) but i can't acces to dumaos page

Did potatoaim's instructions resolve your issue?

Share this post


Link to post
Share on other sites

Has anyone had any troubles playing B04 On DUMA OS,    For some reason I keep getting a moderate Nat Type,  I have Port 3074-3076 Forwarded To My Static IP Of my Xbox,  If i reset my router/unplug it, Re open the game, Its OPEN,   Never shutting my Xbox off, The next time i open the game again, Its back to moderate??  I've never had this issue before,  I've also tried just letting the UPNP Taking it over and it still does the same thing,  I Don't know if its something with DUMA OS, Or if its something with the game,  Also My NAT is Always OPEN  When checking Network Settings, And Yes I Have IPV6 Off,   I Cant figure this out and its really getting to me..  If anyone has any tips please feel free to toss them my way i will try anything! 

Share this post


Link to post
Share on other sites
37 minutes ago, IGotzPotatoAim said:

Has anyone had any troubles playing B04 On DUMA OS,    For some reason I keep getting a moderate Nat Type,  I have Port 3074-3076 Forwarded To My Static IP Of my Xbox,  If i reset my router/unplug it, Re open the game, Its OPEN,   Never shutting my Xbox off, The next time i open the game again, Its back to moderate??  I've never had this issue before,  I've also tried just letting the UPNP Taking it over and it still does the same thing,  I Don't know if its something with DUMA OS, Or if its something with the game,  Also My NAT is Always OPEN  When checking Network Settings, And Yes I Have IPV6 Off,   I Cant figure this out and its really getting to me..  If anyone has any tips please feel free to toss them my way i will try anything! 

This'll likely be due to the Geo-Filter blocking a NAT server. We always recommend only enabling the Geo-Filter (i.e switching it to Filtering Mode) once you're on the Multiplayer menu in-game.

That being said, your Moderate in-game NAT reading is likely false. We've tested this extremely thoroughly - the Geo-Filter can cause it to display as Moderate, yet your NAT will actually be open. You can prove this to yourself by searching for a game - if the game behaves normally and you connect relatively easily, you likely have an open NAT.

I hope this helps!

Share this post


Link to post
Share on other sites
4 hours ago, IGotzPotatoAim said:

Has anyone had any troubles playing B04 On DUMA OS,    For some reason I keep getting a moderate Nat Type,  I have Port 3074-3076 Forwarded To My Static IP Of my Xbox,  If i reset my router/unplug it, Re open the game, Its OPEN,   Never shutting my Xbox off, The next time i open the game again, Its back to moderate??  I've never had this issue before,  I've also tried just letting the UPNP Taking it over and it still does the same thing,  I Don't know if its something with DUMA OS, Or if its something with the game,  Also My NAT is Always OPEN  When checking Network Settings, And Yes I Have IPV6 Off,   I Cant figure this out and its really getting to me..  If anyone has any tips please feel free to toss them my way i will try anything! 

same thing happens to me, i just reboot the router from the software info tab at the top, when it restarts its back to open

Share this post


Link to post
Share on other sites
2 hours ago, TODDzillaInLA said:

same thing happens to me, i just reboot the router from the software info tab at the top, when it restarts its back to open

I would classify that as a bug.  Jack, is this something being looked at; can anything be done to correct this behaviour or does anything even need to be done?  It especially doesn't make sense considering that before a reboot, it shows 'Moderate', yet afterwards it's 'Open'.  I can accept your statement that most likely the NAT is open, but the game is reporting 'Moderate' (mine does the same thing), yet I have no issues getting into games at all, and no issues communicating via voice for in-game chat or Xbox Live party, however my OCD won't let this go either ;) .

 

For the record, this is my first complaint with regards to this DumaOS/BO4 combination, lol.

Share this post


Link to post
Share on other sites

the game showing Moderate definitely effects playing in bo4. when you have a group of 5 or 6 players lobbied up and you go to search a game, the game will kick you back to the main start menu. also noticed people that are already allowed, if they are outside the geo filter you have to click on there icon again and the ping at the bottom pops up with there saved name and info but if you don't hit allow again it won't let them join

i didn't know it was the netduma causing the moderate nat type to a couple post ago. i thought after this last big bo4 update that's what caused it. i use to only have upnp enabled for open nat type. i just changed the settings and i turned upnp off and i port forwarded all the xbox recommended ports but i noticed with upnp disabled ports like 3074 still show up under upnp. also when port forwarding if a port needed both tcp and udp i would have to make 2 new rules, 1 for tcp and 1 for udp. if i tried the option for one port number like 3074 and i tried to use the dual option of tcp + udp it would give me a error 

Share this post


Link to post
Share on other sites

It's possible we're blocking a NAT server - that would explain why the Geo-Filter sometimes causes as moderate NAT to show in game. We will try to hunt it down. I would recommend you do not touch your UPNP / Port Forwarding settings if your NAT is open on the console.

Share this post


Link to post
Share on other sites
1 minute ago, Netduma Admin said:

It's possible we're blocking a NAT server - that would explain why the Geo-Filter sometimes causes as moderate NAT to show in game. We will try to hunt it down. I would recommend you do not touch your UPNP / Port Forwarding settings if your NAT is open on the console.

I end my gaming sessions by shutting down my Xbox, and then turning off the Geo Filter.  Doing this ensures my console NAT always reports as 'Open' when I turn it back on next time.  However regardless of if the console NAT is 'Open', UPNP is enabled or not, or manually using Port Forwarding instead, no matter which setting, or combination of settings, the game will always report 'Moderate', even before I turn on the Geo Filter.  I think since I've upgraded to DumoOS, I've only had one BO4 session show as 'Open'.

 

Are you guys actively adding NAT servers for Xbox Live?  It would be nice to not have to manually shut off the Geo Filter every time I turn my console off.

 

By 'turning off the Geo Filter' I mean that I put my console into 'Spectating' mode.  I don't delete the device or anything like that.

 

Hopefully the additional info helps you guys out with getting to the bottom of this.  Thanks for your efforts!

Share this post


Link to post
Share on other sites

So just to be clear, you are seeing a Moderate NAT in game with the GEo-Filter in Spectating Mode? That's very odd if so. Do you have multiple consoles on your network?

Share this post


Link to post
Share on other sites
11 minutes ago, Netduma Admin said:

So just to be clear, you are seeing a Moderate NAT in game with the GEo-Filter in Spectating Mode? That's very odd if so. Do you have multiple consoles on your network?

Nope, at least not right now.  There hasn't been a second active console since the summer (while on the old firmware).

 

I'll test again tonight.  I'll make sure to deactivate Xbox and game-related Port Forwarding, and ensure UPnP is enabled, ensure Geo Filter is off, reboot my Internet modem, reboot the R1 router, reboot my console, then check console NAT to ensure 'Open', launch game, check in-game NAT, report into here, enable Geo Filter and hope that I've seen and can maintain an 'Open' in-game NAT.  I'll get back to you guys tonight to confirm what the in-game NAT reported before I enable the Geo Filter.

 

That should cover the test, unless you want to add any intermediary steps?

Share this post


Link to post
Share on other sites
7 hours ago, Netduma Admin said:

You got it. Let us know what happens when you do this. I think it's the Geo-Filter causing moderate NAT. If not, please let us know!

So far so good!  I've got an 'Open' NAT on both the console and in-game in BO4.  Geo Filter is disabled (still), so don't know what it'll be after I enable it.  I'll restart my game after and report again.

 

Afterwards: Enabled Geo Filter, re-started the game (did NOT restart the console at this point) and the NAT is still 'Open'.

 

Now I guess the true test will be disabling the Geo FIlter (like I do every night), a restart of the console, restart the game, and check to see if NAT in-game is still 'Open', report back here, re-enable the Geo Filter, and wreck some n00bs! :D  BRB...

 

Afterwards again:  I disabled the Geo Filter, restarted the console, found console NAT to be 'Open', restarted the game, and found in-game NAT to be 'Open'.

 

Success!  Now, hopefully, it stays that way without having to restart my Internet modem, router and console.  I'll report back in the next few days if it reverts to 'Moderate' NAT without me restarting anything.

 

Thanks for reading so far down ;) .

Share this post


Link to post
Share on other sites

Wow Tons of reply's so fast!!  I will also check disabling GF and see if this works,  But im pretty sure i usually leave the GF off until i open COD or about to play COD Then turn it on, Im going to try a few steps and see if it works!  But thank you everyone for all the quick reply's 

Share this post


Link to post
Share on other sites

it is the geo filter causing moderate nat. started the game with it on and it was moderate turned it off rebooted everything it went back to open turned it on in game. last night before i went to sleep i turned it off then this morning before i went to work i turned on the xbox to check and it was open

 

also with the geo filter on set to call of duty the lobby usually gets kicked back to the main screen, i posted a video of it

https://twitter.com/OWUH_Gaming/status/1059865175753285632

all so peers are starting to show as dedicated for some reason 

 

Share this post


Link to post
Share on other sites
9 hours ago, Netduma Jack said:

Awesome, great to hear you've got your open NAT :D

So Jack, is it possible that you guys will be able to correct this behaviour?  It would be nice to not have to turn off the Geo Filter manually every night to get an open NAT the next gaming session.  I'd love to be able to leave this on, and in fact, not have to do anything with the Netduma at all.

Share this post


Link to post
Share on other sites
33 minutes ago, kssxs said:

So Jack, is it possible that you guys will be able to correct this behaviour?  It would be nice to not have to turn off the Geo Filter manually every night to get an open NAT the next gaming session.  I'd love to be able to leave this on, and in fact, not have to do anything with the Netduma at all.

same. on the old firmware i left the geofilter on all the time. my internet is basically for me and call of duty 😃  i would even change the bandwidth bars when matching movies i always left them at 70%

Share this post


Link to post
Share on other sites

For some reason Turning the Geo filter off didnt seem to work for me,  Even resetting my Xbox green screen and coming back in with the GF still being off still didnt work, Still Moderate,   I Dont have a problem with any other ports And my Nat is open on Xbox, Just not COD, Witch its trying to use 3075, And the Xbox Is using 3074,  Do you think if i change my Xbox to run on a different port in the settings that the game will try to use 3074?     Im Not sure what is going on here, But its driving me nuts,  My friend cant join me until i reset my router and come back and reopen the game, Bam Its OPEN!      This is driving me nuts,   Anything else i can try?

Share this post


Link to post
Share on other sites

call of duty uses 3074 3075 and 3076 for multi console systems. any of those ports should give you open nat

i didn't start having moderate nat to that first big BO4 update, i think its something in game along with the GF but getting backed out the way i do to the main lobby like in the video i posted and having to add people all the time is definitely the geo filter

Share this post


Link to post
Share on other sites

So I just go home and checked my nat type, I left geo filter off and when I the game booted up I went to settings network and it was moderate, restarted router hard reset xbone and now it’s open 

Share this post


Link to post
Share on other sites

Without restarting anything, NAT is 'Moderate' again.  It was 'Open' last night during my gaming session.  Shut down the Xbox then, and  turned off the Geo Filter.  Tonight, I started up the Xbox and the game, and checked the in-game NAT status and found it 'Moderate'.  Did not enable Geo Filter until I checked the NAT status.  I also realized I had QOS disabled on the Netduma, but that just wasn't a factor as my tests were done with it disabled.

 

Something's not right here.  This should not be an issue.

Edited by kssxs
Added additional details

Share this post


Link to post
Share on other sites

Yup, I Get the same thing!   And like i said I Have 3074-3076 opened and forwarded,  And I've also Tried just running UPNP, And Both at the same time, And Deleting The Port Forward And Just running UPNP,  And Tried With Geo Off, Still Nothing, But As soon as i close the game, Restart the router, BAAAM its open!  And will stay open, Until I close the game,  Sometimes only 1 restart or Sometimes i can restart the game a few times, Before it goes back to Moderate!    And this is NEVER shutting my Xbox off,  I Leave it on 24/7, Because i have my TV ran through it!  And before someone says something about leaving it on 24/7 lol,  I Did Rip my X apart and Relay the crappy heatsink compound and put on some Arctic silver 5 And some thermal grizzly pads And did the fan mod, Thing stays in the mid 40's while gaming!  And it for sure is moderate because a few of my friends can not join me until i get it open and then its fine, they can join,  So its not just a glitch showing that its moderate and its really open,   I was hoping it was!    Hopefully we can get a fix for this soon, From either COD or netduma, I'm not sure what side its on!  And thank you guys again for the super fast reply's, You guys ROCK! 💎

Share this post


Link to post
Share on other sites

Thanks everyone for the info - and Potato for the kind words!

Are any of you happy to connect your console to your modem (or another router) for a day or so - the reason I ask is if the Geo-Filter is disabled, and your console NAT is open, it might just be an issue with the game. Nothing on the R1 should be interfering with your NAT type.

And not to play it down, but this is a visual annoyance only right? It's not actually limiting your ability to play the game normally?

Share this post


Link to post
Share on other sites

Ive tried, If i disconnect the R1 and just run my modem router its open!  And its not just visual like i was hoping, It does actually stop people from connecting to me and me to them and takes longer to find matches in COD,  Mostly Blackout over just the Multiplayer!    I Actually Have my R1 in DMZ through my Ubee Modem/Router,   Because for some reason If i just use the bridge it resets my modem like every few hours,  Its something with the single from the cable company!   I think,  It thinks im trying to steal internet or something and shuts it down,  So I have to DMZ the R1,  And Also ive tried opening the port through the Ubee,  But in the old netduma software there was  UP UPNP Witch aloud UPNP From another router,  So I Dont even know if its working in this build? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...