Jump to content
MRxFUZZ

Geo Filter Problems/Anit Bufferbloat

Recommended Posts

Having problems of no friends showing on the geo filter or they are showing up as servers. Also my xbox is getting the full download after putting the slider down to 50% or any percentage.

Share this post


Link to post
Share on other sites

If you have Anti Bufferbloat set to only apply when high priority traffic is detected it will only limit you speeds when you are playing a game. The rest of the time you will get your full speeds.

Share this post


Link to post
Share on other sites

Hi and welcome to the forum

 

For your Geo-Filter - what game are you playing and on which device?

 

As for Anti-Bufferbloat, change the mode to ‘always’ and make sure you have set the correct total bandwidth numbers in the options for AntiBufferbloat

Share this post


Link to post
Share on other sites

It’s already on the mode ‘always’ for Anti bufferbloat. I have played COD, Pubg, and Rocket League, on the Xbox one X with the XR500. Friends or people don’t show up on the geo filter even if they are in my party. Thanks guys for the fast repsonse.

Share this post


Link to post
Share on other sites

Do you mean it's getting the full bandwidth that you have after applying Anti-Bufferbloat e.g. if you have 100mbps speeds and lower that to 50% the console is getting 50mbps? 

 

If that is the case it is because share excess is enabled on Bandwidth Allocation so it won't be limited to whatever % you have given it on there, it will take extra bandwidth from devices that don't need it.

 

Is your console wired or wireless? Check on the device manager for the Xbox's MAC/IP and make sure it matches the details on the Xbox settings. Once you're sure make sure it's marked as a console on device manager, then add it to the Geo-Filter in the devices panel. On the map make sure you are zoomed completely out so you can see anything appearing on the map.

Share this post


Link to post
Share on other sites

Yes, still getting the full bandwidth after applying Anti-Buffer even with share excess off (Only on my console). Works for Upload speeds but not Download speeds.

 

My console is wired, and the MAC/IP both match. Its also marked as Xbox on the device manager. 

Share this post


Link to post
Share on other sites

Disable the Traffic Prioritization then that should fix it. Can you confirm if that is the case? 

 

If so I can explain why, Traffic Prioritization prioritises devices/games and puts them ahead of the queue which means it bypasses your QoS settings. That doesn't mean it's not getting the speeds you've allowed it, it just means that when you do the test the test is being prioritised. You'll still be getting your speeds and your games will still be prioritised.

Share this post


Link to post
Share on other sites

Nothing, still only affecting the upload speeds. Should I just do a factory reset and then try again ?

 

Before doing that could you please give us a screenshot of your QoS page, if I can't diagnose it from that I can do a quick 1 on 1 with you.

Share this post


Link to post
Share on other sites

Having a similar problem where my friend and I cannot connect to each other under strict mode on the geo-filter, although we have both allowed each other.  For some reason he shows me in California when I'm in Missouri, yet I see him clearly on my geofilter.  I did move my icon/pin to a dedi in Texas for a better ping but I am still within his range anyway. 

 

We both have XR500s.  We are both rookies and trying to learn this router.  

Using PS4 playing WW2

If we both remove strict mode we can connect no problem.  

Share this post


Link to post
Share on other sites

Having a similar problem where my friend and I cannot connect to each other under strict mode on the geo-filter, although we have both allowed each other.  For some reason he shows me in California when I'm in Missouri, yet I see him clearly on my geofilter.  I did move my icon/pin to a dedi in Texas for a better ping but I am still within his range anyway. 

 

We both have XR500s.  We are both rookies and trying to learn this router.  

Using PS4 playing WW2

If we both remove strict mode we can connect no problem.  

 

Hey, welcome to the forum! Can you start a new topic for your issue please as it'll be hard to support multiple people in one post but to answer quickly It sounds like you may have allowed something that wasn't your friend as you should be able to join no problem. Go into a private match on CoD with spectator mode enabled, then invite your friend into the game, there should only be one thing that appears on the map - allow that. Then you should be good to go.

Share this post


Link to post
Share on other sites

So I found the problem. So when using IPv4 and IPv6 on the console it wont filter the download speed. Only IPv4 it works. Why ?

 

Interesting, VERY good find. We don't have that feature at the moment, it only works with IPv4. I will suggest that to our Development team in the morning. If needed would you be available during the day tomorrow for them to take a look if they need more information?

Share this post


Link to post
Share on other sites

Hi Mr Fuzz,

 

We will look into this tomorrow and providexplanation and update ASAP.

 

May I ask why you use ipv6 for your console? Do you still have ipv4 nat router?

 

Thanks!

Share this post


Link to post
Share on other sites

Iain,

 

I noticed this same issue on other routers as well. Anything that was actively using IPv6, would bypass QoS, and be able to max out your connection still.

 

With that said there's reasons people need IPv6, and that's not to say they need it for their consoles. Still in this case any device using IPv6 on their network will bypass QoS, and overall that's not good. So even if they are able to disable IPv6 on the xbox itself it will not fix the issue. As for PS4 it doesn't officially support IPv6 yet. So no option to enable/disable it on the PS4. However i have read the PS4 will acquire a IPv6 address though.

 

With all this said. This is something that need's to be looked into, and a way for IPv6 traffic to be handled by QoS as well.

Share this post


Link to post
Share on other sites

Iain,

 

I noticed this same issue on other routers as well. Anything that was actively using IPv6, would bypass QoS, and be able to max out your connection still.

 

With that said there's reasons people need IPv6, and that's not to say they need it for their consoles. Still in this case any device using IPv6 on their network will bypass QoS, and overall that's not good. So even if they are able to disable IPv6 on the xbox itself it will not fix the issue. As for PS4 it doesn't officially support IPv6 yet. So no option to enable/disable it on the PS4. However i have read the PS4 will acquire a IPv6 address though.

 

With all this said. This is something that need's to be looked into, and a way for IPv6 traffic to be handled by QoS as well.

 

Now that we know there is an actual use case we can look into implementing this feature.

Share this post


Link to post
Share on other sites

I have always set up my Xbox while using IPv4 and IPv6 (link below). I’ve had the R1 with IPv6 enabled and it worked fine. When we tested it yesterday, the QOS was only affecting the upload speeds and not throttling the download speeds when using both IPv4/IPv6.

 

https://support.xbox.com/en-AU/xbox-one/networking/ipv6-on-xbox-one.

 

No worries, now we know that there are people who require IPv6 we can work on implementing that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...