Jump to content
Grimy1928

BT TV and setting up bt smart hub with netduma

Recommended Posts

Hi there, I have a little issue here.

 

First of all, I have a BT TV box that works fine most of the time but when using the netduma and openreach modem everything works like on demand but not the live internet channels like comedy central. However, if I swap out out the two with just the BT smart hub then it works without issue.

 

My question is, if I want to use the BT TV with netduma do I have to use the BT smart hub for its modem by adding the netduma to the DMZ table? Also, if that would be what I need to do then could I please have some help setting it up with the netduma as I am having trouble doing so. I tried following the bt homehub 4/5 setup guide but can hardly get past the first step with the smart hub. Any help would be greatly appreciated as I'm banging my head against the wall because of this BT TV box crap.

 

Thanks,

Adam.

Share this post


Link to post
Share on other sites

you should not have an issue as I have a bt youview box ( i presume that is what you mean by bt tv). I had a connection issue snf what i did to resolve it was turn the power off on the back of the bt tv box. go into the netduma and remove the bt tv box from the device manager listing and reboot the netduma...........then restart the bt tv box and you should be fine! 

Share this post


Link to post
Share on other sites

Oh okay thanks. That sounds good and I will definitely try that soon when I get a chance. I am using the BT youview box and the only thing that doesn't work is the live channels like comedy central etc but on demand works fine. I forgot to say the error message I got was IPC 6023 (I think). I hope your method works. Thanks.

 

I tried what you said but netduma said it was still active so I turned it off and had to reboot the router but now it doesn't show up without saying it is active so I cannot remove it. Any ideas?

Share this post


Link to post
Share on other sites

if it is not listed in device manager at all then it is nolonger connected to your network. a simple reboot of the netduma and then the youview box in that order should resolve this.

 

 

hold on a moment, are you saying that on demand works such as itv player and netflix but you cannot watch live channels such as bbc1,2,3,4, itv, ch4 ch5? In that case your youview box must receive it's signal for those live channels from your ariel and not via ethernet.

Share this post


Link to post
Share on other sites

The device shows up. Rebooting everything like you said didn't fix it. I do have Arial which is how I get channels like ITV but internet subscription based channels such as comedy central work. However, it does have internet as it can do on demand from those internet channels but just can't play them live.

Share this post


Link to post
Share on other sites

The device shows up. Rebooting everything like you said didn't fix it. I do have Arial which is how I get channels like ITV but internet subscription based channels such as comedy central work. However, it does have internet as it can do on demand from those internet channels but just can't play them live.

 

Apparently the only way to get this to work is by doing as you said in your first post - adding the Netduma to the DMZ table on the BT smart hub. Please let us know if you can get those channels using this setup :)

 

What do you need help setting up? Do you get your speeds, and do you need help setting up the Netduma for gaming?

Share this post


Link to post
Share on other sites

Hi there, thanks for the response. I did feel that I would have to do the whole DMZ thing. Could I get a bit of help with setting up the BT smart hub if possible though please? I tried following an old guide for the BT home hub 4/5 but it isn't clear to what router to connect to and the netduma device manager doesn't take me to the bt UI or show any connections. I know what to do for home hubs but can't figure out how to do it with the smart hub. Are there any guides I've missed? Thanks.

Share this post


Link to post
Share on other sites

Access the Netduma and go to Device Manager, copy it's WAN IP address. If it doesn't have this and doesn't have any devices at all then it sounds like you haven't set it up correctly. Port 1 of the Netduma should be connected to port 1 of the hub.

 

Then access the hub and go to advanced settings > firewall, then paste the IP address into the DMZ section.

Share this post


Link to post
Share on other sites

Hi, thank you for the response. I tried what you said and got the WAN IP address from device manager. However, when I get into the BT interface and enter the WAN IP to the DMZ section and I select the on button, it says that I need to save changes but I press save and it does nothing but if I turn off DMZ then it saves no issue. Any ideas why? I tried it wireless and wired but with no success. Thanks for the help.

Share this post


Link to post
Share on other sites

I mean that when pressing save after adding the WAN IP it does nothing. Nothing on the screen changes and it doesn't save. After refreshing the page, no settings have been saved. I must be doing something wrong. Is there some setting I need to configure for it to work and do I need to use wired or wireless? I know what to do but the DMZ just doesn't save what I do but as soon as DMZ is on, it will save whatever has been changed in that area. Any ideas? Thanks.

Share this post


Link to post
Share on other sites

I mean that when pressing save after adding the WAN IP it does nothing. Nothing on the screen changes and it doesn't save. After refreshing the page, no settings have been saved. I must be doing something wrong. Is there some setting I need to configure for it to work and do I need to use wired or wireless? I know what to do but the DMZ just doesn't save what I do but as soon as DMZ is on, it will save whatever has been changed in that area. Any ideas? Thanks.

 

Perhaps it's defaulting to off and the save button isn't the one you need. Is there another button which relates to saving? (e.g Save to Flash, Apply)? This might also be a browser issue - try using another browser and device to access the BT Interface.

 

It'd also be helpful if you could take a screenshot of that whole page on the BT interface. Uploading images here is annoying, I'd recommend doing it through a site like Imgur.

Share this post


Link to post
Share on other sites

Perhaps it's defaulting to off and the save button isn't the one you need. Is there another button which relates to saving? (e.g Save to Flash, Apply)? This might also be a browser issue - try using another browser and device to access the BT Interface.

 

It'd also be helpful if you could take a screenshot of that whole page on the BT interface. Uploading images here is annoying, I'd recommend doing it through a site like Imgur.

Hi there, sorry about the late response. I've been very very busy and forgot to get back on topic about this. Anyway, I tried different browsers and there wasn't any difference and I didn't see any other save button. In the screenshot you can see I have entered the Wan IP address the netduma showed in the device manager and have tried pressing save at the top right. However, after pressing save, it doesn't do anything. The screen stays exactly the same saying that I need to save the changes.

 

https://imgur.com/a/jLeuK

Share this post


Link to post
Share on other sites

Hi there, sorry about the late response. I've been very very busy and forgot to get back on topic about this. Anyway, I tried different browsers and there wasn't any difference and I didn't see any other save button. In the screenshot you can see I have entered the Wan IP address the netduma showed in the device manager and have tried pressing save at the top right. However, after pressing save, it doesn't do anything. The screen stays exactly the same saying that I need to save the changes.

 

https://imgur.com/a/jLeuK

 

I would honestly love to be able to give you the solution. I've looked this up (BT Smart Hub not saving) and it looks to be a bug with their software. You aren't doing anything incorrectly - indeed, this is how BT instructs you to enter the DMZ. The bug is certain settings not saving, and I've seen people switching to the BT Home Hub because of it.

 

We unfortunately can't really help you to resolve this saving issue as it's not our software. Investing in a secondary router or a new modem (supported by BT) would very likely solve this issue though I know that's not ideal. Please let us know what you decide to do :)

Share this post


Link to post
Share on other sites

HM...interesting. BT like always with their trash not working properly! I appreciate the help you've given me but it's just unfortunate I can't really do anything. However, I have a bt homehub 5 which has a modem built in. I'm just wondering if my internet would be impacted negatively in any way by using that over the smart hub as I intend to use the netduma for wireless and wired connections. Thanks!

Share this post


Link to post
Share on other sites

HM...interesting. BT like always with their trash not working properly! I appreciate the help you've given me but it's just unfortunate I can't really do anything. However, I have a bt homehub 5 which has a modem built in. I'm just wondering if my internet would be impacted negatively in any way by using that over the smart hub as I intend to use the netduma for wireless and wired connections. Thanks!

 

I'd definitely give the homehub a go - I doubt it will negatively impact your connection, and it would be a great way to prove that the Smart Hub software is faulty if you managed to get the homehub DMZ working!

Share this post


Link to post
Share on other sites

Have not read all the posts, with the BT box you have to connect it directly to the home hub.

 

I have tested this with a friends connection 76/18mb and while streaming the sports ping plotter does not show any adverse jitter while doing so.

Share this post


Link to post
Share on other sites

Okay, so I successfully added the netduma to the DMZ on the home hub 5. However, when connecting to the netduma via wifi, it says connected but no internet but the by home hub 5 works with the internet without an issue. Why?

Share this post


Link to post
Share on other sites

All devices. Netduma WiFi won't work but BT home hub 5 WiFi works fine after adding the netduma to the DMZ table. I'm really really confused as I've followed the guides online exactly. It's just like the netduma isn't using the home hub as a modem or something.

Share this post


Link to post
Share on other sites

Could be congestion, you haven't by any chance given it the same name/password as BT WiFi have you? 

 

Use a WiFi analyser to find the least congested channel in your area and use PSK2. 

 

If that still doesn't work disable it on the interface, reboot from misc settings, enable it then reboot again from misc settings. Does it work then?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...