Jump to content
Sign in to follow this  
OzQuant

My XBoxOne requires a restart every time to get NAT=Open

Recommended Posts

Every time I boot up my Xbox One, it tells me that NAT=Moderate. But as soon as a reboot the Xbox One, it tells me that NAT=Open. I would prefer that it be NAT=Open all the time without the constant forced reboot.

 

My set up is kind of complicated.

 

Cable Modem (NTD) for internet.

 

Modem/router (in router mode) from NTD. I reserve an IP address in the DHCP table for the R1. This IP address is in the DMZ of the modem/router.

 

desktop 8 port switch to the modem/router. Simple switch, no config.

 

R1 from the switch. R1 has UPnP enabled. Downstream UPnP is unticked (disabled).

 

Xbox One from the R1. Xbox One is set to Automatic IP and Automatic DNS.

 

Everything is via cable (CAT5)

 

I've tried reserving Xbox One's IP in the R1, but this gave me NAT=Unavailable and caused errors playing games.

 

I'd like to know why the Xbox One gives me NAT=Moderate upon bootup, but a subsequent reboot makes NAT=Open and how to fix it.

 

Thank you.

Share this post


Link to post
Share on other sites

Hi, if i'm reading it correctly you have an 8 port switch between your R1 and the modem? Could you not swap them round as you are defeating the purpose of the built in hyperlane and congestion control otherwise.

 

Is your Xbox set to instant on mode? If it is, this could be the reason as i found i had a similar problem. Instant makes the Xbox try to hold ports open all the time it is on, which i'm guessing the router does not like. By resetting the Xbox you are reopening the ports. I have since turned mine to power saving mode and i have not had that problem since.

Share this post


Link to post
Share on other sites

Hi, if i'm reading it correctly you have an 8 port switch between your R1 and the modem? Could you not swap them round as you are defeating the purpose of the built in hyperlane and congestion control otherwise.

 

Is your Xbox set to instant on mode? If it is, this could be the reason as i found i had a similar problem. Instant makes the Xbox try to hold ports open all the time it is on, which i'm guessing the router does not like. By resetting the Xbox you are reopening the ports. I have since turned mine to power saving mode and i have not had that problem since.

 

Thank you for your reply.

 

I have too many other devices and I only want the Xbox One on Netduma. I only need the geofilter feature. I still don't trust the R1 enough to put all my devices through it. (considering the trouble I'm having with only 1 device attached)

 

No, my Xbox One is not on Instant On mode. I found that it conflicted with getting achievements, so the Xbox One is in Power Saving Mode (? the option to switch it off completely)

Share this post


Link to post
Share on other sites

I still don't trust the R1 enough to put all my devices through it. (considering the trouble I'm having with only 1 device attached)

 

More than likely the whole reason for your issues is due to an awkward and improper setup. The R1 is designed to control your entire network and should be placed as close to the front of the line as possible.

 

The correct way would be modem in bridge mode (or get a stand alone modem if possible) connected to the R1, then the switch and everything connected to the R1 or the switch.

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

 

It's almost certainly double NATing caused by using 2 routers and improper settings/communication between them. Since you don't trust the R1 to control your devices, the advice that I would give in a 2 router setup may affect the other devices that are not connected to the R1.

 

Are you port forwarding on the R1 as well as using UPnP? That would be the only reason I could think that you're getting that issue when reserving it an IP.

 

If you're lucky this may work without changing anything else: Disable the Geo-filter, then hard turn on and off the console - do you have an open NAT? If so then just enable the Geo-filter and game as normal.

Share this post


Link to post
Share on other sites

could this be you are leaving the geofilter enabled for your Xbox One service on the R1?

 

i had a similar thing when i first got the R1 where normally on boot up of my Xbox One i would have an open NAT but now it was always moderate. disabling the service for my xbox one when finished for the night solved my problem and i always have an open NAT as long as i untick enabled for my Xbox One service on the R1 when i'm finished.

 

just a thought...

Share this post


Link to post
Share on other sites

Hi, if i'm reading it correctly you have an 8 port switch between your R1 and the modem? Could you not swap them round as you are defeating the purpose of the built in hyperlane and congestion control otherwise.

 

Is your Xbox set to instant on mode? If it is, this could be the reason as i found i had a similar problem. Instant makes the Xbox try to hold ports open all the time it is on, which i'm guessing the router does not like. By resetting the Xbox you are reopening the ports. I have since turned mine to power saving mode and i have not had that problem since.

 

This.

Share this post


Link to post
Share on other sites

Thank you for your reply.

 

I have too many other devices and I only want the Xbox One on Netduma. I only need the geofilter feature. I still don't trust the R1 enough to put all my devices through it. (considering the trouble I'm having with only 1 device attached)

 

No, my Xbox One is not on Instant On mode. I found that it conflicted with getting achievements, so the Xbox One is in Power Saving Mode (? the option to switch it off completely)

 

I have 4 xbox ones and about 30 devices going through my Netduma, I was going to suggest instant on as being a problem, but since it starts up from off i can't see why you should need to reboot. I will vouch for the Netduma as doing a great job on QOS/congestion control and for hyperlane traffic for gaming. see if it fixes your issue.

Share this post


Link to post
Share on other sites

 

Hey, welcome to the forum!

 

It's almost certainly double NATing caused by using 2 routers and improper settings/communication between them. Since you don't trust the R1 to control your devices, the advice that I would give in a 2 router setup may affect the other devices that are not connected to the R1.

 

Are you port forwarding on the R1 as well as using UPnP? That would be the only reason I could think that you're getting that issue when reserving it an IP.

 

If you're lucky this may work without changing anything else: Disable the Geo-filter, then hard turn on and off the console - do you have an open NAT? If so then just enable the Geo-filter and game as normal.

 

I am not portforwarding on the R1. Just the UPnP.

 

I have the geofilter disabled as default and switch it on/off only when I need to use it (which is very rarely).

 

When I boot the X1, it will show as NAT=Moderate, but when I reboot it NAT=Open. There is something going on in the R1 that I would like to know.

 

I have 4 xbox ones and about 30 devices going through my Netduma, I was going to suggest instant on as being a problem, but since it starts up from off i can't see why you should need to reboot. I will vouch for the Netduma as doing a great job on QOS/congestion control and for hyperlane traffic for gaming. see if it fixes your issue.

 

Yes, I to don't understand why a reboot makes the NAT=Open. I just wished that NAT was Open all the time without requiring the reboot.

 

My Netduma sometimes requires a reboot as well. X1 says NAT=unavailable and the only way to fix it is to reboot the Netduma.

 

I've also heard my Netduma reboot on it's own. Not sure what causes a self reboot.

Share this post


Link to post
Share on other sites

I imagine there is UPnP/port forwarding on the NTD modem/router that is causing conflicts with the R1 as otherwise it would be open every time as the settings are clearly there for it to be open.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...