Jump to content
belly120

UPnP's gone crazy!!! multiple rules being created

Recommended Posts

Ok so this just happened!! Very weird, Duma has been up and running a fair while, setup is solid, wired connections, hyperlane etc etc.

 

Its been solid but suddenly my UPnP table is showing this, my partners ps4 has gone mental and just demanded as many ports to 3074 as possible. we both play on wired connections with reserved IP's for our consoles, no port forwarding rules in place anywhere etc but clearly Duma or Console are not in sync.

 

Any suggestions other than a reboot which is what i will now do but i don't want the issue just coming back.

 

thanks 

post-6003-0-99410400-1496835071_thumb.jpg

Share this post


Link to post
Share on other sites

I have noticed this as well, UpNp table showing more ports than I think it should be using like the chart does not update when the port is in use.  However I have far less ports showing up but more than I think I should.

Share this post


Link to post
Share on other sites

Just curious do you have instant-on enabled or energy saving? I've noticed instant on constantly running sometimes doesn't release the ports.

Share this post


Link to post
Share on other sites

Ok so this just happened!! Very weird, Duma has been up and running a fair while, setup is solid, wired connections, hyperlane etc etc.

 

Its been solid but suddenly my UPnP table is showing this, my partners ps4 has gone mental and just demanded as many ports to 3074 as possible. we both play on wired connections with reserved IP's for our consoles, no port forwarding rules in place anywhere etc but clearly Duma or Console are not in sync.

 

Any suggestions other than a reboot which is what i will now do but i don't want the issue just coming back.

 

thanks 

 

Definitely take a look at what PharmDawgg suggested above, and make sure you're using the default theme on Chrome or Firefox.

Share this post


Link to post
Share on other sites

Just curious do you have instant-on enabled or energy saving? I've noticed instant on constantly running sometimes doesn't release the ports.

Just to note this happens to me aswell with 2 PS4's on the same network 

Share this post


Link to post
Share on other sites

Just to note this happens to me aswell with 2 PS4's on the same network 

 

Thanks for letting us know, and that goes to XSXS and belly120 as well. I'm making note of it as a potential bug - Fraser and I don't see any real reason why those ports should need to be opened by UPnP. If we get some sort of reason why from other devs, I'll make sure to post it here - otherwise I wouldn't worry about it too much if your gameplay is unaffected.

This one should hopefully be stamped out in DumaOS.

Share this post


Link to post
Share on other sites

Ok so  4 weeks ago I started this thread after my Upnp started creating duplicate rules for my girlfriends ps4.  it was port 3074 playing cod at same time as me.

 

for some reason my old forum account has died, can't access it and its not linked to my email address any more so created a new account.

 

basically its happened again, she now has 6 different port entries on the Upnp table for port 3074 all to random internal ports. the IP address hasn't changed for her ps4 and there aren't any conflicts with port forwarding as we don't have any rules set.  very random. did you have any joy in your investigations?

 

also ps4 SECCA ports are still not playing ball via Upnp, namely port 9308, my ps4 gets it but UPNP doesn't pick it up and bypass to a random internal port for her ps4, any joy on that for duma OS

Share this post


Link to post
Share on other sites

Just curious do you have instant-on enabled or energy saving? I've noticed instant on constantly running sometimes doesn't release the ports.

 

is that on the ps4 or router?

Share this post


Link to post
Share on other sites

ok so ps4 doesn't have a "power saving/instant on" setting, does have the standby mode which we both use and they are both left connected to the web for the purpose of background downloads for updates etc. that could be causing the issue if its not releasing the port but surely its still the same session so would just re use that last port setup anyway??

Share this post


Link to post
Share on other sites

any thoughts on this issue?

 

It doesn't seem like this is causing you any issues in terms of performance, and whilst it looks like it's duplicating ports it has opened a different external port every time. So long as your gameplay is unaffected etc, I wouldn't worry too much. In terms of why this bug has happened, we still aren't sure but DumaOS will solve it no doubt.

 

I'll PM you with a reset password for your old account.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...