Jump to content

Wallynova

Members
  • Content Count

    15
  • Joined

  • Last visited

Posts posted by Wallynova


  1. Hey Fraser,

    I got your PM message.  I was able to download the new firmware from the link provided.  I unfortunately seem to have the same behavior on the new firmware version as I did the old.  Wired devices follow the "Always" congestion rules, but Wireless devices do not. 

    Here is a list of the steps that I took for the process:

    Downloaded the XR1000 1.0.0.53_1.0.53 firmware from the DropBox Link.
    Installed the firmware to the XR1000 router.
    Reset the router to factory default settings.
    Followed the initial setup wizard for automatic configuration.
    Set Wifi SSID and password.
    Set the Speeds to correspond with my Cable internet speeds 460 down/24 up
    Went to QoS and enabled "Always" congestion controls and set 70% down (322Mbps) and 42% Up (10.1Mbps)
    Ran a speed test from my Wired computer.  got 322/10 on results. (followed rules as expected)
    Ran a speed test from multiple Wireless devices on network.  iOS devices, android devices, Dell laptops.  Wifi devices would not follow rules and hit speeds of 400/24.  ignoring the "Always" congestion control rules.

    If we could get someone to attempt to replicate this behavior on their XR1000 or in a lab environment that would be very helpful.  Thanks guys.

     


  2. Fraser you are awesome!

    Thank you so much for all of that information.  That makes perfect since to me now.  From what I have gathered I think most ISPs ignore QoS tags on WAN traffic coming from residential customers.  They do however obey it on leased business lines.  That could of changed over the years though.  I have Comcast Xfinity service and was going to ask a live agent but they are busy today.  Maybe I will get a hold of them and some point and update this thread with that info.  Would be interesting to know.  

    This has been great for getting me back up to speed in the world of networking and seeing what is new and has changed.  Thanks for your support Fraser.  You have a good one  


  3. Hey Fraser,

    the XR1000 with firmware 1.0.0.52_1.0.38 does not have an option for enabling/disabling WMM in Wireless setup or Advanced Wireless settings.  I would hope and assume it is enabled in the code, but doesn't allow you to change it on the interface.   

    The Netgear Nighthawk RAX43 however does allow you to enable/disable WMM in the QoS settings on firmware 1.0.2.72.

    An interesting note, I have noticed that configuring both the Netgear RAX43 and XR1000 QoS congestion controls have the same issue.  The wireless devices throughout the office do not obey the congestion rules, but the wired devices do.  

    I followed your other suggestions as well such as toggling CC never/always, resting distributions, verifying Share Excess enabled, and disabled all Traffic Prioritization rules, which currently is only the DUMA classified games rule.  I also played around with just about every setting I could see, such as disabling AX, toggling settings such as MU-MIMO, OFDMA, disabling 2.4Ghz/5Ghz and trying each band separately etc.  Doesn't seem to change any behaviors on obeying the congestion rules unfortunately. Almost like the integrated Wireless access point in the device gets to ignore the rules entirely.       

    Thanks Fraser

    Perhaps if we could get a dev to try and replicate this in a lab environment for us.  If he can't replicate I would love to know. 

    Thanks 


     


  4. I do not have IPv6, VLAN, or PPPoE enabled. 

    I disabled QoS entirely and ran speed tests from both Wired and Wireless devices.  Disabling QoS allowed both Wired and Wireless devices on the network to get full maximum internet speeds as expected.

    After Enabling QoS back on, Wired devices obeyed the congestion rules set at 70%/42%, but Wireless devices did not.  

    Can anyone verify that congestion control should work for wireless devices on the XR1000 and that this is an isolated incident?

    Thank you for your support Fraser   


  5. Hello I have a XR1000 running firmware 1.0.0.52_1.0.38.  I have upgrade to this version and did a factory settings reset of the device.

    My maximum internet speeds have been set properly in the device at 460Mbps/24Mbps.

    I have set congestion control to "Always" and have download set to 322mbps(70%) and upload set to 10.1mbps(42%).

    When I run a speed test from a Wired LAN computer, the computer will obey the congestion control rule properly.  

    However, when I run a speed test from a Wireless device, it will not obey the set Upload congestion control rule and will use all 24Mbps of the upload speed and cause buffer-bloat on the network.  I have tested this from an IPhone 8 and a Dell laptop.  Both devices support WMM QoS.  Both devices are connected to the 2.4Ghz band and are identified properly in the DUMA Device Manger (Phone and laptop)  

    Wireless settings are set at default except for setting a SSID and password.

    Thank you for your support.


  6. AH HA! Newfie is exactly right! 

    When you are selecting "Wireless Type" on the list you are selecting from the 3 different WMM Multimedia traffic types! Voice/gaming, Video, or best-effect(normal/default).  of course this would only apply if your device was a wireless device that supports WMM.  in my case my device is a hard-wired PC. I feel like the wording should be updated in that section of DUMA to focus more on letting your know it is for WMM QoS.

    There is only ONE question that remains! :

    What the heck is that "Apply to WAN" check box doing? 

     

    Thank you guys for finding all of this stuff out for me.  I hope you guys have a happy Holidays :) 

     

     

     


  7. Thank you Fraser for the quick response

    You have answered all of my questions for me.  Do you mind going into a little more detail as to why you would pick "Apply to WAN" when prioritizing traffic for a wireless device?

    I could understand if it said "Apply to WLAN" instead of "Apply to WAN."  I have a Entry-Level network admin background so I can take it. Hit me with all the details.

    Thanks Fraser


  8. Thanks for the quick feedback Liam

    I will do my research for each VoIP application so that I can prioritize those destination ports in the rules.  I was curious to know if DPI(Deep Packet inspection) would be able to detect all voip traffic regardless of port or application and prioritize those packets in that manner with some type of rule.  Wasn't sure if DPI technology was quite that advanced yet or not.

    As to my other questions I would like to focus on:

    1. "Wireless Type" (Normal, Video, Gaming/Voice) selection during the traffic prioritization rule creation.  What do these selections do exactly?

    2. "Apply rule to WAN" check mark box.  what does that do? (this option is at the very end of the rule creation wizard)

    3. I noticed that I can select an individual device when creating a traffic rule, but i can't select "All Devices" like how the DumaOS Classified games rule was created.  Is there a way I can say "All devices" and then specify a destination port? That would be nice.

    Thanks guys


  9. I have a XR1000 with firmware version 1.0.0.50_1.0.36

    During the process of creating a prioritization rule, the wizard will ask you to select a "Wireless Type"

    Normal (default)
    Video
    Gaming/Voice

    It will also ask if you would like to Apply the rule to WAN (off by default)

    I have been unable to find details to help explain what impact these options will have to the rule being created.  Can someone please help explain what these options will effect?  Thank you

     

    The goal I am achieving:

    The default DumaOS classified games rule has been working very well at identifying game traffic on the network.  I would also like to create a prioritization rule to prioritize all VoIP software for all devices on the network as well.  Such as Discord, teamspeak, xbox app party chat, etc.

    Thank you guys for your help and support. 

     

×
×
  • Create New...