Jump to content
tatman

so many errors and i have to keep rebooting to forward ports to my web server

Recommended Posts

I am having issues with the router blocking traffic to my website. I am on the newest release of duma os on the R1.  here is a log file of all the errors on the router. I am not sure what is causing the issues i have port 80 forwarded to my web server and it works for about an hour and then crashes the connection to the site.  Trying to access the site changes to You don't have permission to access /UI on this server. which there is no UI on the server it changes the .com to .com/UI . it works on an internal network but not an external.. 

 

Thanks to anyone who can help!!

log-1550003258715.txt

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

To start with your normal web browsing uses port 80 which is now being forwarded to your server so I'm not sure if thats the best idea. Are you using something like Apache? If so I'd suggest looking at their support for the specific message you're getting and see what they suggest

Share this post


Link to post
Share on other sites

Yes I am using apache. I have already looked for it in all of the support I could find and have not been able to find an answer.

Thanks for your reply! 

It is also in the setup for accessing the web server outside of the lan is to forward TCP port 80 to the ip address of the physical server which I have dona and was working for a few weeks and now it only works if i reboot the router about every hour. Were you able to look at the log files at all Fraser?

Share this post


Link to post
Share on other sites

Are you using the internet/downloading for that first hour that it works? It looks like you may be switching between IPv4 and IPv6, disable IPv6 in LAN and WAN Settings and see if that helps.

I'd suggest making a post here as well: https://www.apachelounge.com/viewforum.php?f=2 as they may be better able to help

Share this post


Link to post
Share on other sites

Yes I am we cut the cord so we are streaming all the time and I also have another server running plex as well with no issues 

And I will give that a try thank you 

 

Share this post


Link to post
Share on other sites

I'd see if you could start up the server before you go to bed so theres not much traffic happening on the network and see how long it lasts as may be related to internet usage. Is it disabled for WAN as well? I'd check your ISP hub also and disable IPv6 there as well

Share this post


Link to post
Share on other sites

yes it is disabled on wan as well and my isp hub is just a pass through i have a static ip with them I am on a Fiber network of 500 Mbps up and 500 Mbps down so i don't think that will be an issue. thanks though i will give it a try. whats weird is it works on the local network just not outside the network and i have already called the isp to see if there was anything on their end and everything looks good 

Share this post


Link to post
Share on other sites

I Believe I found the problem I have a western digital My book on the network that had its remote access turned on which in turn was redirecting traffic on port 80 through upnp of the router even though I have the ports forwarded thru to the server.  I have disabled the remote access to the drive and all is well.

thank you again for all your help and speedy responses 

and about the logs even though everything is failing and timing out i shouldn't worry?

 

Share this post


Link to post
Share on other sites
9 hours ago, tatman said:

I Believe I found the problem I have a western digital My book on the network that had its remote access turned on which in turn was redirecting traffic on port 80 through upnp of the router even though I have the ports forwarded thru to the server.  I have disabled the remote access to the drive and all is well.

thank you again for all your help and speedy responses 

and about the logs even though everything is failing and timing out i shouldn't worry?

Super interesting, thank you for letting us know your solution! You shouldn't worry about the logs, that's standard behaviour and doesn't affect performance. (If any other router showed you their logs you'd see the same fail / time out messages :) )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×