Jump to content
George

R1 on DumaOS 1.3 can’t handle IKEv2 VPN traffic

Recommended Posts

Hi everyone,

I have been trying to use my VyprVPN client on my iOS devices but it seems that my R1 after upgrading to DumaOS (now running DumaOS 2.1.3.29) can’t handle IKEv2 VPN traffic. If I remove the R1 from my home network setup everything works fine. If connect through a different WiFi or through my cellular 4G connection again there is absolutely no problem.

Additionally I tried accessing the very same VPN servers through the OpenVPN iOS app that uses the openVPN protocol and it works fine with my R1. 

Is this a known issue with R1 on DumaOS? 

 

Best regards, 

Georgios

Share this post


Link to post
Share on other sites
57 minutes ago, Netduma Fraser said:

Currently the VPN Hybrid only supports Open VPN, we have not yet implemented additional support for other protocols. So you'll need to use the OpenVPN protocol from Vypr in order to connect successfully.

Hi Fraser,

Applogies if I am missing something, but VPN hybrid is the feature when DumaOS connects to a VPN server and directs some selected services traffic through the VPN channel whereas gaming services access the internet as usual correct?

if so I am not talking about that. I haven’t setup any VPN configuration on my R1 nor I want to do that. I have a VPN client installed locally on my iPhone/iPad and want to connect via IKEv2 to a VPN server. That is irrelevant with the router’s hybrid VPN feature right?

Share this post


Link to post
Share on other sites
10 hours ago, Netduma Fraser said:

Yes that's right. My apologies, I understand now. Can you disable QoS completely in Anti-Bufferbloat settings and see if that resolves it please

I tried setting anti-bufferbloat to “never” but it didn’t make any difference. 

 

 

Share this post


Link to post
Share on other sites

Hi George - there's actually a completely disable QoS setting, which is in Anti-Bufferbloat's advanced options. Click the 'burger' menu icon in the top left corner of the Anti-Bufferbloat panel to access it. Then check the option to disable QoS and click proceed at the warning message. Then see if that improves things for you.

Share this post


Link to post
Share on other sites
16 hours ago, Netduma Admin said:

Hi George - there's actually a completely disable QoS setting, which is in Anti-Bufferbloat's advanced options. Click the 'burger' menu icon in the top left corner of the Anti-Bufferbloat panel to access it. Then check the option to disable QoS and click proceed at the warning message. Then see if that improves things for you.

Ah I found the setting thanks for the info, unfortunately it didn’t resolve the issue though. 

Share this post


Link to post
Share on other sites
6 minutes ago, Netduma Admin said:

Is UPNP enabled in your network settings?

And did this all work fine through the R1 on pre DumaOS?

Do you have any port forwarding rules setup?

Yes UPNP is enabled. No manually defined rules, I can only see the ones that are automatically created because of UPNP. 

 

Yes in the older firmware it used to work fine. 

 

Merry Christmas by the way! ☺️

Share this post


Link to post
Share on other sites
6 hours ago, Netduma Admin said:

Very odd - so to make sure I understand, you can get internet through your VPNd device through your modem, and also through the R1 pre-DumaOS. But with DumaOS it won’t work? 

Merry Christmas to you too!

Indeed it is quite strange! So my iOS devices (iPhone and iPad) have proper internet access through my DumaOS R1 WiFi however they can’t connect to the VPN though the VPN app installed locally on those devices that uses the IKEv2 protocol. However if I remove the R1 from my network setup they connect to the VPN with absolutely no issues at all. Pre-DumaOS everything worked fine, I never had to remove my R1 from my network setup to allow my iOS devices to connect to the VPN through that very same local VPN app

Share this post


Link to post
Share on other sites
3 hours ago, Netduma Fraser said:

Pre-DumaOS did you have turbo mode disabled by any chance? If so do you remember if enabling it prevented the VPN working correctly?

Is turbo mode disabled by default in the pre-dumaOS firmware? If so probably it was disabled. Not 100% sure though 

Share this post


Link to post
Share on other sites
On 12/28/2018 at 12:55 AM, Netduma Fraser said:

Yes it was disabled by default and on DumaOS it's enabled by default. Could you as an experiment, downgrade, check with turbo off, does it work? Enable turbo then does it work?

Sure thing I can give it a shot. Could you help me locate the turbo mode setting on DumaOS? 

 

 

Share this post


Link to post
Share on other sites
19 minutes ago, Netduma Fraser said:

Theres no option to disable it on DumaOS, its built in. So by downgrading where you can toggle it and testing it there that should enable us to see if turbo mode is the issue

Ah I see. 

Share this post


Link to post
Share on other sites
38 minutes ago, Netduma Fraser said:

Theres no option to disable it on DumaOS, its built in. So by downgrading where you can toggle it and testing it there that should enable us to see if turbo mode is the issue

Hi Fraser, 

since I have been in touch with my VPN provider’s support team about the very same issue, I inquired if they can supply you with a temp testing VPN account to perform the test from your side, as I am unable to downgrade my router and to the required testing. 

 

 

Share this post


Link to post
Share on other sites
37 minutes ago, Netduma Fraser said:

If I may ask why are you unable to downgrade? Does it not work for you? 

If you do get those details could you email them to [email protected] please and link this topic as well so it can be tested by a colleague in the new year.

No technical restriction of any sort, it’s just that I don’t have the capacity at the moment to get into a downgrading/re-upgrading loop. 

 

Of of course I will forward all relevant info. Thanks a lot for the help!

Share this post


Link to post
Share on other sites

I am with you bro.. Same thing... Fraser, you know me, I used to email you about Netduma R1 QoS bug/etc I am profoundly deaf person and I gave you big feedback or hint.

i'm sure that turbo mode was off before I upgrade R1.. but I did not use factory reset on R1 nor on Netduma R1...

I turn QoS off, Anti Bufferbloat off, etc It is worse than original R1, I used to watch 4K, now its 50/50, I had to restart R1 - it seems that longer the stay, the more bug overlap.

 

Now I cannot use my VPN with R1 now, with different router, BUT VPN works when I use OPEN REACH modem only and straight to R1 with PPPOE (username and password vdsl) The VPN works.

I believe it is do with WAN address setting because I swapped the Open reach as primary then to R1, it works now.

I had to change R1 to secondary because of PPPOE username/password give me too low speed (40-50MBps max)

I used technicolour vdsl built in as primary and secondary as R1 - it give me full speed of 90Mb/s but no VPN for phone, but VPN works on PC...

NOTE: I am not using R1 as wireless, the BT hub is plugged in with R1 always for 5G/non 5G wireless.

You need to sort QoS stuff out and device per bandwidth maximum each, not share - it confuse %%%% out of me, For example I want to limit ONE device to 1mb/s and while others is normal. because Im giving one user next door very limit bandwidth speed.. its like I limited it to 1Mb/s and the colour goes green, but when I move an user to red line, its giving them full speed of 100mb/s Wrong. I believe in order. Ping/traffic order (circles) and red should be at lowest, limit speed. (not increasing bandwidth showing wrong)

In old R1:-

VPN both works (PC/Mobile apps) 
VPN feature (built in) - it works 50% of it Some OpenVPN config was old some works - that's fine.
When not in gaming, I can access to PC (internet/R1 access) while PS4 downloading. (LAN)
When in gaming, I can access to PC (Internet/R1 access while PS4 downloading and gaming. - the way it should be.

In new R1:-

VPN PC works (both routers way methods see above)
VPN mobile does not work when R1 is not primary (again different method)
VPN feature (built in) it works pretty well, but again some OpenVPN config some is error some is old, which need to find working one - managed to get 70Mbps out of it.
When not in gaming, I can access to PC (internet) but NOT R1 while PS4 is downloading. I had to PAUSE PS4 downloading to access R1!
When in gaming, I cant access to PC - while PS4 is downloading - terrible.

When I had to TURN QoS OFF and setting:-

When not in gaming, I can access to PC (Internet/R1 access) while PS4 downloading not slower below.
When in gaming, I can access to PC (Internet/R1 access) while PS4 downloading, just a bit slower
When PS4 not in anything to downloading, i.e watching TV 4K, I can surf internet PC/R1 access.

With QoS - this is nothing like old R1
 

Now right now. I'm trying to watch 4K while PS4 is not on. it's 1080p mode. I looked at this stuff below.. so many errors, I fiddle to try to get it back in the game, I test wifi  it dropped to 40mb/s when I switch to 5G it was 55mb/s.  QoS is off. 

It does not make any sense because I tested PS4 testing network, PS4 reported 69Mb/s that's fast. The TV is hooked up with ethernet. So it seems it's either it being fed up looping error or filling error or whatever it is Memory loss or, because once I switch r1 as secondary from PPPOE (primary) it was 100mb/s internet, but then I noticed few weeks later it become slower.. So

I don't really want to re-config all again with devices setup names etc etc etc. its lots of hard work.

Orginial is so much better BUT I like new R1 so you just need to match it. 
UI mobile is a must, either you bulid a phone app to support R1 or all other router. Make no difference if you said not possible, because its same Netduma OS, same input all router responds. just different hardware.

I hope I can helpful with this. R1 user since Destiny The Taken King.

Now I don't know if I should go back to old R1 but I am willing thinking its do with WAN dns need to communicate to primary which make vpn mobile might work.

 

Sat Feb  9 15:16:10 2019 daemon.warn odhcpd[739]: Failed to send to ff02::1%br-lan (Operation not permitted)
Sat Feb  9 15:09:06 2019 user.info com.netdumasoftware.qos: Using disabled(NOP) QoS subclass

 

Share this post


Link to post
Share on other sites

Hey, welcome to the forum!

It sounds to me like your issues stem from the fact that all your devices are not connected to the R1. Hence they're causing local congestion that the R1 can't control and it's being pushed out by other devices. There is no lock bandwidth option so if you wanted to limit it you'd have to untick share excess to limit them to the 1mbps you set.

Share this post


Link to post
Share on other sites

That unticked shared excess I forget to mention as well. That applied as well.

It is connected well. I don't think I did not explain clearly, because I do more practical work than theory or thesis... 

I do have degree on networking, server, redhat, cisco, even running windows 2018 server, I am website developer for non profit disability charity. :)

I can see there is bug on netduma r1, as what I do is memory served compare to old R1. That's all I am trying to help you and feedbacks to improve netduma R1.

If I invite you to my house and show you all the work I have done, you would see more clearly then I can explain it to you. Sorry for me being profoundly deaf and for lack of English.

Thanks and yes, your forum has greatly improved!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×