Jump to content
Azlios

QoS isn't working at all for Rocket League on PC

Recommended Posts

I can be happily playing Rocket League on PC with a solid steady 24 Ping and then as soon as the Fire TV is turned on I have the worst lag ever with my ping fluctuating to over a 100 and then back down.

I've tried literally everything I can to fix this, I've tried manually forwarding the required ports for Rocket League on PC, it had no effect. I've reclassified my PC on the duma as an xbox and it didnt change anything. I tried giving the Fire TV 0 priority in the flower but it literally changes nothing as it continues to pull absurd amounts of bandwidth. The only way I've found to stop it causing me to lag is to turn off share excess and give it .01Mbps of internet up and down. As you can understand this isn't ideal as I immediately get moaned at that the TV is now buffering.

any help would be appreciated.

 

Edit - its all PC games actually. getting the same on Siege as well.

Share this post


Link to post
Share on other sites
14 minutes ago, boasty said:

Are you using ppoe , i know there might be problems using qos until they sort it out. If you are not using ppoe  I would try a factory reset as this sorts it out sometimes.

Been told I don't need PPOE when using a BT Smart Hub. Any time I've tried to use PPOE on the Duma with the Smart Hub I couldn't get a connection.

Share this post


Link to post
Share on other sites

I assume you're on dumaos? Add your own ports to hyper traffic for UDP 7000-10000 and it'll pick up RL and turn on QoS for you when you join a game

 

I know their port forwarding rules say ports 7000-9000 but it uses up to 10000

 

I've spent ALOT of time trying to find a way to make it work, this is the only way I got

Share this post


Link to post
Share on other sites

I have tried this but I feel like I'm doing it wrong, do I put both numbers into both the source port and destination port boxes or do I only put 7000 in the source port and 10000 in the destination port?

Share this post


Link to post
Share on other sites

What have you set your Anti-Bufferbloat % to? I recommend you set them to at least 70%, if not lower, to prevent congestion from building.

Also, are you gaming wirelessly? It's possible this is a wireless issue caused when the Fire TV starts using data

Share this post


Link to post
Share on other sites
55 minutes ago, Netduma Admin said:

What have you set your Anti-Bufferbloat % to? I recommend you set them to at least 70%, if not lower, to prevent congestion from building.

Also, are you gaming wirelessly? It's possible this is a wireless issue caused when the Fire TV starts using data

sliders at 70%, playing on TP-Link TL-PA9020PKIT power line adaptors.

Share this post


Link to post
Share on other sites

So done some digging into this with PingPlotter, definitely something up with the fire tv.

Max Down - 80Mbps

Max Up - 20Mbps

I actually get these speeds to, averaging between 76-79mbps and 17-19Mbps 

I hope this image makes sense to you guys, tried to make it as simple as possible.

FireStickSucks.jpg

Share this post


Link to post
Share on other sites

Thank you - this is a very clear diagram. As you found, looks a lot like it's down to the Firestick.

Two questions: 

  1. The Firestick is 100% connected to the router, rather than the modem?
  2. What are your QoS settings? Could you take a screenshot of your entire QoS page so we can check that everything looks ok? 

Thanks.

Share this post


Link to post
Share on other sites
55 minutes ago, Netduma Admin said:

They all look great. Could you disable IPv6 in Network Settings for both LAN and WAN if you have not already done so please.

Does that improve things? It's very odd that Fire TV is causing this many problems

IPv6 has always been turned off as i've never known how to properly use it.

I also found this, my amazon tv doesn't have the wifi direct thing though

 

Share this post


Link to post
Share on other sites
21 minutes ago, Netduma Fraser said:

Very good catch, that could be it, did you use a WiFi analyser to determine the WiFi direct channel wasn't available? 

Also could you disable DumaOS Classified Games please and then try RL & Fire TV again, does it still suffer the same issue?

Yeah, I have no wifi direct thing as its the wrong type of fire tv. 

 

I've tried before with classified games turned off and it didnt help.

Share this post


Link to post
Share on other sites

I just have the standard st up.

Wall socket > BT Smart Hub > Netduma > Everything

 

Not really sure what’s going on with it. Thinking I might just replace the amazon tv with another chrome cast.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×