Jump to content
xr450owner

XR450 Wi-Fi Calling Being Blocked

Recommended Posts

I ensured cellular data is turned off which got me thinking. That toggle is worded cellular “data” and not necessarily cellular “voice” as well.  I can confirm data does not work with it turned off along with WiFi. But does that toggle truly disable all carrier functionaity on the device? The rabbit hole grows deeper. Lol. 

Share this post


Link to post
Share on other sites

airplane mode should mean all radios shut off , otherwise you may down many airplanes or kill people in the hospitals. lol.

if you toggle wifi on it should not toggle on any other radios, so if call works, wifi calling is working .. unless iphone sneaks on the celluar radios? which could be deadly. i know in galaxy its most definitely off

it could be just that whatever the phone uses to detect wifi calling is having an issue with the 450, so it's just not showing you that message , but it's actually on?

Share this post


Link to post
Share on other sites

I totally agree, airplane mode should shut everything off, except if you turn on WiFi and Bluetooth manually. But on iOS, i am not convinced it does. I have no way of ensuring the device is using Wi-Fi calling, except for that logo. But I dont think that logo means it is for sure using wifi calling. For when I was able to make a call on airplane mode, i believe it was cellular because the voice quality sounded muddy like on 4G and not crystal clear like when on Wi-FI calling. All the other times my phone attempts to call on Wi-Fi, its straight up call failed, like its being blocked. 

Also, I have a Galaxy S6 and it appears to be working just fine with Wi-Fi calling on the XR450. More variables to add to the madness.

Share this post


Link to post
Share on other sites
2 minutes ago, xr450owner said:

I totally agree, airplane mode should shut everything off, except if you turn on WiFi and Bluetooth manually. But on iOS, i am not convinced it does. I have no way of ensuring the device is using Wi-Fi calling, except for that logo. But I dont think that logo means it is for sure using wifi calling. For when I was able to make a call on airplane mode, i believe it was cellular because the voice quality sounded muddy like on 4G and not crystal clear like when on Wi-FI calling. All the other times my phone attempts to call on Wi-Fi, its straight up call failed, like its being blocked. 

Also, I have a Galaxy S6 and it appears to be working just fine with Wi-Fi calling on the XR450. More variables to add to the madness.

in the States we have this thing called e911.  Its a way for emergency services to locate a cell phone's GPS position.  I guess you Brits have something similar.  I would imagine the radios cannot be turned off by airplane mode, because how else would the man be able to zoom in on your position when you're being all nefarious?  Maybe whatever is left on for those purposes is all wifi calling needs to validate a call?  it's possible?  It's also possible that @xr450owner just exposed an issue with iphone radios 

Share this post


Link to post
Share on other sites

Recent troubleshooting efforts with XR450:

UPnP turned on, Disable SIP ALG checked, Disable IGMP checked, no port forwarding or triggering enabled, no QoS enabled.

iPhone 7, iOS 11.4.1, Verizon: Wi-Fi calling not working. Turning off cellular data still allows me to make calls. Turning Airplane mode on, with only Wi-Fi enabled, does not allow Wi-Fi calling, icon does not even pop up even though Wi-Fi calling option is enabled on device. Seems to be blocked.

iPhone 7 Plus, iOS 12.1.1, AT&T: Had Wi-Fi calling reset around noon by carrier. Turning off cellular data still allows me to make calls. Wi-Fi calling intermittent, but can't confirm it's actually Wi-Fi calling and not cellular. Turning on airplane mode with only Wi-Fi enabled, Wi-Fi icon popped up once and I made a call, but sound quality sounds like cellular. Initially worked with Airplane mode on, but now will not. Seems to be blocked. 

Samsung S6, 7.0, Verizon: Wi-Fi calling appears to be working. Put device in airplane mode. Turned only Wi-Fi on and was able to make calls. Cellular option isn't even available when airplane mode is turned on, as should be the case. 

Share this post


Link to post
Share on other sites

Testing performed with TP-Link Archer C8 router:

So now I am 100% convinced it's an issue with the Netgear router. Plugged in my old router and connected both iPhone 7 and 7 Plus. Put both in airplane mode. Both phones immediately popped up with the Wi-Fi icon and I was able to make calls, no blockage at all. Both had the clear sound quality associated with Wi-Fi calling. 

I love the XR450 for everything but it's inability to support Wi-Fi calling on iPhones. I will be forced to go back to my TP-Link for now. Can any admins confirm this issue will be fixed anytime soon with Netgear?

Share this post


Link to post
Share on other sites

Disable Port Scan and DoS Protection: unchecked

Default DMZ Server: unchecked

Respond to Ping on Internet Port: unchecked

Disable IGMP Proxy is checked

Nat Filtering is set to secured

MTU Size 1492 (PPPoE)

Disabled SIP ALG unchecked

Hope that helps.

Share this post


Link to post
Share on other sites

Finally got around to testing suggested settings. I updated to the latest firmware (2.3.2.40) and tested @Killhippie settings. Still not working. :(

My return window closes this week so I’ll be forced to return the router. Was hoping to keep for the geo filter feature but no WiFi calling is a killer. 

Share this post


Link to post
Share on other sites
18 hours ago, xr450owner said:

Finally got around to testing suggested settings. I updated to the latest firmware (2.3.2.40) and tested @Killhippie settings. Still not working. :(

My return window closes this week so I’ll be forced to return the router. Was hoping to keep for the geo filter feature but no WiFi calling is a killer. 

I'm sorry to hear that. WiFi calling is something that should be addressed in the future - there's a lot of exciting features on the horizon. As Fraser said though, since these kinds of features are designed by Netgear, we have no idea when the release date would be for any potential fix. It does seem like we've reached the bottom of the barrel for solutions here, so hopefully this issue will be solved sooner rather than later!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×