Jump to content
Zippy

Odd Geo Filter Behavior

Recommended Posts

   Hello everyone!  Ive been having some strange things happen while playing Halo5. With the geo filter enabled and set to strict everything works as it should. But after about 5 games or so the filter seems to quit working. Then I start to make connections to servers outside my filter range. Its very strange. I also have other issues.. When I had my ASUS router hooked up it would tell me what ports info was being sent and received on. The XR500 only shows 3074 UDP. Is this normal? Im just wondering why I don't see other ports other than the 3074 UDP. With my ASUS I would see other ports pop in like the ones XBOX Live would show.. This maybe no big deal but found this strange as well. I am currently using UPnP. Should I be port forwarding ports instead on my XR500 over UPnP? Once in awhile while playing a game I will notice the game played very odd. When I looked the UPnP showed nothing. So I was wondering if UPnP had quit working as well..

I am running on the most current firmware for the XR500. And maybe I have something set wrong. Which is very possible. Just wanted to get some thoughts what might be going on. If any other info is needed just let me know. Thanks everyone! I do love this Netduma OS. 

Zippy.

Share this post


Link to post
Share on other sites

Hi Zippy,

The Geo-Filter not showing after 5 games - that's a very strange one. Are you zoomed in on the map? Is it possible a server is appearing outside of your range? If you could take a screenshot of your Geo-Filter page and post here that would be very helpful, so we can check the settings are ok.

As for UPNP, do you have an Open NAT on your console? And how is your network setup? For example, does it just go Modem->XR500, or are there any other devices in this setup?

Thanks.

Share this post


Link to post
Share on other sites

Thank you for the reply. I will take a few screen shots and post back here.. Am I suppose to be zoomed in?  I live in the US and there is two servers really close to each other. Ones in Iowa and the other in Chicago IL. So I was wonder because they were so close might be the cause. The sad part is the one server which is the Chicago IL gives me the best pings but also has  very severe lag spikes. Any other server I hit is much more consistent in the US. So I have been trying to block the Chicago IL server. I actually had reached out to Josh from 343 and he explained to me what takes place when a lag spike is detected on there server hosting there game. He explained that when a lag spike is detected ones upload speed is throttled down to about nothing and slowly brought back up until another lag spike is detected. Which I found very interesting.. At least it explains why when I hit that server the game performed very poor for me.. 

As for UPnP I do have an Open Nat on my Xbox One. I just found it strange that I never would see any other ports in the pooling list other then 3074 UDP..  My network setup is cable modem to the XR500 thats it nothing else is connected between the two.. But to be fair with all the issues a lot of cable modems are having I sometimes wonder if I have a bad modem. And that it might also be the cause to some of these lag spikes and possible effecting the geo filter.. Most of the big cable providers around here have issues they are still sorting out with the DOCSIS 3.1. It hasn't gone as smooth as they would have liked.. Again thank you for your time I greatly appreciate it.. If you have any suggestions im all ears. I will post a few screen shots tonight.. Thanks again!

Zippy.

Share this post


Link to post
Share on other sites

Zoom out so you can see more accurately what may be happening. It will only open what is requested by the console/game so can't really comment too much on that. If you suspect a faulty modem I would suggest running pingplotter directly connected to the modem and see how stable your ping is.

Share this post


Link to post
Share on other sites

Now this is when things really get ugly.. Here is PingPlotter running pinging google while im playing a game using the RX500.. My next test will be taking the router out of the mix and going directly to the modem.. These screen shots are with the router. Im getting a lot of packet loss just about everywhere..

913373748_Screenshot(8).thumb.png.40d66345640bc5238e3c33dd8cab4e7a.png1544575098_Screenshot(12).thumb.png.d4e87ea77f95049101d615a0b7c304eb.png

Share this post


Link to post
Share on other sites
4 hours ago, Zippy said:

Here's another screen shot of the Geo Filter putting me on a server outside my search radius..

1720216724_Screenshot(17).thumb.png.43d6e400ffb48487e7f75ef547424318.png

This is a whitelisted server, any servers you see with a white circle around them are whitelisted, it is normal behaviour for whitelisted servers to be outside your radius.

Share this post


Link to post
Share on other sites

And they are either whitelisted because it's a crucial server (usually an 'authentication server') that your game needs to be able to get you online, or because you have previously added it to your Allow list.

Have you manually allowed them? If not, then it looks like Halo 5 dedicated servers could have dropped into our Whitelist somehow. If you could include any other examples of single servers being allowed when in a game that'd be great. Could you also copy and paste their IDs in here too (click on the icon to load the ping graph to see the ID - if Auto Ping is enabled the Ping graph will load automatically).

Nice wallpaper by the way!

Share this post


Link to post
Share on other sites
7 hours ago, Netduma Admin said:

And they are either whitelisted because it's a crucial server (usually an 'authentication server') that your game needs to be able to get you online, or because you have previously added it to your Allow list.

Have you manually allowed them? If not, then it looks like Halo 5 dedicated servers could have dropped into our Whitelist somehow. If you could include any other examples of single servers being allowed when in a game that'd be great. Could you also copy and paste their IDs in here too (click on the icon to load the ping graph to see the ID - if Auto Ping is enabled the Ping graph will load automatically).

Nice wallpaper by the way!

Thank you for your reply. I haven not manually allowed them to my list. Also the strange thing is when I do connect to that server that is outside my search radius it doesn't give me ping readings or ID's. And that is with Auto Ping enabled.  Have any ideas how I could get the ID's for you?  It only happens when I connect to the Chicago IL server. Which is the server just outside my search radius.. The sad thing is if it wasn't for the server in Chicago IL I really wouldn't even need to use the Geo Filter because the rest of the servers perform quite well for me. Again thanks for your time! :)

Zippy.

p.s. Thanks about the nice wallpaper! :)

Share this post


Link to post
Share on other sites
8 hours ago, pollutionblues said:

This is a whitelisted server, any servers you see with a white circle around them are whitelisted, it is normal behaviour for whitelisted servers to be outside your radius.

Thanks pollutionblues! If it is normal to see them outside my search radius is it also normal for me to connect to that server for a game? Currently that is what is happening which is unfortunate..  If you have any ideas im all ears! Thanks my friend! :)

Zippy.

Share this post


Link to post
Share on other sites
15 minutes ago, Netduma Fraser said:

Can you flush the cloud please and see if that resolves it

Hey Fraser! I will give that a try tonight and report back. :) I was always wondering what flush the cloud meant or did ha ha. I will give it a go! Thanks again my friend!

Share this post


Link to post
Share on other sites

Well after flushing the cloud still no luck. I still get servers outside my radius.. Here is one I took a snapshot of with the server ID. But the only way to obtain it was by turning auto ping off and then click on the server Icon.. Just in case you cant read the ID of this server here is the number. 389d9e693ad73237  Thanks!

1328355173_Screenshot(19).thumb.png.78979ce0f18d59cf9d5cd158edeaa166.png

Share this post


Link to post
Share on other sites
10 hours ago, Zippy said:

Well after flushing the cloud still no luck. I still get servers outside my radius.. Here is one I took a snapshot of with the server ID. But the only way to obtain it was by turning auto ping off and then click on the server Icon.. Just in case you cant read the ID of this server here is the number. 389d9e693ad73237  Thanks!

1328355173_Screenshot(19).thumb.png.78979ce0f18d59cf9d5cd158edeaa166.png

In the case of this screenshot, the server shown might be recognised as inside your radius. That little bit of the circle is inside your radius, so if it's anything like the old R1 firmware it will be seen as 'inside' the radius (even though the center-point of the server is technically outside). I know that's counter intuitive, I think that's just a phenomenon of how the Geo-Filter was coded.

I reckon it's potentially incorrectly whitelisted - thanks for providing the ID etc!

Share this post


Link to post
Share on other sites
11 hours ago, Netduma Jack said:

In the case of this screenshot, the server shown might be recognised as inside your radius. That little bit of the circle is inside your radius, so if it's anything like the old R1 firmware it will be seen as 'inside' the radius (even though the center-point of the server is technically outside). I know that's counter intuitive, I think that's just a phenomenon of how the Geo-Filter was coded.

I reckon it's potentially incorrectly whitelisted - thanks for providing the ID etc!

Hey thanks Jack! I was wondering if that was a bit close to the cut off. Sometimes it blocks it and sometimes it doesn't. Just hit and miss.. Im going to try and shrink my search radius a bit more and see if that helps. Im just trying to catch the server right next door to it.. ;) Thanks again for your reply! 

Share this post


Link to post
Share on other sites
9 hours ago, Zippy said:

Hey thanks Jack! I was wondering if that was a bit close to the cut off. Sometimes it blocks it and sometimes it doesn't. Just hit and miss.. Im going to try and shrink my search radius a bit more and see if that helps. Im just trying to catch the server right next door to it.. ;) Thanks again for your reply! 

Ah right, well let's see if that works out - I have a feeling that should work :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×