Jump to content
Kazamario

Can't see Printer on Network (2.4 G)

Recommended Posts

Good Evening,

 

I have a Brother MFC-J6920DW and I can't for the life of me get the Nighthawk to see it. Is there a setting I'm missing? Can someone please give me a hand with getting this device visible on my network? 

 

Thanks,

 

Mario

Share this post


Link to post
Share on other sites

Heya Fraser, 

 

Thx for the prompt reply, I apologize for not including more detail in my OP. I used WPS/AOSS and it connected without issue, and the printer prints off a Connection: OK page with the Network Name, HW Address, Comm Mode, Auth Type, Encryption, and Network Channel metrics. All those fields are filled in. The printer is powered on as well as the laptop, and both are connected to the 2.4 G network but the printer isn't present on the Device Manager section of the UI and it won't print anything in the print queue.

 

Any other suggestions? Should I try the WPS connection again?

 

 

EDIT: Attached two images, one is the network map, and the other is my WLAN report.

post-8146-0-64649000-1530571475_thumb.png

post-8146-0-98733800-1530572280_thumb.png

Share this post


Link to post
Share on other sites

I have encountered some printers are somehow picky about their ip given from the router. I have had success in the past by assigning a printer a static instead of it getting one from the router via DHCP. Give that a try

 

If you need assistance on how to do this let me know

Share this post


Link to post
Share on other sites

Can someone link me the instructions on how to assign a static ip for my printer? Or is that something I do on my printer?

 

 

EDIT: On the Brother MFC-J6920DW, I found it under:

  • Tap wrench icon in upper-right hand corner of the touchscreen
  • Tap "Wi-Fi" icon
  • TCP/IP
  • Tap BOOT Method
    • Select Static
       

I'm going to do a full restart of my network devices and laptop. Will report back.

Share this post


Link to post
Share on other sites

Make sure with windows 10 that in file explorer you click on network and change the network to private.

If you don't do this, Windows won't find any devices on your network at all as windows firewall blocks any workgroup browsing as it assumes all newly connected networks are public until told otherwise.

Share this post


Link to post
Share on other sites

I performed a Network Reset on the printer, and then changed the speed in the Settings > Wireless Setup> Mode: Up to 54 Mbps, and used the Brother Utility program >> Tools > Remote Setup and set a STATIC IP. All is well.

 

Thanks Fraser and Wally!

Share this post


Link to post
Share on other sites

Glad it is working. I have never figured out why but Whenever I have someone who has a issue with printer staying connected, assigning it a static ip works 99% of the time.

 

Btw this isn’t specific to the xr500 or dumaos. I have seen this issue on numerous routers, just wanted to clarify that

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×