Jump to content

Welcome to Netduma Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Who do we contact for a replacement or Refund from Netgear?


  • Please log in to reply
3 replies to this topic

#1
Nighthawk Pro Gaming

Nighthawk Pro Gaming

    [BOT] Latest forum topics from Nighthawk Pro Gaming Community

  • Moderators
  • 346 posts
  • Local time: 03:59 AM

I'm tired of waiting for these promised features that never get fixed.

-VPN was advertised to work and barely does so even with the crappy HMA.

-Ports in reverse order manufacturer's defect that does not effect functionality but does hinder any resale value and frankly should be something you'd recall out of pride.

-GeoFilter hosts disappear or do not appear always

-reboots on it's own

-loses hard-wired connectivity on it's own once a day, wifi still works but hardwired devices do not.

-Daily I still see R-Apps slow to load message and sometimes R-Apps not working.

 

Seriously, do not say contact your place of purchase.  That ship sailed long ago waiting on your BS fixes.  I want my money back or at least a device that works 99.9% of the time without random reboots, dropped connections, and mislabeled ports. 

 

Class actions carry through with 40 people.  I know 5 just in my neighborhood. 

 



View the full article

#2
JOE1305

JOE1305

    Member

  • Members
  • PipPipPip
  • 67 posts
  • Local time: 01:59 PM

 

I'm tired of waiting for these promised features that never get fixed.

-VPN was advertised to work and barely does so even with the crappy HMA.

-Ports in reverse order manufacturer's defect that does not effect functionality but does hinder any resale value and frankly should be something you'd recall out of pride.

-GeoFilter hosts disappear or do not appear always

-reboots on it's own

-loses hard-wired connectivity on it's own once a day, wifi still works but hardwired devices do not.

-Daily I still see R-Apps slow to load message and sometimes R-Apps not working.

 

Seriously, do not say contact your place of purchase.  That ship sailed long ago waiting on your BS fixes.  I want my money back or at least a device that works 99.9% of the time without random reboots, dropped connections, and mislabeled ports. 

 

Class actions carry through with 40 people.  I know 5 just in my neighborhood. 

 



View the full article

 

 

thats bad man. :(. so much money for broken devices. thats why i will never buy any of this routers again. i changed my netduma r1 last week because i still was in warranty. since i bought it i had only issues with it. it didnt reduce lag, it didnt improve shit. in 2 weeks i get another internet provider, if that doesnt help, im gonna sell the r1. its useless



#3
Netduma Fraser

Netduma Fraser

    Tech & Customer Support

  • Administrators
  • 18,592 posts
  • Local time: 12:59 PM

thats bad man. :(. so much money for broken devices. thats why i will never buy any of this routers again. i changed my netduma r1 last week because i still was in warranty. since i bought it i had only issues with it. it didnt reduce lag, it didnt improve shit. in 2 weeks i get another internet provider, if that doesnt help, im gonna sell the r1. its useless

 

If you have an issue make a post and we can help you.


Twitter/Facebook/YouTube/Twitch/Instagram/Steam Group/Discord

 

Official R1 Support Times: 10am - 6pm BST



Official DumaOS/XR500 Support Times: 12pm - Midnight BST



Time Converter

If you're having Settings or Hardware issues with the XR500 please go here and login to get the number for Netgear's 24/7 support line: http://support.netgear.com/


#4
JOE1305

JOE1305

    Member

  • Members
  • PipPipPip
  • 67 posts
  • Local time: 01:59 PM

If you have an issue make a post and we can help you.

 

bro i made a lotta posts here and you guys helped me out with little issues. but i still didnt figure out why i am lagging even with the r1. i did all the stuff you guys advised me with speedtests, pingplotter etc. nothing helped for my jitter spikes issue. in 2 weeks im getting a new internet provider. i will see if it really was an issue with my line. what i read in the forums here, it got alot better for people when they changed their internet providers. i wll let u know. peace






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users